python3-virtualenv-16.1.0-1.1.noarch.rpm


Advertisement

Description

python3-virtualenv - Virtual Python Environment builder

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-virtualenv-16.1.0-1.1.noarch.rpm
Package name python3-virtualenv
Package version 16.1.0
Package release 1.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage http://www.virtualenv.org/
License MIT
Maintainer -
Download size 1.72 MB
Installed size 2.08 MB
virtualenv is a tool to create isolated Python environments.
The basic problem being addressed is one of dependencies and versions, and
indirectly permissions. Imagine you have an application that needs version 1
of LibFoo, but another application requires version 2. How can you use both
these applications? If you install everything into
/usr/lib/python2.4/site-packages (or whatever your platforms standard location
is), its easy to end up in a situation where you unintentionally upgrade an
application that shouldnt be upgraded.
Or more generally, what if you want to install an application and leave it be?
If an application works, any change in its libraries or the versions of those
libraries can break the application.
Also, what if you cant install packages into the global site-packages
directory? For instance, on a shared host.
In all these cases, virtualenv can help you. It creates an environment that
has its own installation directories, that doesnt share libraries with other
virtualenv environments (and optionally doesnt use the globally installed
libraries either).

Alternatives

Package Version Architecture Repository
python3-virtualenv - - -

Requires

Name Value
/usr/bin/python3 -
python(abi) = 3.7
python3 -
python3-setuptools -
update-alternatives -

Provides

Name Value
python3-virtualenv = 16.1.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-virtualenv-16.1.0-1.1.noarch.rpm
Source Package python-virtualenv-16.1.0-1.1.src.rpm

Install Howto

Install python3-virtualenv rpm package:

# zypper install python3-virtualenv

Files

Path
/etc/alternatives/virtualenv
/usr/bin/virtualenv
/usr/bin/virtualenv-3.7
/usr/lib/python3.7/site-packages/virtualenv.py
/usr/lib/python3.7/site-packages/__pycache__/virtualenv.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/__pycache__/virtualenv.cpython-37.pyc
/usr/lib/python3.7/site-packages/virtualenv-16.1.0-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/virtualenv-16.1.0-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/virtualenv-16.1.0-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/virtualenv-16.1.0-py3.7.egg-info/entry_points.txt
/usr/lib/python3.7/site-packages/virtualenv-16.1.0-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/virtualenv-16.1.0-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/virtualenv-16.1.0-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/virtualenv_support/__init__.py
/usr/lib/python3.7/site-packages/virtualenv_support/pip-18.1-py2.py3-none-any.whl
/usr/lib/python3.7/site-packages/virtualenv_support/setuptools-40.5.0-py2.py3-none-any.whl
/usr/lib/python3.7/site-packages/virtualenv_support/wheel-0.32.2-py2.py3-none-any.whl
/usr/lib/python3.7/site-packages/virtualenv_support/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/virtualenv_support/__pycache__/__init__.cpython-37.pyc
/usr/share/doc/packages/python3-virtualenv/README.rst
/usr/share/licenses/python3-virtualenv/LICENSE.txt

Changelog

2019-02-05 - Nicolas Bock <nicolas.bock@suse.com>
- Version bump to 16.1.0:
* Fixed documentation to use pypi.org and correct curl options; :issue:`1042`
* bug fix: ensure prefix is absolute when creating a new virtual
environment :issue:`1208`
* upgrade setuptools from ``39.1.0`` to ``40.5.0``
* upgrade wheel from ``0.31.1`` to ``0.32.2``
* upgrade pip from ``10.0.1`` to ``18.1``
* ``activate.csh`` does not use basename and handles newlines :issue:`1200`
* fix failure to copy on platforms that use lib64 :issue:`1189`
* enable tab-completion in the interactive interpreter by default,
thanks to a new ``sys.__interactivehook__`` on Python 3 :issue:`967`
* suppress warning of usage of the deprecated ``imp`` module :issue:`1238`
* Drop support for Python 2.6.
* Upgrade pip to 10.0.1.
* Upgrade setuptools to 39.1.0.
* Upgrade wheel to 0.31.1.
- Removed patch
- pypa-virtualenv-1189.patch
2018-08-04 - matwey.kornilov@gmail.com
- Add requires: python-setuptools (bsc#1127328)
> virtualenv-3.6 --help
Traceback (most recent call last):
File "/usr/bin/virtualenv-3.6", line 6, in <module>
from pkg_resources import load_entry_point
ModuleNotFoundError: No module named 'pkg_resources'
2018-07-22 - tchvatal@suse.com
- Enable tests, skip upstream failing one
2018-07-20 - mwilck@suse.com
- Fix failure of virtualenv --always-copy (bsc#1102096):
* pypa-virtualenv-1189.patch
2018-02-21 - tbechtold@suse.com
- Add missing Requires for python (bsc#1081707)
2017-03-27 - jmatejek@suse.com
- do not generate HTML documentation for packages that are indirect
dependencies of Sphinx
(see docs at https://virtualenv.readthedocs.org/ )
- move uninstall_alternatives to %postun
2017-03-16 - tbechtold@suse.com
- Merge python-virtualenv-doc.spec into python-virtualenv.spec
2017-03-16 - tbechtold@suse.com
- update to 15.1.0:
* Support Python 3.6.
* Upgrade setuptools to 28.0.0.
* Upgrade pip to 9.0.1.
* Don't install pre-release versions of pip, setuptools, or wheel from PyPI.
- Switch to singlespec approach

See Also

Package Description
python3-virtualenv-clone-0.5.3-1.1.noarch.rpm Script to clone virtualenvs
python3-virtualenvwrapper-4.8.2-2.2.noarch.rpm Enhancements to virtualenv
python3-visitor-0.1.3-1.2.noarch.rpm A tiny pythonic visitor implementation
python3-vispy-0.5.3-2.1.noarch.rpm Interactive visualization in Python
python3-vistir-0.3.1-2.1.noarch.rpm Utilities for filesystems, paths, projects, subprocesses, and more
python3-vobject-0.9.6.1-2.2.noarch.rpm Python package for parsing and creating iCalendar and vCard files
python3-voluptuous-0.11.5-1.2.noarch.rpm A Python data validation library
python3-vtk-8.2.0-3.1.i586.rpm Python bindings for VTK
python3-vtk-8.2.0-3.1.x86_64.rpm Python bindings for VTK
python3-vtk-openmpi-8.2.0-3.1.i586.rpm Python bindings for VTK
python3-vtk-openmpi-8.2.0-3.1.x86_64.rpm Python bindings for VTK
python3-vtk-openmpi2-8.2.0-3.1.i586.rpm Python bindings for VTK
python3-vtk-openmpi2-8.2.0-3.1.x86_64.rpm Python bindings for VTK
python3-vulkan-1.1.99.0-1.1.noarch.rpm Python bindings for the Vulkan API
python3-vulture-1.0-1.1.noarch.rpm Python module for finding dead code
Advertisement
Advertisement