python3-scikit-umfpack-0.3.2-1.3.x86_64.rpm


Advertisement

Description

python3-scikit-umfpack - Python interface to UMFPACK sparse direct solver

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-scikit-umfpack-0.3.2-1.3.x86_64.rpm
Package name python3-scikit-umfpack
Package version 0.3.2
Package release 1.3
Package architecture x86_64
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/scikit-umfpack/scikit-umfpack
License BSD-3-Clause
Maintainer -
Download size 65.42 KB
Installed size 316.26 KB
The scikit-umfpack package provides wrapper of UMFPACK sparse direct solver to SciPy.

Alternatives

Package Version Architecture Repository
python3-scikit-umfpack-0.3.2-1.3.i586.rpm 0.3.2 i586 openSUSE Oss
python3-scikit-umfpack - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libpthread.so.0()(64bit) -
libpython3.7m.so.1.0()(64bit) -
libumfpack.so.5()(64bit) -
python(abi) = 3.7
python3-numpy >= 1.14.3
python3-scikits.example -
python3-scipy >= 1.0.0rc1

Provides

Name Value
python3-scikit-umfpack = 0.3.2-1.3
python3-scikit-umfpack(x86-64) = 0.3.2-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-scikit-umfpack-0.3.2-1.3.x86_64.rpm
Source Package python-scikit-umfpack-0.3.2-1.3.src.rpm

Install Howto

Install python3-scikit-umfpack rpm package:

# zypper install python3-scikit-umfpack

Files

Path
/usr/lib64/python3.7/site-packages/scikit_umfpack-0.3.2-py3.7.egg-info/PKG-INFO
/usr/lib64/python3.7/site-packages/scikit_umfpack-0.3.2-py3.7.egg-info/SOURCES.txt
/usr/lib64/python3.7/site-packages/scikit_umfpack-0.3.2-py3.7.egg-info/dependency_links.txt
/usr/lib64/python3.7/site-packages/scikit_umfpack-0.3.2-py3.7.egg-info/requires.txt
/usr/lib64/python3.7/site-packages/scikit_umfpack-0.3.2-py3.7.egg-info/top_level.txt
/usr/lib64/python3.7/site-packages/scikits/
/usr/lib64/python3.7/site-packages/scikits/umfpack/__init__.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/__umfpack.cpython-37m-x86_64-linux-gnu.so
/usr/lib64/python3.7/site-packages/scikits/umfpack/_umfpack.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/interface.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/setup.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/umfpack.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/version.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/__init__.cpython-37.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/_umfpack.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/_umfpack.cpython-37.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/interface.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/interface.cpython-37.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/setup.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/setup.cpython-37.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/umfpack.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/umfpack.cpython-37.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/version.cpython-37.opt-1.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/__pycache__/version.cpython-37.pyc
/usr/lib64/python3.7/site-packages/scikits/umfpack/tests/test_interface.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/tests/test_umfpack.py
/usr/lib64/python3.7/site-packages/scikits/umfpack/tests/try_umfpack.py
/usr/share/doc/packages/python3-scikit-umfpack/README.rst
/usr/share/licenses/python3-scikit-umfpack/LICENSE

Changelog

2018-12-22 - Todd R <toddrme2178@gmail.com>
- Update to 0.3.2
* replace non-ascii character
* Remove hack for windows
2018-05-24 - toddrme2178@gmail.com
- spec file cleanups
2018-04-19 - toddrme2178@gmail.com
- Update to 0.3.1
* FIX: replace scipy with scikit.umfpack
* setup: require scipy 1.0
* FIX: define Suitesparse_long as UF_long if not defined
* BUG: type Suitesparse_long to be UF_long.
* FIX: revert the int32 type conversion
* setup: set the correct install_requires
* FIX: use explicit bit-width types in UmfpackContext._getIndx()
* BUG: fix UmfpackContext family selection in UmfpackLU.__init__()
* replace suppress_warnings() by warnings.catch_warnings()
2017-07-14 - toddrme2178@gmail.com
- Update to 0.3.0 official release
- Use the scikits namespace package
- Implement single-spec version
- Fix source URL.
2016-01-11 - toddrme2178@gmail.com
- Use proper package name (python-scikit-umfpack)
- Update to 0.2.1 official release
- Implement update-alternatives for scikits/__init__.py
2013-10-24 - speilicke@suse.com
- Require python-setuptools instead of distribute (upstreams merged)
2012-06-03 - toddrme2178@gmail.com
- Clean up spec file
2012-03-07 - scorot@free.fr
- build requires suitesparse-devel instead of umfpack-devel
2011-03-03 - scorot@gtt.fr
- first package

See Also

Package Description
python3-scikits.example-0.1-1.2.noarch.rpm Scikits example and base package
python3-scipy-1.2.1-2.1.i586.rpm Scientific Tools for Python
python3-scipy-1.2.1-2.1.x86_64.rpm Scientific Tools for Python
python3-scipy-gnu-hpc-1.2.1-2.1.x86_64.rpm Dependency package for python3-scipy_1_2_1-gnu-hpc
python3-scipy_1_2_1-gnu-hpc-1.2.1-2.1.x86_64.rpm Scientific Tools for Python
python3-scour-0.37-1.1.noarch.rpm An SVG scrubber
python3-scp-0.13.2-1.1.noarch.rpm SSH scp module for paramiko
python3-scripttest-1.3-6.2.noarch.rpm Helper to test command-line scripts
python3-scrypt-0.8.13-1.1.i586.rpm Bindings for scrypt
python3-scrypt-0.8.13-1.1.x86_64.rpm Bindings for scrypt
python3-scspell3k-2.2-1.1.noarch.rpm A conservative interactive spell checker for source code
python3-seaborn-0.9.0-3.1.noarch.rpm Statistical data visualization for python
python3-selection-0.0.14-1.1.noarch.rpm API to extract content from HTML & XML documents
python3-selectors2-2.0.1-2.1.noarch.rpm Back-ported, durable, and portable selectors
python3-selenium-3.14.1-1.2.i586.rpm Python bindings for Selenium
Advertisement
Advertisement