python3-prelude-correlator-4.0.0-1.4.noarch.rpm


Advertisement

Description

python3-prelude-correlator - Real time correlator of events received by Prelude Manager

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-prelude-correlator-4.0.0-1.4.noarch.rpm
Package name python3-prelude-correlator
Package version 4.0.0
Package release 1.4
Package architecture noarch
Package type rpm
Category Productivity/Networking/Security
Homepage https://www.prelude-siem.org
License GPL-2.0+
Maintainer -
Download size 44.37 KB
Installed size 135.86 KB
Prelude-Correlator allows conducting multi-stream correlations
thanks to a powerful programming language for writing correlation
rules. With any type of alert able to be correlated, event
analysis becomes simpler, quicker and more incisive. This
correlation alert then appears within the Prewikka interface
and indicates the potential target information via the set of
correlation rules.

Alternatives

Package Version Architecture Repository
python3-prelude-correlator - - -

Requires

Name Value
/usr/bin/python3 -
prelude-correlator-core >= 4.0.0
python(abi) = 3.7
python3-libprelude -
python3-netaddr -

Provides

Name Value
python3-prelude-correlator = 4.0.0-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-prelude-correlator-4.0.0-1.4.noarch.rpm
Source Package prelude-correlator-4.0.0-1.4.src.rpm

Install Howto

Install python3-prelude-correlator rpm package:

# zypper install python3-prelude-correlator

Files

Path
/usr/bin/prelude-correlator
/usr/bin/prelude-correlator-3.7
/usr/lib/python3.7/site-packages/prelude_correlator-4.0.0-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/prelude_correlator-4.0.0-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/prelude_correlator-4.0.0-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/prelude_correlator-4.0.0-py3.7.egg-info/entry_points.txt
/usr/lib/python3.7/site-packages/prelude_correlator-4.0.0-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/prelude_correlator-4.0.0-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/preludecorrelator/__init__.py
/usr/lib/python3.7/site-packages/preludecorrelator/config.py
/usr/lib/python3.7/site-packages/preludecorrelator/context.py
/usr/lib/python3.7/site-packages/preludecorrelator/download.py
/usr/lib/python3.7/site-packages/preludecorrelator/error.py
/usr/lib/python3.7/site-packages/preludecorrelator/idmef.py
/usr/lib/python3.7/site-packages/preludecorrelator/log.py
/usr/lib/python3.7/site-packages/preludecorrelator/main.py
/usr/lib/python3.7/site-packages/preludecorrelator/pluginmanager.py
/usr/lib/python3.7/site-packages/preludecorrelator/require.py
/usr/lib/python3.7/site-packages/preludecorrelator/siteconfig.py
/usr/lib/python3.7/site-packages/preludecorrelator/utils.py
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/config.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/config.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/context.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/context.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/download.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/download.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/error.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/error.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/idmef.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/idmef.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/log.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/log.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/main.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/main.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/pluginmanager.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/pluginmanager.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/require.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/require.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/siteconfig.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/siteconfig.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/utils.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/__pycache__/utils.cpython-37.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/plugins/__init__.py
/usr/lib/python3.7/site-packages/preludecorrelator/plugins/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/preludecorrelator/plugins/__pycache__/__init__.cpython-37.pyc

Changelog

2017-10-04 - thomas.andrejak@gmail.com
- Update to 4.0.0
- Rename source prelude-correlator.run to prelude-correlator-tmpfiles.conf
- Clean prelude-correlator.service
- Create python2-prelude-correlator and python3-prelude-correlator
packages since prelude-correlator is python 3 compatible
- Move to Python Singlespec
2017-02-10 - thomas.andrejak@gmail.com
- Update to 3.1.0 (Prelude 3.1.0 released on 14 Sept 2016)
- Remove unnecessary patches (prelude-correlator-main_py.patch)
- Remove unnecessary spool directory
- Spec-Cleaner
2016-09-04 - thomas.andrejak@gmail.com
Remove Selinux since it should be directly in Security:SELinux
2016-05-03 - thomas.andrejak@gmail.com
Initial import
Add patchs :
* prelude-correlator-ez_setup.patch
* Support old setuptools
* prelude-correlator-main_py.patch
* Wrong shebang
Add systemd files because it is a daemon.
Also package SELinux files.

See Also

Package Description
python3-pretend-1.0.9-1.1.noarch.rpm A library for stubbing in Python
python3-prewikka-4.0.0-2.3.noarch.rpm Graphical front-end analysis console for the Prelude Framework
python3-proboscis-1.2.6.0-5.2.noarch.rpm Extends Nose with certain TestNG like features
python3-process-tests-2.0.2-1.1.noarch.rpm Tools for testing processes
python3-proglog-0.1.9-1.1.noarch.rpm Log and progress bar manager for Python
python3-progress-1.5-1.1.noarch.rpm Progress bars for Python
python3-progressbar-2.5-2.2.noarch.rpm Text Progressbar Library for Python
python3-prometheus_client-0.2.0-2.2.noarch.rpm Python client for the Prometheus monitoring system
python3-promise-2.2.1-1.1.noarch.rpm Promises/A+ implementation for Python
python3-prompt_toolkit-2.0.9-1.1.noarch.rpm Library for building interactive command lines in Python
python3-prompt_toolkit1-1.0.15-1.4.noarch.rpm Library for building interactive command lines in Python
python3-proselint-0.10.2-2.1.noarch.rpm A linter for prose
python3-protobuf-3.6.1-5.1.i586.rpm Python3 Bindings for Google Protocol Buffers
python3-protobuf-3.6.1-5.1.x86_64.rpm Python3 Bindings for Google Protocol Buffers
python3-pscript-0.7.0-1.1.noarch.rpm Python to JavaScript compiler
Advertisement
Advertisement