python3-pcp-4.3.1-2.1.i586.rpm


Advertisement

Description

python3-pcp - Performance Co-Pilot (PCP) Python3 bindings and documentation

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-pcp-4.3.1-2.1.i586.rpm
Package name python3-pcp
Package version 4.3.1
Package release 2.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://pcp.io
License GPL-2.0+
Maintainer -
Download size 126.30 KB
Installed size 525.71 KB
This python PCP module contains the language bindings for
Performance Metric API (PMAPI) monitor tools and Performance
Metric Domain Agent (PMDA) collector tools written in Python3.

Alternatives

Package Version Architecture Repository
python3-pcp-4.3.1-2.1.x86_64.rpm 4.3.1 x86_64 openSUSE Oss
python3-pcp - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libpcp.so.3 -
libpcp.so.3(PCP_3.0) -
libpcp.so.3(PCP_3.16) -
libpcp.so.3(PCP_3.2) -
libpcp.so.3(PCP_3.21) -
libpcp.so.3(PCP_3.22) -
libpcp.so.3(PCP_3.6) -
libpcp3 = 4.3.1-2.1
libpcp_pmda.so.3 -
libpcp_pmda.so.3(PCP_PMDA_3.0) -
libpcp_pmda.so.3(PCP_PMDA_3.7) -
libpcp_pmda.so.3(PCP_PMDA_3.8) -
libpcp_pmda.so.3(PCP_PMDA_3.9) -
libpthread.so.0 -
libpython3.7m.so.1.0 -
python(abi) = 3.7
python3 -

Provides

Name Value
python3-pcp = 4.3.1-2.1
python3-pcp(x86-32) = 4.3.1-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-pcp-4.3.1-2.1.i586.rpm
Source Package pcp-4.3.1-2.1.src.rpm

Install Howto

Install python3-pcp rpm package:

# zypper install python3-pcp

Files

Path
/usr/lib/python3.7/site-packages/cmmv.cpython-37m-i386-linux-gnu.so
/usr/lib/python3.7/site-packages/cpmapi.cpython-37m-i386-linux-gnu.so
/usr/lib/python3.7/site-packages/cpmda.cpython-37m-i386-linux-gnu.so
/usr/lib/python3.7/site-packages/cpmgui.cpython-37m-i386-linux-gnu.so
/usr/lib/python3.7/site-packages/cpmi.cpython-37m-i386-linux-gnu.so
/usr/lib/python3.7/site-packages/pcp/__init__.py
/usr/lib/python3.7/site-packages/pcp/mmv.py
/usr/lib/python3.7/site-packages/pcp/pmapi.py
/usr/lib/python3.7/site-packages/pcp/pmcc.py
/usr/lib/python3.7/site-packages/pcp/pmconfig.py
/usr/lib/python3.7/site-packages/pcp/pmda.py
/usr/lib/python3.7/site-packages/pcp/pmgui.py
/usr/lib/python3.7/site-packages/pcp/pmi.py
/usr/lib/python3.7/site-packages/pcp-4.1-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/pcp-4.1-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/pcp-4.1-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/pcp-4.1-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/pcp/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/__init__.cpython-37.pyo
/usr/lib/python3.7/site-packages/pcp/__pycache__/mmv.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/mmv.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/mmv.cpython-37.pyo
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmapi.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmapi.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmapi.cpython-37.pyo
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmcc.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmcc.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmcc.cpython-37.pyo
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmconfig.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmconfig.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmconfig.cpython-37.pyo
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmda.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmda.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmda.cpython-37.pyo
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmgui.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmgui.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmgui.cpython-37.pyo
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmi.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmi.cpython-37.pyc
/usr/lib/python3.7/site-packages/pcp/__pycache__/pmi.cpython-37.pyo

Changelog

2019-03-08 - David Disseldorp <ddiss@suse.com>
- Split out zeroconf, pmda-haproxy, pmda-smart, pmda-prometheus,
pcp2elasticsearch, pcp2json, pcp2spark, and pmlogger_daily_report files
into separate packages, matching upstream; (bsc#1128523).
- Fix incorrect dependencies for rewritten monitoring agents; (bsc#1128606).
- Ensure symlink sources and targets are in the same package; (bsc#1127978).
- Move pcp-dstat into the pcp-system-tools package; (bsc#1127978).
2019-03-07 - Bernhard Wiedemann <bwiedemann@suse.com>
- drop unreproducible perfevent_coverage program (boo#1040589)
- override build date to make package build reproducible (boo#1047218)
2019-02-28 - ddiss@suse.com
- Upgrade to 4.3.1; (bsc#1127437).
+ Add proper systemd timer service dependency tracking
+ pmrep: fix a dynamic header corner case with missing values
+ pmie: fix for segv and bad sum_inst() use
+ pmview: fix a missing timeout slot connection
- Drop upstreamed patches:
0004-create-pmlogger-and-pmie-logdirs-during-install.patch
0007-pmie-add-systemd-timers-as-cron-alternative.patch
0008-pmlogger_daily-add-systemd-timers-as-cron-alternativ.patch
0009-pmlogger_daily_report-add-systemd-timers-as-cron-alt.patch
0010-pmns-don-t-package-.NeedRebuild-for-SUSE-distros.patch
2019-02-19 - ddiss@suse.com
- Drop python2 support for Factory and SLES15-SP1; (bsc#1077777).
2019-02-06 - ddiss@suse.com
- export PACKAGE_DISTRIBUTION="suse" for build; (bsc#1123311).
2019-01-31 - ddiss@suse.com
- Drop distribution-release build dependency completely; (bsc#1123311).
+ modify 0010-pmns-don-t-package-.NeedRebuild-for-SUSE-distros.patch
2019-01-30 - ddiss@suse.com
- Replace openSUSE/sles-release build dependency; (bsc#1123311).
2019-01-18 - ddiss@suse.com
- Drop conflicting dstat symlink; (bsc#1122502).
2019-01-15 - ddiss@suse.com
- Package missing PMDA binaries; (bsc#1121920).
+ refresh 0001-Install-libraries-without-exec-permission.patch
- Don't package pmns .NeedRebuild flag; (bsc#1092160).
+ add 0010-pmns-don-t-package-.NeedRebuild-for-SUSE-distros.patch
2019-01-10 - ddiss@suse.com
- Upgrade to 4.3.0; (bsc#1121914).
- Refreshed patches
0001-Install-libraries-without-exec-permission.patch
0007-pmie-add-systemd-timers-as-cron-alternative.patch
0008-pmlogger_daily-add-systemd-timers-as-cron-alternativ.patch
0009-pmlogger_daily_report-add-systemd-timers-as-cron-alt.patch

See Also

Package Description
python3-pdd-1.4-1.1.noarch.rpm Tiny date, time diff calculator with timers
python3-pdfkit-0.6.1-3.2.noarch.rpm Python wrapper for wkhtmltopdf, a HTML-to-PDF converter that uses Qt/WebKit
python3-pdfrw-0.4-3.1.noarch.rpm PDF file reader/writer library
python3-pecan-1.3.3-1.1.noarch.rpm A WSGI object-dispatching web framework
python3-peewee-3.9.3-1.1.i586.rpm An expressive ORM that supports multiple SQL backends
python3-peewee-3.9.3-1.1.x86_64.rpm An expressive ORM that supports multiple SQL backends
python3-pefile-2019.4.18-1.1.noarch.rpm A python module to work with PE (pertable executable) files
python3-pelican-4.0.1-2.2.noarch.rpm A tool to generate a static blog from reStructuredText or Markdown input files
python3-pem-18.2.0-1.1.noarch.rpm PEM file parsing in Python
python3-pep517-0.5.0-1.1.noarch.rpm Wrappers to build Python packages using PEP 517 hooks
python3-pep8-naming-0.8.2-1.1.noarch.rpm Flake8 plugin for checking PEP-8 naming conventions
python3-peppercorn-0.5-2.1.noarch.rpm Pyramid exceptions logger
python3-persistent-4.4.3-2.1.i586.rpm Translucent persistent objects
python3-persistent-4.4.3-2.1.x86_64.rpm Translucent persistent objects
python3-persistent-devel-4.4.3-2.1.i586.rpm Translucent persistent objects
Advertisement
Advertisement