python3-mox3-0.27.0-1.1.noarch.rpm


Advertisement

Description

python3-mox3 - An unofficial port of the Google mox framework to Python 3

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-mox3-0.27.0-1.1.noarch.rpm
Package name python3-mox3
Package version 0.27.0
Package release 1.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/openstack/mox3
License Apache-2.0
Maintainer -
Download size 49.95 KB
Installed size 234.29 KB
Mox3 is an unofficial port of the Google mox framework to Python 3. It
was meant to be as compatible with mox as possible, but small
enhancements have been made. The library was tested on Python version
3.2, 2.7 and 2.6.

Alternatives

Package Version Architecture Repository
python3-mox3 - - -

Requires

Name Value
python(abi) = 3.7
python3-fixtures >= 3.0.0
python3-pbr >= 2.0.0

Provides

Name Value
python3-mox3 = 0.27.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-mox3-0.27.0-1.1.noarch.rpm
Source Package python-mox3-0.27.0-1.1.src.rpm

Install Howto

Install python3-mox3 rpm package:

# zypper install python3-mox3

Files

Path
/usr/lib/python3.7/site-packages/mox3/__init__.py
/usr/lib/python3.7/site-packages/mox3/fixture.py
/usr/lib/python3.7/site-packages/mox3/mox.py
/usr/lib/python3.7/site-packages/mox3/stubout.py
/usr/lib/python3.7/site-packages/mox3-0.27.0-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/mox3-0.27.0-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/mox3-0.27.0-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/mox3-0.27.0-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/mox3-0.27.0-py3.7.egg-info/pbr.json
/usr/lib/python3.7/site-packages/mox3-0.27.0-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/mox3-0.27.0-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/mox3/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/mox3/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/mox3/__pycache__/fixture.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/mox3/__pycache__/fixture.cpython-37.pyc
/usr/lib/python3.7/site-packages/mox3/__pycache__/mox.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/mox3/__pycache__/mox.cpython-37.pyc
/usr/lib/python3.7/site-packages/mox3/__pycache__/stubout.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/mox3/__pycache__/stubout.cpython-37.pyc
/usr/share/doc/packages/python3-mox3/COPYING.txt
/usr/share/doc/packages/python3-mox3/README.rst

Changelog

2019-03-14 - Tomá? Chvátal <tchvatal@suse.com>
- Update to 0.27.0:
* import zuul job settings from project-config
* add python 3.6 unit test job
* Use template for lower-constraints
2019-02-13 - Tomá? Chvátal <tchvatal@suse.com>
- Update URL to point to the project page
- Remove tests from installed package
2018-12-31 - Thomas Bechtold <tbechtold@suse.com>
- Remove --slowest from stestr run to fix build
2018-11-06 - Todd R <toddrme2178@gmail.com>
- update to version 0.26.0
* Switch to stestr
* Remove the unnecessary spaces
* Update links in README
* fix tox python3 overrides
* set default python to python3
* fix a typo in documentation
* add lower-constraints job
* Updated from global requirements
- Update to version 0.25.0
* Updated from global requirements
* Updated from global requirements
* Updated from global requirements
- Add missing unittest dependency
- Spec file cleanups
- Build documentation with python3
2018-02-23 - cloud-devel@suse.de
- update to version 0.24.0
- Updated from global requirements
- Avoid tox_install.sh for constraints support
2017-11-24 - dmueller@suse.com
- update to version 0.23.0:
* Update URLs in documents according to document migration
* Update .gitignore
* turn on warning-is-error flag for doc build
* switch from oslosphinx to openstackdocstheme
* rearrange existing documentation based on the new standard layout

See Also

Package Description
python3-mpi4py-3.0.1-2.1.i586.rpm MPI for Python
python3-mpi4py-3.0.1-2.1.x86_64.rpm MPI for Python
python3-mpi4py-devel-3.0.1-2.1.i586.rpm Development files for python3-mpi4py
python3-mpi4py-devel-3.0.1-2.1.x86_64.rpm Development files for python3-mpi4py
python3-mpmath-1.1.0-1.1.noarch.rpm Python library for arbitrary-precision floating-point arithmetic
python3-mraa-2.0.0-2.1.i586.rpm Python3 bindings for mraa
python3-mraa-2.0.0-2.1.x86_64.rpm Python3 bindings for mraa
python3-msgpack-0.6.1-1.1.i586.rpm MessagePack (de)serializer
python3-msgpack-0.6.1-1.1.x86_64.rpm MessagePack (de)serializer
python3-msgpack-numpy-0.4.4.2-1.1.noarch.rpm Numpy data serialization library using msgpack
python3-msk-0.3.12-1.2.noarch.rpm Mycroft Skills Kit
python3-msm-0.6.3-2.1.noarch.rpm Mycroft Skills Manager
python3-msrest-0.5.5-1.2.noarch.rpm AutoRest swagger generator Python client runtime
python3-msrestazure-0.5.0-1.2.noarch.rpm AutoRest swagger generator - Azure-specific module
python3-mulpyplexer-0.08-2.2.noarch.rpm A module that multiplexes interactions with lists of python objects
Advertisement
Advertisement