python3-matplotlib-web-3.0.3-1.1.i586.rpm


Advertisement

Description

python3-matplotlib-web - Web backend for python3-matplotlib

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-matplotlib-web-3.0.3-1.1.i586.rpm
Package name python3-matplotlib-web
Package version 3.0.3
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/Python
Homepage http://matplotlib.org
License SUSE-Matplotlib
Maintainer -
Download size 377.48 KB
Installed size 1.76 MB
This package includes the browser-based webagg backend
for the python3-matplotlib plotting package

Alternatives

Package Version Architecture Repository
python3-matplotlib-web-3.0.3-1.1.x86_64.rpm 3.0.3 x86_64 openSUSE Oss
python3-matplotlib-web - - -

Requires

Name Value
python(abi) = 3.7
python3-matplotlib = 3.0.3
python3-tornado -

Provides

Name Value
python3-matplotlib-web = 3.0.3-1.1
python3-matplotlib-web(x86-32) = 3.0.3-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-matplotlib-web-3.0.3-1.1.i586.rpm
Source Package python-matplotlib-3.0.3-1.1.src.rpm

Install Howto

Install python3-matplotlib-web rpm package:

# zypper install python3-matplotlib-web

Files

Path
/usr/lib/python3.7/site-packages/matplotlib/backends/backend_webagg.py
/usr/lib/python3.7/site-packages/matplotlib/backends/backend_webagg_core.py
/usr/lib/python3.7/site-packages/matplotlib/backends/__pycache__/backend_webagg.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/matplotlib/backends/__pycache__/backend_webagg.cpython-37.pyc
/usr/lib/python3.7/site-packages/matplotlib/backends/__pycache__/backend_webagg_core.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/matplotlib/backends/__pycache__/backend_webagg_core.cpython-37.pyc
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/all_figures.html
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/ipython_inline_figure.html
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/nbagg_uat.ipynb
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/single_figure.html
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/css/boilerplate.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/css/fbm.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/css/page.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery/
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/AUTHORS.txt
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/LICENSE.txt
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/index.html
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.js
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.min.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.min.js
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.structure.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.structure.min.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.theme.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/jquery-ui.theme.min.css
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/package.json
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/external/
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/external/jquery/jquery.js
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_444444_256x240.png
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_555555_256x240.png
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_777620_256x240.png
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_777777_256x240.png
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_cc0000_256x240.png
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery-ui-1.12.1/images/ui-icons_ffffff_256x240.png
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery/js/jquery-1.11.3.js
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/jquery/js/jquery-1.11.3.min.js
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/js/mpl.js
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/js/mpl_tornado.js
/usr/lib/python3.7/site-packages/matplotlib/backends/web_backend/js/nbagg_mpl.js
/usr/share/licenses/python3-matplotlib-web/license.rst
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE.PIL
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_AMSFONTS
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_BAKOMA
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_COLORBREWER
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_CONDA
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_JQUERY
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_QT4_EDITOR
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_STIX
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_YORICK
/usr/share/licenses/python3-matplotlib-web/LICENSE/LICENSE_enthought.txt
/usr/share/licenses/python3-matplotlib-web/LICENSE/Solarized.txt
/usr/share/licenses/python3-matplotlib-web/LICENSE/pnpoly.license

Changelog

2019-03-01 - Arun Persaud <arun@gmx.de>
- update to version 3.0.3:
* fix several possible memory leaks
* documentation fixes
* jquery-ui is no longer bundled in git repo and is downloaded
during the install or sdist process. If you are installing from
pypi the files will be included, but if you are installing from
git you will need internet access the first time you run `pip
install .`. The install process tries to cache the files and will
not need internet access on future installations.
2019-02-27 - Fabian Vogt <fvogt@suse.com>
- Disable Qt4 support on Tumbleweed by default
2018-11-12 - Arun Persaud <arun@gmx.de>
- update to version 3.0.2:
* Un-breaks basemap which was broken by partially restoring private
APIs for cartopy.
* Fixes bug in warning code when used in an embedded context.
* Fixes crash when using Tk and closing the first open window before
showing it
* Many documentation improvements.
* Restore a corner case on ColorBar tick usage.
* Change the default behavior of `matplotlib.use` to silently allow
more 'safe' switching after auto-discovery, but before starting an
event loop.
* Improvements to bounding box calculations.
* Provide the correct length for RcParams instances.
2018-10-26 - Todd R <toddrme2178@gmail.com>
- Update to version 3.0.1
* Fix failure to import bug when on Python 3.6.7 and 3.7.1
* Fixed a number of failure to import bugs around finding fonts
* Fix Qt4 backend
* Fix bug on OSX that recursively searched current directory for fonts
* Fix bouncing-rocket on OSX when doing backend fallback and not
selecting OSX
* Temporarily restore several private APIs to unbreak cartopy
* Make pyplot more tolerant of varying signatures in 3rd-party
sub-classe
* Improve datetime64 unit handling
* Fixed several poor interactions with tight_layout
2018-09-19 - Todd R <toddrme2178@gmail.com>
- Update to version 3.0.0
* Improved default backend selection
* Cyclic colormaps
* Ability to scale axis by a fixed order of magnitude
* Add AnchoredDirectionArrows feature to mpl_toolkits
* Add minorticks_on()/off() methods for colorbar
* Colorbar ticks can now be automatic
* Don't automatically rename duplicate file names
* Legend now has a *title_fontsize* kwarg (and rcParam)
* Support for axes.prop_cycle property *markevery* in rcParams
* Multipage PDF support for pgf backend
* Pie charts are now circular by default
* Add ax.get_gridspec to .SubplotBase
* Axes titles will no longer overlap xaxis
* New convenience methods for GridSpec
* Figure has an ~.figure.Figure.add_artist method
* math directive renamed to mathmpl
- Python 2 support was dropped upstream, so disable it in the spec
file and drop python2-specific parts.
- Enable wx backend for python 3, since python 3 is now supported
by wxPython upstream.
2018-08-14 - toddrme2178@gmail.com
- Update to version 2.2.3
* Fix import failure on BSD systems
* Fix import errors in Qt shims for PyQt5 5.11 and PyQt4 4.12
* Fix import errors if bz2 module is not in standard library
* Fix overflow in _path.h
* Fix infinite recursion in transform repr
* Fix bug with XKCD style
* Remove unsafe usage of Popen
2018-06-02 - hpj@urpla.net
- don't use any lua expressions for suse_version < 1500
2018-06-01 - dimstar@opensuse.org
- Only recommend python-matplotlib-tk if tk is already flagged for
installation. On most systems there is no reason to have tk
available (those UIs are out of date and not well perceived
anyway).
2018-05-15 - tbechtold@suse.com
- Add missing Requires for python-backports.functools_lru_cache (boo#1074491)
2018-05-10 - toddrme2178@gmail.com
- Fix building on SLE which doesn't have qhull.

See Also

Package Description
python3-matplotlib-wx-3.0.3-1.1.i586.rpm WxWidgets backend for python3-matplotlib
python3-matplotlib-wx-3.0.3-1.1.x86_64.rpm WxWidgets backend for python3-matplotlib
python3-matrix-synapse-0.34.1.1-2.1.noarch.rpm Matrix protocol reference homeserver
python3-matrix-synapse-ldap3-0.1.2-1.3.noarch.rpm An LDAP3 auth provider for Synapse
python3-maxminddb-1.4.1-1.2.i586.rpm Reader for the MaxMind DB format
python3-maxminddb-1.4.1-1.2.x86_64.rpm Reader for the MaxMind DB format
python3-mccabe-0.6.1-1.4.noarch.rpm McCabe checker, plugin for flake8
python3-mechanize-0.4.1-1.1.noarch.rpm Stateful programmatic web browsing
python3-meld3-1.0.2-3.2.noarch.rpm HTML/XML templating engine for Python
python3-memory_profiler-0.55.0-2.1.noarch.rpm A module for monitoring memory usage of a python program
python3-metaextract-1.0.5-3.1.noarch.rpm get metadata for python modules
python3-minidb-2.0.2-3.2.noarch.rpm SQLite3-based store for Python objects
python3-minio-4.0.13-1.1.noarch.rpm Minio library for Amazon S3 compatible cloud storage
python3-miniupnpc-2.1-3.2.i586.rpm Universal Plug'n'Play (UPnP) Client Module for Python
python3-miniupnpc-2.1-3.2.x86_64.rpm Universal Plug'n'Play (UPnP) Client Module for Python
Advertisement
Advertisement