python3-lilv-0.24.4-1.4.i586.rpm


Advertisement

Description

python3-lilv - Python 3 bindings for lilv

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-lilv-0.24.4-1.4.i586.rpm
Package name python3-lilv
Package version 0.24.4
Package release 1.4
Package architecture i586
Package type rpm
Category Development/Libraries/Python
Homepage http://drobilla.net/software/lilv/
License ISC
Maintainer -
Download size 24.20 KB
Installed size 66.33 KB
Lilv is a C library to make use of LV2 plugins in applications.
This subpackage contains the Python 3 bindings for lilv.

Alternatives

Package Version Architecture Repository
python3-lilv-0.24.4-36.7.x86_64.rpm 0.24.4 x86_64 Multimedia Libs
python3-lilv-0.24.4-36.7.i586.rpm 0.24.4 i586 Multimedia Libs
python3-lilv-0.24.4-1.4.x86_64.rpm 0.24.4 x86_64 openSUSE Oss
python3-lilv - - -

Requires

Name Value
python(abi) = 3.7

Provides

Name Value
python3-lilv = 0.24.4-1.4
python3-lilv(x86-32) = 0.24.4-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-lilv-0.24.4-1.4.i586.rpm
Source Package lilv-0.24.4-1.4.src.rpm

Install Howto

Install python3-lilv rpm package:

# zypper install python3-lilv

Files

Path
/usr/lib/python3.7/site-packages/lilv.py

Changelog

2018-09-14 - Tomá? Chvátal <tchvatal@suse.com>
- Version update to 0.24.4:
* Fix saving state when broken links are encountered
* Don't attempt to load remote or non-Turtle files
* lv2apply: Activate plugin before running
* lv2apply: Use default values when they are not nan
* lv2bench: Improve support for plugins with sequence ports
* lv2bench: Support running a single plugin given on the command line
* Gracefully handle plugins with missing binary URIs
* Remove use of deprecated readdir_r
* Install Python bindings when configured without tests
(thanks Clement Skau)
2017-11-04 - davejplater@gmail.com
- Revert devel package name to original, causes unresolvables.
2017-11-03 - mpluskal@suse.com
- Switch to python3
- Run spec cleaner
- Rename devel subpackage
2017-11-03 - davejplater@gmail.com
- Update to version 0.24.2
- Remove patch lilv-python-bindings-fix.diff it's now incorporated
by upstream.
- Upstream changes:
Fix saving state to paths that contain URI delimiters
Fix comparison of restored states with paths
Add new hand-crafted Pythonic bindings with full test
coverage.
Add lv2apply utility for applying plugins to audio files
Add lilv_world_get_symbol()
Add lilv_state_set_metadata() for adding state banks/comments
/etc (based on patch from Hanspeter Portner)
Fix crash when state contains non-POD properties
Fix crash if NULL predicate passed to lilv_world_find_nodes()
Fix state file versioning
Unload contained resources when bundle is unloaded
Do not instantiate plugin when data fails to parse
Support re-loading plugins
Replace bundles if bundle with newer plugin version is loaded
Fix loading dyn-manifest from bundles with spaces in path
Check lv2:binary predicate for UIs
Add LILV_URI_ATOM_PORT and LILV_URI_CV_PORT defines
Fix documentation installation
Fix outdated comment references to lilv_uri_to_path()
2017-02-02 - jengelh@inai.de
- Rename soname to sover to better reflect its use
- Update descriptions
- Since there is no %pre section, replace questionable
Requires(pre) by Requires.
2017-01-12 - olaf@aepfle.de
- Add baselibs.conf for gstreamer-plugins-bad-32bit
2015-12-19 - davejplater@gmail.com
- Force lilv package to use the version of sord that it was built
against.
2015-12-08 - someuniquename@gmail.com
- Add runtime requirement of sord 0.13 (new API required since 0.22)
2015-12-08 - someuniquename@gmail.com
- Update to version 0.22.0, Added lilv-python-bindings-fix.diff
backported from unreleased v 0.22.1
- Upstream changes :
* Fix loading files with spaces in their path
* Add lilv_file_uri_parse() for correct URI to path conversion
* Add lilv_node_get_path() for convenient file URI path access
* Add lilv_state_emit_port_values() for special port value handling
* Add lilv_state_get_uri()
* Add lilv_state_delete() for deleting user saved presets
* Add lilv_free() for systems picky about such things
* Fix lilv_world_ask() to work with wildcards
* Fix creation of duplicate manifest entries when saving state
* Fix bindings for Python 3
* Load discovered owl ontologies as specifications
* Expose lilv_world_load_specifications() and
lilv_world_load_plugin_classes()
* Tolerate passing NULL to lilv_state_restore()
* Preserve absolute paths in state if no link directory is given
* Fix a few minor/unlikely memory errors
* Configure based on compiler target OS for cross-compilation
* Fix lilv_realpath() on pre-POSIX-2008 systems
* Fix directory walking on some systems (thanks Matt Fischer)
* Windows fixes (thanks John Emmas)
* Minor documentation improvements
* Upgrade to waf 1.8.14

See Also

Package Description
python3-limnoria-2019.02.23-1.1.noarch.rpm A modified version of Supybot (an IRC bot and framework)
python3-line_profiler-2.1.2-4.2.i586.rpm Line-by-line profiler
python3-line_profiler-2.1.2-4.2.x86_64.rpm Line-by-line profiler
python3-linecache2-1.0.0-4.2.noarch.rpm Backports of the linecache module
python3-linux-procfs-0.6-1.2.noarch.rpm Linux /proc abstraction classes
python3-lit-0.6.0-2.2.noarch.rpm A portable tool for executing test suites
python3-lldb-7.0.1-2.1.x86_64.rpm Python bindings for liblldb
python3-lldb6-6.0.1-6.1.x86_64.rpm Python bindings for liblldb
python3-lldb7-7.0.1-6.1.x86_64.rpm Python bindings for liblldb
python3-llfuse-1.3.5-1.2.i586.rpm Python Bindings for the low-level FUSE API
python3-llfuse-1.3.5-1.2.x86_64.rpm Python Bindings for the low-level FUSE API
python3-llvmlite-0.28.0-1.1.i586.rpm Lightweight wrapper around basic LLVM functionality
python3-llvmlite-0.28.0-1.1.x86_64.rpm Lightweight wrapper around basic LLVM functionality
python3-lmdb-0.94-1.6.i586.rpm Universal Python binding for the LMDB 'Lightning' Database
python3-lmdb-0.94-1.6.x86_64.rpm Universal Python binding for the LMDB 'Lightning' Database
Advertisement
Advertisement