python3-google-auth-1.6.3-1.1.noarch.rpm


Advertisement

Description

python3-google-auth - Google Authentication Library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-google-auth-1.6.3-1.1.noarch.rpm
Package name python3-google-auth
Package version 1.6.3
Package release 1.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/GoogleCloudPlatform/google-auth-library-python
License Apache-2.0
Maintainer -
Download size 93.33 KB
Installed size 545.05 KB
This library simplifies using Google’s various server-to-server authentication mechanisms to access Google APIs.

Alternatives

Package Version Architecture Repository
python3-google-auth - - -

Requires

Name Value
python(abi) = 3.7
python3-cachetools -
python3-cryptography -
python3-oauth2client -
python3-oauth2client-gce -
python3-pyasn1 -
python3-pyasn1-modules -
python3-requests -
python3-rsa -
python3-setuptools -
python3-six -
python3-urllib3 -

Provides

Name Value
python3-google-auth = 1.6.3-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-google-auth-1.6.3-1.1.noarch.rpm
Source Package python-google-auth-1.6.3-1.1.src.rpm

Install Howto

Install python3-google-auth rpm package:

# zypper install python3-google-auth

Files

Path
/usr/lib/python3.7/site-packages/google_auth-1.6.3-py3.7-nspkg.pth
/usr/lib/python3.7/site-packages/google/
/usr/lib/python3.7/site-packages/google/auth/__init__.py
/usr/lib/python3.7/site-packages/google/auth/_cloud_sdk.py
/usr/lib/python3.7/site-packages/google/auth/_default.py
/usr/lib/python3.7/site-packages/google/auth/_helpers.py
/usr/lib/python3.7/site-packages/google/auth/_oauth2client.py
/usr/lib/python3.7/site-packages/google/auth/_service_account_info.py
/usr/lib/python3.7/site-packages/google/auth/app_engine.py
/usr/lib/python3.7/site-packages/google/auth/credentials.py
/usr/lib/python3.7/site-packages/google/auth/environment_vars.py
/usr/lib/python3.7/site-packages/google/auth/exceptions.py
/usr/lib/python3.7/site-packages/google/auth/iam.py
/usr/lib/python3.7/site-packages/google/auth/impersonated_credentials.py
/usr/lib/python3.7/site-packages/google/auth/jwt.py
/usr/lib/python3.7/site-packages/google/auth/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_cloud_sdk.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_cloud_sdk.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_default.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_default.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_helpers.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_helpers.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_oauth2client.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_oauth2client.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_service_account_info.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/_service_account_info.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/app_engine.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/app_engine.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/credentials.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/credentials.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/environment_vars.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/environment_vars.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/exceptions.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/exceptions.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/iam.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/iam.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/impersonated_credentials.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/impersonated_credentials.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/jwt.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/__pycache__/jwt.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/compute_engine/__init__.py
/usr/lib/python3.7/site-packages/google/auth/compute_engine/_metadata.py
/usr/lib/python3.7/site-packages/google/auth/compute_engine/credentials.py
/usr/lib/python3.7/site-packages/google/auth/compute_engine/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/compute_engine/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/compute_engine/__pycache__/_metadata.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/compute_engine/__pycache__/_metadata.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/compute_engine/__pycache__/credentials.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/compute_engine/__pycache__/credentials.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__init__.py
/usr/lib/python3.7/site-packages/google/auth/crypt/_cryptography_rsa.py
/usr/lib/python3.7/site-packages/google/auth/crypt/_helpers.py
/usr/lib/python3.7/site-packages/google/auth/crypt/_python_rsa.py
/usr/lib/python3.7/site-packages/google/auth/crypt/base.py
/usr/lib/python3.7/site-packages/google/auth/crypt/rsa.py
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/_cryptography_rsa.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/_cryptography_rsa.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/_helpers.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/_helpers.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/_python_rsa.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/_python_rsa.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/base.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/base.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/rsa.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/crypt/__pycache__/rsa.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__init__.py
/usr/lib/python3.7/site-packages/google/auth/transport/_http_client.py
/usr/lib/python3.7/site-packages/google/auth/transport/grpc.py
/usr/lib/python3.7/site-packages/google/auth/transport/requests.py
/usr/lib/python3.7/site-packages/google/auth/transport/urllib3.py
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/_http_client.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/_http_client.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/grpc.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/grpc.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/requests.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/requests.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/urllib3.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/auth/transport/__pycache__/urllib3.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__init__.py
/usr/lib/python3.7/site-packages/google/oauth2/_client.py
/usr/lib/python3.7/site-packages/google/oauth2/credentials.py
/usr/lib/python3.7/site-packages/google/oauth2/id_token.py
/usr/lib/python3.7/site-packages/google/oauth2/service_account.py
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/_client.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/_client.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/credentials.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/credentials.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/id_token.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/id_token.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/service_account.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/oauth2/__pycache__/service_account.cpython-37.pyc
/usr/lib/python3.7/site-packages/google_auth-1.6.3-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/google_auth-1.6.3-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/google_auth-1.6.3-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/google_auth-1.6.3-py3.7.egg-info/namespace_packages.txt
/usr/lib/python3.7/site-packages/google_auth-1.6.3-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/google_auth-1.6.3-py3.7.egg-info/top_level.txt
/usr/share/doc/packages/python3-google-auth/README.rst
/usr/share/licenses/python3-google-auth/LICENSE

Changelog

2019-03-15 - Tomá? Chvátal <tchvatal@suse.com>
- Update to 1.6.3:
* follow rfc 7515 : strip padding from JWS segments #324 (#324)
* Add retry to _metadata.ping() (#323)
* Announce deprecation of Python 2.7 (#311)
* Link all the PRs in CHANGELOG (#307)
* Automatically refresh impersonated credentials (#304)
* Add google.auth.impersonated_credentials (#299)
* Enable static type checking with pytype (#298)
* Make classifiers in setup.py an array. (#280)
- Drop oauth-no-appengine.patch should not be needed
2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-09-12 - Thomas Bechtold <tbechtold@suse.com>
- update to 1.5.1:
- Fix check for error text on Python 3.7. (#278)
- Use new Auth URIs. (#281)
- Add code-of-conduct document. (#270)
- Fix some typos in test_urllib3.py (#268)
- Warn when using user credentials from the Cloud SDK (#266)
- Add compute engine-based IDTokenCredentials (#236)
- Corrected some typos (#265)
2018-05-29 - tbechtold@suse.com
- update to 1.4.2:
- Raise a helpful exception when trying to refresh credentials without
a refresh token. (#262)
- Fix links to README and CONTRIBUTING in docs/index.rst. (#260)
- Fix a typo in credentials.py. (#256)
- Use pytest instead of py.test per upstream recommendation,
[#]dropthedot. (#255)
- Fix typo on exemple of jwt usage (#245)
- Drop Flask from Requires. It is only needed for testing
2018-05-08 - tchvatal@suse.com
- Add patch to not check for oauth appengine which we disable in
openSUSE:
* oauth-no-appengine.patch
2018-05-07 - tchvatal@suse.com
- Fix fdupes call and run tests
2018-05-07 - adrian.glaubitz@suse.com
- New upstream release (bsc#1088358)
+ Version 1.4.1
- Added a check for the cryptography version before attempting to use it.
+ From version 1.4.0
- Added `cryptography`-based RSA signer and verifier.
- Added `google.oauth2.service_account.IDTokenCredentials`.
- Improved documentation around ID Tokens
+ From version 1.3.0
- Added ``google.oauth2.credentials.Credentials.from_authorized_user_file``.
- Dropped direct pyasn1 dependency in favor of letting ``pyasn1-modules``
specify the right version.
- ``default()`` now checks for the project ID environment var before
warning about missing project ID.
- Fixed the docstrings for ``has_scopes()`` and ``with_scopes()``.
- Fixed example in docstring for ``ReadOnlyScoped``.
- Made ``transport.requests`` use timeouts and retries
to improve reliability.
2017-11-19 - mc@suse.com
- initial version 1.2.1

See Also

Package Description
python3-google-auth-httplib2-0.0.3-1.1.noarch.rpm Google Authentication Library: httplib2 transport
python3-google-cloud-core-0.29.1-1.1.noarch.rpm Google Cloud API client core library
python3-google-cloud-kms-1.0.0-1.1.noarch.rpm Cloud Key Management Service (KMS) API API client library
python3-google-cloud-speech-1.0.0-1.1.noarch.rpm Google Cloud Speech API client library
python3-google-cloud-storage-1.14.0-1.1.noarch.rpm Google Cloud Storage API client library
python3-google-resumable-media-0.3.2-1.1.noarch.rpm Utilities for Google Media Downloads and Resumable Uploads
python3-googleapis-common-protos-1.5.9-1.1.noarch.rpm Common protobufs used in Google APIs
python3-googlemaps-3.0.2-1.1.noarch.rpm Python client library for Google Maps API Web Services
python3-gpg-1.13.0-1.1.i586.rpm Python 3 bindings for GPGME, a library for accessing GnuPG
python3-gpg-1.13.0-1.1.x86_64.rpm Python 3 bindings for GPGME, a library for accessing GnuPG
python3-gpgme-0.3-2.5.i586.rpm A Python module for working with OpenPGP messages
python3-gpgme-0.3-2.5.x86_64.rpm A Python module for working with OpenPGP messages
python3-gphoto2-2.0.0-1.1.i586.rpm Python interface to libgphoto2
python3-gphoto2-2.0.0-1.1.x86_64.rpm Python interface to libgphoto2
python3-gprof2dot-2017.9.19-3.2.noarch.rpm Script to generate a dot graph from the output of several profilers
Advertisement
Advertisement