python3-google-api-core-1.8.2-1.1.noarch.rpm


Advertisement

Description

python3-google-api-core - Google API client core library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-google-api-core-1.8.2-1.1.noarch.rpm
Package name python3-google-api-core
Package version 1.8.2
Package release 1.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/GoogleCloudPlatform/google-cloud-python
License Apache-2.0
Maintainer -
Download size 91.05 KB
Installed size 488.82 KB
Core Library for Google Client Libraries

Alternatives

Package Version Architecture Repository
python3-google-api-core - - -

Requires

Name Value
python(abi) = 3.7
python3-google-auth >= 0.4.0
python3-googleapis-common-protos >= 1.5.3
python3-grpcio >= 1.8.2
python3-protobuf >= 3.0.0
python3-pytz -
python3-requests >= 2.18.0
python3-setuptools >= 34.0.0
python3-six >= 1.10.0

Provides

Name Value
python3-google-api-core = 1.8.2-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-google-api-core-1.8.2-1.1.noarch.rpm
Source Package python-google-api-core-1.8.2-1.1.src.rpm

Install Howto

Install python3-google-api-core rpm package:

# zypper install python3-google-api-core

Files

Path
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7-nspkg.pth
/usr/lib/python3.7/site-packages/google/
/usr/lib/python3.7/site-packages/google/api_core/__init__.py
/usr/lib/python3.7/site-packages/google/api_core/bidi.py
/usr/lib/python3.7/site-packages/google/api_core/datetime_helpers.py
/usr/lib/python3.7/site-packages/google/api_core/exceptions.py
/usr/lib/python3.7/site-packages/google/api_core/general_helpers.py
/usr/lib/python3.7/site-packages/google/api_core/grpc_helpers.py
/usr/lib/python3.7/site-packages/google/api_core/iam.py
/usr/lib/python3.7/site-packages/google/api_core/operation.py
/usr/lib/python3.7/site-packages/google/api_core/page_iterator.py
/usr/lib/python3.7/site-packages/google/api_core/path_template.py
/usr/lib/python3.7/site-packages/google/api_core/protobuf_helpers.py
/usr/lib/python3.7/site-packages/google/api_core/retry.py
/usr/lib/python3.7/site-packages/google/api_core/timeout.py
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/bidi.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/bidi.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/datetime_helpers.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/datetime_helpers.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/exceptions.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/exceptions.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/general_helpers.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/general_helpers.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/grpc_helpers.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/grpc_helpers.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/iam.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/iam.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/operation.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/operation.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/page_iterator.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/page_iterator.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/path_template.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/path_template.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/protobuf_helpers.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/protobuf_helpers.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/retry.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/retry.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/timeout.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/__pycache__/timeout.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__init__.py
/usr/lib/python3.7/site-packages/google/api_core/future/_helpers.py
/usr/lib/python3.7/site-packages/google/api_core/future/base.py
/usr/lib/python3.7/site-packages/google/api_core/future/polling.py
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/_helpers.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/_helpers.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/base.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/base.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/polling.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/future/__pycache__/polling.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__init__.py
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/client_info.py
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/config.py
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/method.py
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/routing_header.py
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/client_info.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/client_info.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/config.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/config.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/method.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/method.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/routing_header.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/gapic_v1/__pycache__/routing_header.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/__init__.py
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/operations_client.py
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/operations_client_config.py
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/__pycache__/operations_client.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/__pycache__/operations_client.cpython-37.pyc
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/__pycache__/operations_client_config.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/google/api_core/operations_v1/__pycache__/operations_client_config.cpython-37.pyc
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7.egg-info/namespace_packages.txt
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/google_api_core-1.8.2-py3.7.egg-info/top_level.txt
/usr/share/doc/packages/python3-google-api-core/README.rst
/usr/share/licenses/python3-google-api-core/LICENSE

Changelog

2019-03-26 - Tomá? Chvátal <tchvatal@suse.com>
- Update to 1.8.2:
* Remove classifier for Python 3.4 for end-of-life. (#7535)
2019-03-14 - Tomá? Chvátal <tchvatal@suse.com>
- Update to 1.8.1:
* Protect the creation of a background thread in BackgroundConsumer and wait on it starting. (#7499)
* Add support to unwrap Anys into wrapped pb2 objects. (#7430)
* Add Operation.deserialize. (#7427)
2019-02-18 - John Vandenberg <jayvdb@gmail.com>
- Activate tests
- Update to version 1.7.0
* New Features
+ Support converting DatetimeWithNanos to / from
google.protobuf.timestamp_pb2.Timestamp
* Documentation
+ Document Python 2 deprecation. (#6910)
+ Add usage example for google.api_core.iam.Polcy. (#6855)
* Internal / Testing Changes
+ Work around pytype big for ABCMeta.register
- from version 1.6.0
(not documented)
- from version 1.5.2
* Implementation Changes
+ Retry transient errors in 'PollingFuture.result'
* Dependencies
+ Remove hyphen from named extra in api_core. (#6468)
+ Bump minimum 'api_core' version for all GAPIC libs to 1.4.1. (#6391)
+ Avoid broken 'google-common-apis 1.5.4' release
- from version 1.5.1
* Implementation Changes
+ Don't URL-encode slashes in gRPC request headers
* Internal / Testing Changes
+ Back out changes from #6267
- from version 1.5.0
* New Features
+ Add bidi, Bidirection Streaming, to api-core
* Internal / Testing Changes
+ Use new Nox
- from version 1.4.1
* Internal / Testing Changes
+ Add type-checking via pytype to api_core
2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-09-12 - Thomas Bechtold <tbechtold@suse.com>
- update to version 1.4.0
* Add support for gRPC connection management (available when using
optional grpc_gcp dependency) (#5553) (#5904)
* Update classifiers to drop Python 3.4 and add Python 3.7 (#5702)
* Add protobuf_helpers.field_mask to calculate a field mask from
two messages (#5320)
2018-05-29 - tbechtold@suse.com
- update to 1.2.0:
* Add close method to grpc Channel (#5333)
* Fix tests after grpcio update (#5333)
* Add Test runs for Python 3.7 and remove 3.4 (#5295)
- use %license
2018-05-18 - tbechtold@suse.com
- Initial packaging (version 1.1.2)

See Also

Package Description
python3-google-api-python-client-1.7.8-1.1.noarch.rpm Google APIs Python Client
python3-google-auth-1.6.3-1.1.noarch.rpm Google Authentication Library
python3-google-auth-httplib2-0.0.3-1.1.noarch.rpm Google Authentication Library: httplib2 transport
python3-google-cloud-core-0.29.1-1.1.noarch.rpm Google Cloud API client core library
python3-google-cloud-kms-1.0.0-1.1.noarch.rpm Cloud Key Management Service (KMS) API API client library
python3-google-cloud-speech-1.0.0-1.1.noarch.rpm Google Cloud Speech API client library
python3-google-cloud-storage-1.14.0-1.1.noarch.rpm Google Cloud Storage API client library
python3-google-resumable-media-0.3.2-1.1.noarch.rpm Utilities for Google Media Downloads and Resumable Uploads
python3-googleapis-common-protos-1.5.9-1.1.noarch.rpm Common protobufs used in Google APIs
python3-googlemaps-3.0.2-1.1.noarch.rpm Python client library for Google Maps API Web Services
python3-gpg-1.13.0-1.1.i586.rpm Python 3 bindings for GPGME, a library for accessing GnuPG
python3-gpg-1.13.0-1.1.x86_64.rpm Python 3 bindings for GPGME, a library for accessing GnuPG
python3-gpgme-0.3-2.5.i586.rpm A Python module for working with OpenPGP messages
python3-gpgme-0.3-2.5.x86_64.rpm A Python module for working with OpenPGP messages
python3-gphoto2-2.0.0-1.1.i586.rpm Python interface to libgphoto2
Advertisement
Advertisement