python3-flask-mongoengine-0.9.5-1.2.noarch.rpm


Advertisement

Description

python3-flask-mongoengine - A Flask extension that provides integration with MongoEngine and WTForms

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-flask-mongoengine-0.9.5-1.2.noarch.rpm
Package name python3-flask-mongoengine
Package version 0.9.5
Package release 1.2
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/mongoengine/flask-mongoengine
License BSD-3-Clause
Maintainer -
Download size 50.03 KB
Installed size 165.63 KB
Flask-MongoEngine is a Flask extension that provides integration with MongoEngine.
It handles connection management for apps and also integrates with WTForms
as model forms for models.

Alternatives

Package Version Architecture Repository
python3-flask-mongoengine - - -

Requires

Name Value
python(abi) = 3.7
python3-Flask >= 0.8
python3-Flask-WTF >= 0.13
python3-mongoengine >= 0.8.0
python3-six -

Provides

Name Value
python3-flask-mongoengine = 0.9.5-1.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-flask-mongoengine-0.9.5-1.2.noarch.rpm
Source Package python-flask-mongoengine-0.9.5-1.2.src.rpm

Install Howto

Install python3-flask-mongoengine rpm package:

# zypper install python3-flask-mongoengine

Files

Path
/usr/lib/python3.7/site-packages/flask_mongoengine/__init__.py
/usr/lib/python3.7/site-packages/flask_mongoengine/connection.py
/usr/lib/python3.7/site-packages/flask_mongoengine/json.py
/usr/lib/python3.7/site-packages/flask_mongoengine/operation_tracker.py
/usr/lib/python3.7/site-packages/flask_mongoengine/pagination.py
/usr/lib/python3.7/site-packages/flask_mongoengine/panels.py
/usr/lib/python3.7/site-packages/flask_mongoengine/sessions.py
/usr/lib/python3.7/site-packages/flask_mongoengine-0.9.5-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/flask_mongoengine-0.9.5-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/flask_mongoengine-0.9.5-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/flask_mongoengine-0.9.5-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/flask_mongoengine-0.9.5-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/flask_mongoengine-0.9.5-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/connection.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/connection.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/json.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/json.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/operation_tracker.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/operation_tracker.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/pagination.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/pagination.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/panels.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/panels.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/sessions.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/__pycache__/sessions.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/templates/
/usr/lib/python3.7/site-packages/flask_mongoengine/templates/panels/mongo-panel.html
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__init__.py
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/base.py
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/fields.py
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/models.py
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/orm.py
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/base.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/base.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/fields.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/fields.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/models.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/models.cpython-37.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/orm.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/flask_mongoengine/wtf/__pycache__/orm.cpython-37.pyc
/usr/share/doc/packages/python3-flask-mongoengine/AUTHORS
/usr/share/doc/packages/python3-flask-mongoengine/README.rst
/usr/share/licenses/python3-flask-mongoengine/LICENSE

Changelog

2018-11-17 - Jan Engelhardt <jengelh@inai.de>
- Generalize description.
2018-10-10 - Antonio Larrosa <alarrosa@suse.com> - 0.9.5
- Use sources from github instead of pypi, so we can run tests
- BuildRequire mongodb-server and start an instance in %check since
the tests require a running mongo daemon listening in port 27017.
2018-09-21 - Antonio Larrosa <alarrosa@suse.com> - 0.9.5
- Initial release of python-flask-mongoengine-0.9.5
- Add fix-requirements.patch to remove requirements that are actually
for tests (which are not included in the sources)

See Also

Package Description
python3-flask-peewee-3.0.3-1.2.noarch.rpm Peewee integration for flask
python3-flatbuffers-1.10.0.20190321T162332.a746143-1.1.noarch.rpm The FlatBuffers serialization format for Python
python3-flex-6.14.0-1.1.noarch.rpm Swagger Schema validation
python3-flexmock-0.10.4-1.1.noarch.rpm Testing library for creating mocks, stubs and fakes
python3-flexx-0.7.1-1.1.noarch.rpm Python toolkit for creating graphical user interfaces
python3-flickrapi-2.4.0-1.2.noarch.rpm Python interface to Flickr
python3-flower-0.9.3-1.1.noarch.rpm A web frontend for monitoring and administrating Celery clusters
python3-fluent-0.10.0-2.2.noarch.rpm Localization library for expressive translations
python3-fluidity-sm-0.2.0-1.2.noarch.rpm State machine implementation for Python objects
python3-flup-1.0.3.dev20161029-2.2.noarch.rpm Random assortment of WSGI servers
python3-forbiddenfruit-0.1.2-2.1.i586.rpm Python module to patch python built-in objects
python3-forbiddenfruit-0.1.2-2.1.x86_64.rpm Python module to patch python built-in objects
python3-freetype-py-1.1-2.2.noarch.rpm Freetype python bindings
python3-freezegun-0.3.11-2.1.noarch.rpm Mock time date for Python
python3-freezerclient-2.1.0-1.1.noarch.rpm Python API and CLI for OpenStack Freezer
Advertisement
Advertisement