python3-certifi-2019.3.9-1.1.noarch.rpm


Advertisement

Description

python3-certifi - Python package for providing Mozilla's CA Bundle

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-certifi-2019.3.9-1.1.noarch.rpm
Package name python3-certifi
Package version 2019.3.9
Package release 1.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://pypi.python.org/pypi/certifi
License MPL-2.0
Maintainer -
Download size 15.95 KB
Installed size 6.79 KB
This installable Python package contains a CA Bundle that you can reference
in your Python code. This is useful for verifying HTTP requests, for example.
This is the same CA Bundle which ships with the Requests codebase, and is
derived from Mozilla Firefox's canonical set.

Alternatives

Package Version Architecture Repository
python3-certifi - - -

Requires

Name Value
ca-certificates -
ca-certificates-mozilla -
python(abi) = 3.7

Provides

Name Value
python3-certifi = 2019.3.9-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-certifi-2019.3.9-1.1.noarch.rpm
Source Package python-certifi-2019.3.9-1.1.src.rpm

Install Howto

Install python3-certifi rpm package:

# zypper install python3-certifi

Files

Path
/usr/lib/python3.7/site-packages/certifi/__init__.py
/usr/lib/python3.7/site-packages/certifi/__main__.py
/usr/lib/python3.7/site-packages/certifi/core.py
/usr/lib/python3.7/site-packages/certifi-2019.3.9-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/certifi-2019.3.9-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/certifi-2019.3.9-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/certifi-2019.3.9-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/certifi-2019.3.9-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/certifi/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/certifi/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/certifi/__pycache__/__main__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/certifi/__pycache__/__main__.cpython-37.pyc
/usr/lib/python3.7/site-packages/certifi/__pycache__/core.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/certifi/__pycache__/core.cpython-37.pyc
/usr/share/doc/packages/python3-certifi/README.rst
/usr/share/licenses/python3-certifi/LICENSE

Changelog

2019-03-11 - Tomá? Chvátal <tchvatal@suse.com>
- Update to 2019.3.9:
* Add emSign Root CA - G1
* Add emSign ECC Root CA - G3
* Add Hongkong Post Root CA 3
- Rebase python-certifi-shipped-requests-cabundle.patch
2019-02-11 - John Vandenberg <jayvdb@gmail.com>
- Update to 2018.11.29
* Deprecated old_where() has been removed
* Removed certificates
+ Visa eCommerce Root
+ Certplus Root CA G1
+ Certplus Root CA G2
+ OpenTrust Root CA G1
+ OpenTrust Root CA G2
+ OpenTrust Root CA G3
2019-01-08 - Jonathan Brownell <jbrownell@suse.com>
- Limit SUSE certificate patch to exclude Red Hat platforms since
the relevant /etc/ssl/ca-bundle.pem does not exist there
- %py_compile and %py3_compile macros do not exist on Red Hat;
substitute them with equivalent %python_exec invocations
2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-04-17 - michael@stroeder.com
- update to 2018.4.16
* Remove Elektronik Sertifika Hizket from cacert.pem
- This is noop as we use our cacert list from /etc/ssl/ca-bundle.pem
2018-02-04 - arun@gmx.de
- specfile:
* update copyright year
- update to version 2018.1.18:
* Remove 1024-bit root certificates
* Include license in the list of trove classifiers
* Include license file in the generated wheel package
2017-11-14 - dmueller@suse.com
- update to 2017.11.5:
* Sync with bundle mozilla release
- remove  python-certifi-fix-version-string.patch: obsolete
2017-10-18 - jmatejek@suse.com
- fix macros to support not having python2
2017-10-12 - adrian.glaubitz@suse.com
- add patch to fix version string from 2017.07.27.1 to
2017.7.27.1 to fix the build on SLE12_SP3 and earlier
+ python-certifi-fix-version-string.patch
2017-10-03 - arun@gmx.de
- updated patch
- update to version 2017.7.27.1:
* Use a more expressive API for getting the dir a path is in
* set zip_safe=False to help out setuptools (#63)
* Change license from ISC to MPL-2.0 in setup.py
* Add trove classifiers for missing supported Python versions
* Rename [wheel] section to [bdist_wheel] as the former is legacy

See Also

Package Description
python3-certstream-1.10-1.1.noarch.rpm Python library for receiving certificate transparency list updates
python3-cffi-1.12.3-1.1.i586.rpm Foreign Function Interface for Python calling C code
python3-cffi-1.12.3-1.1.x86_64.rpm Foreign Function Interface for Python calling C code
python3-cfgv-1.6.0-2.1.noarch.rpm Configuration validator producing human readable error messages
python3-cfscrape-1.9.7-1.1.noarch.rpm Python module to bypass Cloudflare's anti-bot page
python3-cftime-1.0.3.4-1.1.i586.rpm Time-handling functionality from netcdf4-python
python3-cftime-1.0.3.4-1.1.x86_64.rpm Time-handling functionality from netcdf4-python
python3-chai-1.1.2-3.2.noarch.rpm Mocking/stub framework for Python
python3-characteristic-14.3.0-4.2.noarch.rpm Python class decorator to implement attribute-related object protocols
python3-chardet-3.0.4-6.1.noarch.rpm Universal encoding detector
python3-check-manifest-0.37-1.2.noarch.rpm Check MANIFEST in a Python source package for completeness
python3-cheroot-6.5.4-1.1.noarch.rpm Highly-optimized, pure-python HTTP server
python3-chest-0.2.3-1.2.noarch.rpm Spill-to-disk dictionary for Python
python3-cinderclient-4.1.0-1.1.noarch.rpm Python API and CLI for OpenStack Cinder
python3-ciscoconfparse-1.3.32-1.1.noarch.rpm Library for parsing, querying and modifying Cisco IOS-style configurations
Advertisement
Advertisement