python3-bleach-3.1.0-1.1.noarch.rpm


Advertisement

Description

python3-bleach - A whitelist-based HTML-sanitizing tool

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-bleach-3.1.0-1.1.noarch.rpm
Package name python3-bleach
Package version 3.1.0
Package release 1.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage http://github.com/jsocol/bleach
License Apache-2.0
Maintainer -
Download size 54.97 KB
Installed size 189.09 KB
Bleach is an HTML sanitation library that escapes or strips markup and
attributes based on a white list. Bleach can also linkify text safely, applying
filters that Django's ``urlize`` filter cannot, and optionally setting ``rel``
attributes, even on links already in the text.
Bleach is intended for sanitizing text from *untrusted* sources.
Because it relies on html5lib, Bleach is as good as modern browsers at dealing
with weird, quirky HTML fragments. Bleach's methods will fix
unbalanced or mis-nested tags.
Documentation is at http://bleach.readthedocs.org/ .

Alternatives

Package Version Architecture Repository
python3-bleach - - -

Requires

Name Value
python(abi) = 3.7
python3-html5lib >= 1.0.0
python3-six >= 1.9

Provides

Name Value
python3-bleach = 3.1.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-bleach-3.1.0-1.1.noarch.rpm
Source Package python-bleach-3.1.0-1.1.src.rpm

Install Howto

Install python3-bleach rpm package:

# zypper install python3-bleach

Files

Path
/usr/lib/python3.7/site-packages/bleach/__init__.py
/usr/lib/python3.7/site-packages/bleach/callbacks.py
/usr/lib/python3.7/site-packages/bleach/html5lib_shim.py
/usr/lib/python3.7/site-packages/bleach/linkifier.py
/usr/lib/python3.7/site-packages/bleach/sanitizer.py
/usr/lib/python3.7/site-packages/bleach/utils.py
/usr/lib/python3.7/site-packages/bleach-3.1.0-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/bleach-3.1.0-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/bleach-3.1.0-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/bleach-3.1.0-py3.7.egg-info/not-zip-safe
/usr/lib/python3.7/site-packages/bleach-3.1.0-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/bleach-3.1.0-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/bleach/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/callbacks.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/callbacks.cpython-37.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/html5lib_shim.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/html5lib_shim.cpython-37.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/linkifier.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/linkifier.cpython-37.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/sanitizer.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/sanitizer.cpython-37.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/utils.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/bleach/__pycache__/utils.cpython-37.pyc
/usr/share/doc/packages/python3-bleach/CHANGES
/usr/share/doc/packages/python3-bleach/README.rst
/usr/share/licenses/python3-bleach/LICENSE

Changelog

2019-03-03 - John Vandenberg <jayvdb@gmail.com>
- Add de-vendor.patch to avoid new vendoring of html5lib in v3.1.0
- Remove direct dependency on webencodings, a dependency of html5lib
- Update to v3.1.0
* Add ``recognized_tags`` argument to the linkify ``Linker`` class. This
fixes issues when linkifying on its own and having some tags get escaped.
It defaults to a list of HTML5 tags
* Add ``six>=1.9`` to requirements
* Fix cases where attribute names could have invalid characters in them.
* Fix problems with ``LinkifyFilter`` not being able to match links
across ``&amp;``.
* Fix ``InputStreamWithMemory`` when the ``BleachHTMLParser`` is
parsing ``meta`` tags
* Fix doctests.
- from v3.0.2
* Merge ``Characters`` tokens after sanitizing them. This fixes issues
in the ``LinkifyFilter`` where it was only linkifying parts of urls
- from v3.0.1
* Support Python 3.7. It supported Python 3.7 just fine, but 3.7 was
added to the list of Python environments being test
* Fix ``list`` object has no attribute ``lower`` in ``clean``
* Fix ``abbr`` getting escaped in ``linkify``
- from v3.0.0
* [breaking] A bunch of functions were moved from one module to another.
These were moved from ``bleach.sanitizer`` to ``bleach.html5lib_shim``:
+ convert_entity
+ convert_entities
+ match_entity
+ next_possible_entity
+ BleachHTMLSerializer
+ BleachHTMLTokenizer
+ BleachHTMLParser
These functions and classes weren't documented and aren't part of the
public API, but people read code and might be using them so we're
considering it an incompatible API change.
If you're using them, you'll need to update your code.
* Bleach no longer depends on html5lib. html5lib==1.0.1 is now vendored into
Bleach. You can remove it from your requirements file if none of your other
requirements require html5lib.
This means Bleach will now work fine with other libraries that depend on
html5lib regardless of what version of html5lib they require.
* Fixed tags getting added when using clean or linkify. This was a
long-standing regression from the Bleach 2.0 rewrite
* Fixed ``<isindex>`` getting replaced with a string. Now it gets escaped or
stripped depending on whether it's in the allowed tags or not
- from v2.1.4
* Dropped support for Python 3.3
* Handle ambiguous ampersands in correctly
2018-12-05 - Jan Engelhardt <jengelh@inai.de>
- Trim rhetorics and bias from descriptions.
2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-03-20 - kbabioch@suse.com
- Update to version 2.1.3:
* Attributes that have URI values weren't properly sanitized if the
values contained character entities. Using character entities, it
was possible to construct a URI value with a scheme that was not
allowed that would slide through unsanitized.
(CVE-2018-7753 bnc#1085969)
2017-12-07 - arun@gmx.de
- specfile:
* update copyright year
- update to version 2.1.2:
* Bug fixes
+ Support html5lib-python 1.0.1. (#337)
+ Add deprecation warning for supporting html5lib-python < 1.0.
+ Switch to semver.

See Also

Package Description
python3-blessed-1.15.0-1.1.noarch.rpm Wrapper around terminal styling, screen positioning, and keyboard input
python3-blessings-1.7-1.2.noarch.rpm A thin, practical wrapper around terminal capabilities in Python
python3-blinker-1.4-4.2.noarch.rpm Object-to-object and broadcast signaling in Python
python3-blist-1.3.6-3.3.i586.rpm A list-like type with better asymptotic performance
python3-blist-1.3.6-3.3.x86_64.rpm A list-like type with better asymptotic performance
python3-blockdiag-1.5.4-1.1.noarch.rpm Program to generate block-diagram images from text
python3-blosc-1.6.2-1.3.i586.rpm Blosc data compressor for Python
python3-blosc-1.6.2-1.3.x86_64.rpm Blosc data compressor for Python
python3-bloscpack-0.15.0-1.2.noarch.rpm Command line interface and serialization format for Blosc
python3-bobo-2.4.0-3.2.noarch.rpm Web application framework for the impatient
python3-bobodoctestumentation-2.4.0-2.2.noarch.rpm Bobo tests and documentation
python3-bokeh-1.0.4-1.2.noarch.rpm Statistical interactive HTML plots for Python
python3-boltons-19.1.0-1.1.noarch.rpm The "Boltons" utility package for Python
python3-boost_parallel_mpi-1.69.0-1.1.noarch.rpm Python 3.x bindings for Boost.Parallel.MPI library
python3-boost_parallel_mpi1_69_0-1.69.0-1.1.i586.rpm Python 3.x bindings for Boost.Parallel.MPI library
Advertisement
Advertisement