python3-PyJWT-1.7.1-2.1.noarch.rpm


Advertisement

Description

python3-PyJWT - JSON Web Token implementation in Python

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python3-PyJWT-1.7.1-2.1.noarch.rpm
Package name python3-PyJWT
Package version 1.7.1
Package release 2.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/progrium/pyjwt
License MIT
Maintainer -
Download size 49.86 KB
Installed size 139.93 KB
A Python implementation of JSON Web Token draft 01.

Alternatives

Package Version Architecture Repository
python3-PyJWT - - -

Requires

Name Value
/usr/bin/python3 -
python(abi) = 3.7
python3-cryptography >= 1.4
python3-ecdsa -
python3-setuptools -
update-alternatives -

Provides

Name Value
python3-PyJWT = 1.7.1-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python3-PyJWT-1.7.1-2.1.noarch.rpm
Source Package python-PyJWT-1.7.1-2.1.src.rpm

Install Howto

Install python3-PyJWT rpm package:

# zypper install python3-PyJWT

Files

Path
/etc/alternatives/pyjwt
/usr/bin/pyjwt
/usr/bin/pyjwt-3.7
/usr/lib/python3.7/site-packages/PyJWT-1.7.1-py3.7.egg-info/PKG-INFO
/usr/lib/python3.7/site-packages/PyJWT-1.7.1-py3.7.egg-info/SOURCES.txt
/usr/lib/python3.7/site-packages/PyJWT-1.7.1-py3.7.egg-info/dependency_links.txt
/usr/lib/python3.7/site-packages/PyJWT-1.7.1-py3.7.egg-info/entry_points.txt
/usr/lib/python3.7/site-packages/PyJWT-1.7.1-py3.7.egg-info/requires.txt
/usr/lib/python3.7/site-packages/PyJWT-1.7.1-py3.7.egg-info/top_level.txt
/usr/lib/python3.7/site-packages/jwt/__init__.py
/usr/lib/python3.7/site-packages/jwt/__main__.py
/usr/lib/python3.7/site-packages/jwt/algorithms.py
/usr/lib/python3.7/site-packages/jwt/api_jws.py
/usr/lib/python3.7/site-packages/jwt/api_jwt.py
/usr/lib/python3.7/site-packages/jwt/compat.py
/usr/lib/python3.7/site-packages/jwt/exceptions.py
/usr/lib/python3.7/site-packages/jwt/help.py
/usr/lib/python3.7/site-packages/jwt/utils.py
/usr/lib/python3.7/site-packages/jwt/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/__main__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/__main__.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/algorithms.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/algorithms.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/api_jws.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/api_jws.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/api_jwt.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/api_jwt.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/compat.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/compat.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/exceptions.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/exceptions.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/help.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/help.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/utils.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/__pycache__/utils.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/__init__.py
/usr/lib/python3.7/site-packages/jwt/contrib/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/__init__.py
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/py_ecdsa.py
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/pycrypto.py
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/__pycache__/py_ecdsa.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/__pycache__/py_ecdsa.cpython-37.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/__pycache__/pycrypto.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/jwt/contrib/algorithms/__pycache__/pycrypto.cpython-37.pyc
/usr/share/doc/packages/python3-PyJWT/AUTHORS
/usr/share/doc/packages/python3-PyJWT/CHANGELOG.md
/usr/share/doc/packages/python3-PyJWT/README.rst
/usr/share/licenses/python3-PyJWT/LICENSE

Changelog

2019-03-07 - Tomá? Chvátal <tchvatal@suse.com>
- Fix fdupes and test calls
2019-02-04 - Hans-Peter Jansen <hpj@urpla.net>
- update to version 1.7.1:
* Update test dependencies with pinned ranges
* Fix pytest deprecation warnings
- update to version v1.7.0:
* Remove CRLF line endings #353
* Update usage.rst #360
* Support for Python 3.7 #375 #379 #384
- removed pyjwt-pytest390.patch (fixed upstream)
- removed pyjwt-python37.patch (fixed upstream)
- removed dos2unix conversion of jwt/__main__.py (fixed upstream)
- add test build conditional
2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-11-27 - John Paul Adrian Glaubitz <adrian.glaubitz@suse.com>
- Add patch to fix testsuite with pytest 3.9.0:
* pyjwt-pytest390.patch
2018-11-14 - Tomá? Chvátal <tchvatal@suse.com>
- Add patch to build with python 3.7:
* pyjwt-python37.patch
2018-07-07 - arun@gmx.de
- update to version 1.6.4:
* Reverse an unintentional breaking API change to .decode() #352
2018-05-23 - tchvatal@suse.com
- Version update to 1.6.3:
* Dropped support for python 2.6 and 3.3 #301
* An invalid signature now raises an InvalidSignatureError instead of DecodeError #316
* Fix over-eager fallback to stdin #304
* Audience parameter throws InvalidAudienceError when application does not specify an audience, but the token does. #336
* All exceptions inherit from PyJWTError #340
* Add type hints #344
* Add help module 7ca41e5
- Drop pointless _service file
2018-02-23 - tbechtold@suse.com
- Avoid not needed python-pytest-cov and python-pytest-runner
BuildRequires. There is no need todo a coverage run during
package build.
2017-11-02 - arun@gmx.de
- update to version 1.5.3:
* Changed
+ Increase required version of the cryptography package to
>=1.4.0.
* Fixed
+ Remove uses of deprecated functions from the cryptography
package.
+ Warn about missing algorithms param to decode() only when verify
param is True #281
2017-08-21 - tbechtold@suse.com
- update to 1.5.2:
- Ensure correct arguments order in decode super call [7c1e61d][7c1e61d]
- Change optparse for argparse. [#238][238]
- Guard against PKCS1 PEM encododed public keys [#277][277]
- Add deprecation warning when decoding without specifying `algorithms` [#277][277]
- Improve deprecation messages [#270][270]
- PyJWT.decode: move verify param into options [#271][271]
- Support for Python 3.6 [#262][262]
- Expose jwt.InvalidAlgorithmError [#264][264]
- Add support for ECDSA public keys in RFC 4253 (OpenSSH) format [#244][244]
- Renamed commandline script `jwt` to `jwt-cli` to avoid issues with the script clobbering the `jwt` module in some circumstances. [#187][187]
- Better error messages when using an algorithm that requires the cryptography package, but it isn't available [#230][230]
- Tokens with future 'iat' values are no longer rejected [#190][190]
- Non-numeric 'iat' values now raise InvalidIssuedAtError instead of DecodeError
- Remove rejection of future 'iat' claims [#252][252]
- Add back 'ES512' for backward compatibility (for now) [#225][225]
- Fix incorrectly named ECDSA algorithm [#219][219]
- Fix rpm build [#196][196]
- Add JWK support for HMAC and RSA keys [#202][202]

See Also

Package Description
python3-PyKMIP-0.8.0-1.3.noarch.rpm KMIP v11 library
python3-PyMeta3-0.5.1-1.1.noarch.rpm Pattern-matching language based on OMeta for Python 3 and 2
python3-PyMsgBox-1.0.6-3.2.noarch.rpm A Python module for JavaScript-like message boxes
python3-PyMySQL-0.9.3-1.1.noarch.rpm Pure Python MySQL Driver
python3-PyNaCl-1.3.0-1.2.i586.rpm Python binding to the Networking and Cryptography (NaCl) library
python3-PyNaCl-1.3.0-1.2.x86_64.rpm Python binding to the Networking and Cryptography (NaCl) library
python3-PyNamecheap-0.0.3-1.2.noarch.rpm Namecheap API client in Python
python3-PyOgg-0.6.9a1-1.1.noarch.rpm Python bindings for Xiphorg's Ogg Vorbis, Opus and FLAC
python3-PyOpenAL-0.7.7a1-1.1.noarch.rpm Python bindings for OpenAL
python3-PyPDF2-1.26.0-3.2.noarch.rpm PDF toolkit
python3-PyPrind-2.11.2-1.1.noarch.rpm Python progress bar and percent indicator utility
python3-PyPrint-0.2.6-3.2.noarch.rpm A printer library for Python
python3-PyQRCode-1.3.0-2.1.noarch.rpm Python 3 module to generate QR Codes
python3-PyRIC-0.1.6.3-2.2.noarch.rpm Python Wireless Library
python3-PySDL2-0.9.6-2.2.noarch.rpm Python SDL2 bindings
Advertisement
Advertisement