python2-spec-1.4.1-2.2.noarch.rpm


Advertisement

Description

python2-spec - Specification-style output for nose

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-spec-1.4.1-2.2.noarch.rpm
Package name python2-spec
Package version 1.4.1
Package release 2.2
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/bitprophet/spec
License MIT
Maintainer -
Download size 30.61 KB
Installed size 68.62 KB
spec is a Python testing tool that provides colorized, specification style output, colorized tracebacks and summary, optional timing display and enables some non-default options of nose.

Alternatives

Package Version Architecture Repository
python2-spec - - -

Requires

Name Value
/usr/bin/python2 -
python(abi) = 2.7
python2-nose >= 1.3
python2-six < 2.0

Provides

Name Value
python-spec = 1.4.1-2.2
python2-spec = 1.4.1-2.2

Obsoletes

Name Value
python-spec < 1.4.1-2.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-spec-1.4.1-2.2.noarch.rpm
Source Package python-spec-1.4.1-2.2.src.rpm

Install Howto

Install python2-spec rpm package:

# zypper install python2-spec

Files

Path
/usr/bin/spec-2.7
/usr/lib/python2.7/site-packages/spec/__init__.py
/usr/lib/python2.7/site-packages/spec/__init__.pyc
/usr/lib/python2.7/site-packages/spec/__init__.pyo
/usr/lib/python2.7/site-packages/spec/_version.py
/usr/lib/python2.7/site-packages/spec/_version.pyc
/usr/lib/python2.7/site-packages/spec/_version.pyo
/usr/lib/python2.7/site-packages/spec/cli.py
/usr/lib/python2.7/site-packages/spec/cli.pyc
/usr/lib/python2.7/site-packages/spec/cli.pyo
/usr/lib/python2.7/site-packages/spec/plugin.py
/usr/lib/python2.7/site-packages/spec/plugin.pyc
/usr/lib/python2.7/site-packages/spec/plugin.pyo
/usr/lib/python2.7/site-packages/spec/trap.py
/usr/lib/python2.7/site-packages/spec/trap.pyc
/usr/lib/python2.7/site-packages/spec/trap.pyo
/usr/lib/python2.7/site-packages/spec/utils.py
/usr/lib/python2.7/site-packages/spec/utils.pyc
/usr/lib/python2.7/site-packages/spec/utils.pyo
/usr/lib/python2.7/site-packages/spec-1.4.1-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/spec-1.4.1-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/spec-1.4.1-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/spec-1.4.1-py2.7.egg-info/entry_points.txt
/usr/lib/python2.7/site-packages/spec-1.4.1-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/spec-1.4.1-py2.7.egg-info/top_level.txt
/usr/share/licenses/python2-spec/LICENSE

Changelog

2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-03-03 - sebix+novell.com@sebix.at
- initial package for version 1.4.1

See Also

Package Description
python2-sphinx-bootstrap-theme-0.7.1-1.1.noarch.rpm Sphinx Bootstrap Theme
python2-sphinx-feature-classification-0.3.2-1.1.noarch.rpm Sphinx extension to generate a matrix of pluggable drivers
python2-sphinx-issues-1.2.0-1.1.noarch.rpm A Sphinx extension for linking to a project's issue tracker
python2-sphinx-removed-in-0.2.0-1.1.noarch.rpm Sphinx directives versionremoved and removed-in
python2-sphinx-testing-1.0.0-1.1.noarch.rpm Testing utility classes and functions for Sphinx extensions
python2-sphinx-version-warning-1.1.2-1.1.noarch.rpm Sphinx extension to add a warning banner
python2-sphinx_rtd_theme-0.4.1-1.2.noarch.rpm ReadTheDocs.org theme for Sphinx
python2-sphinxbase-0.8-3.1.i586.rpm Python bindings for sphinxbase required by python-pocketsphinx
python2-sphinxbase-0.8-3.1.x86_64.rpm Python bindings for sphinxbase required by python-pocketsphinx
python2-sphinxcontrib-actdiag-0.8.5-3.2.noarch.rpm Sphinx actdiag extension
python2-sphinxcontrib-apidoc-0.3.0-1.1.noarch.rpm A Sphinx extension for running 'sphinx-apidoc' on each build
python2-sphinxcontrib-asyncio-0.2.0-3.2.noarch.rpm Sphinx extension to support coroutines in markup
python2-sphinxcontrib-autoprogram-0.1.5-2.2.noarch.rpm Sphinx extension to document CLI programs
python2-sphinxcontrib-autoprogram-doc-0.1.5-2.2.noarch.rpm Documentation for sphinxcontrib-autoprogram
python2-sphinxcontrib-blockdiag-1.5.5-3.2.noarch.rpm Sphinx "blockdiag" extension
Advertisement
Advertisement