python2-requests-aws-0.1.8-2.2.noarch.rpm


Advertisement

Description

python2-requests-aws - AWS authentication for Amazon S3 for the python requests module

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-requests-aws-0.1.8-2.2.noarch.rpm
Package name python2-requests-aws
Package version 0.1.8
Package release 2.2
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/tax/python-requests-aws
License BSD-3-Clause
Maintainer -
Download size 15.03 KB
Installed size 17.41 KB
AWS authentication for Amazon S3 for the Python "requests" library.
It is made to work with Python 2.7 and 3.
At the moment, only S3 is supported.

Alternatives

Package Version Architecture Repository
python2-requests-aws - - -

Requires

Name Value
python(abi) = 2.7
python2-requests >= 2.4.1

Provides

Name Value
python-requests-aws = 0.1.8-2.2
python2-requests-aws = 0.1.8-2.2

Obsoletes

Name Value
python-requests-aws < 0.1.8-2.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-requests-aws-0.1.8-2.2.noarch.rpm
Source Package python-requests-aws-0.1.8-2.2.src.rpm

Install Howto

Install python2-requests-aws rpm package:

# zypper install python2-requests-aws

Files

Path
/usr/lib/python2.7/site-packages/awsauth.py
/usr/lib/python2.7/site-packages/awsauth.pyc
/usr/lib/python2.7/site-packages/awsauth.pyo
/usr/lib/python2.7/site-packages/requests_aws-0.1.8-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/requests_aws-0.1.8-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/requests_aws-0.1.8-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/requests_aws-0.1.8-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/requests_aws-0.1.8-py2.7.egg-info/top_level.txt
/usr/share/doc/packages/python2-requests-aws/README.md
/usr/share/licenses/python2-requests-aws/LICENSE.txt

Changelog

2018-04-30 - jengelh@inai.de
- Trim bias and uninterpreted markup from description.
2018-04-30 - tchvatal@suse.com
- Use license macro
2017-07-03 - tbechtold@suse.com
- convert to singlespec
- update Source url
2015-11-12 - vuntz@suse.com
- Drop unused README.txt: this is just duplicating documentation
from README.md which is installed in the package.
2015-10-26 - mmnelemane@suse.com
- Updated License field
- Moved Usage instructions to README.txt
2015-10-26 - mmnelemane@suse.com
- Submission for IBS
2015-10-26 - mmnelemane@suse.com
- Added new package requests-aws
- Unit tests are not run as they require internet connection.
- The package is used by openstack components for aws authentication.
- one immediate usage is by ceilometer object-store using rados gateway
- Ceilometer authenticates with RGW using S3Auth provided by this package.

See Also

Package Description
python2-requests-cache-0.4.13-2.2.noarch.rpm Persistent cache for requests library
python2-requests-file-1.4.3-2.2.noarch.rpm File transport adapter for Requests
python2-requests-ftp-0.3.1-3.2.noarch.rpm FTP Transport Adapter for Requests
python2-requests-futures-0.9.7-2.3.noarch.rpm Asynchronous Python HTTP Requests for Humans using Futures
python2-requests-hawk-1.0.0-2.2.noarch.rpm Hawk authentication strategy for the requests python library
python2-requests-kerberos-0.12.0-1.1.noarch.rpm A Kerberos authentication handler for python-requests
python2-requests-mock-1.5.2-1.1.noarch.rpm Mock out responses from the requests package
python2-requests-oauthlib-1.2.0-1.1.noarch.rpm OAuthlib authentication support for Requests
python2-requests-toolbelt-0.8.0-1.4.noarch.rpm A utility belt for advanced users of python3-requests
python2-requests-unixsocket-0.1.5-2.1.noarch.rpm UNIX domain socket backend for python-requests
python2-requests_ntlm-1.1.0-2.2.noarch.rpm NTLM authentication for the python-requests library
python2-requestsexceptions-1.4.0-1.1.noarch.rpm Import exceptions from potentially bundled packages in requests
python2-requirementslib-1.4.2-1.1.noarch.rpm A tool for converting between pip-style and pipfile requirements
python2-resampy-0.2.1-2.2.noarch.rpm Signal resampling in Python
python2-resolvelib-0.2.2-2.1.noarch.rpm Module to resolve abstract dependencies into concrete ones
Advertisement
Advertisement