python2-qt4-4.12.3-1.4.x86_64.rpm


Advertisement

Description

python2-qt4 - PyQt - python bindings for Qt 4

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-qt4-4.12.3-1.4.x86_64.rpm
Package name python2-qt4
Package version 4.12.3
Package release 1.4
Package architecture x86_64
Package type rpm
Category Development/Libraries/Python
Homepage http://www.riverbankcomputing.com/software/pyqt/intro
License SUSE-GPL-2.0-with-FLOSS-exception or GPL-3.0 or SUSE-NonFree
Maintainer -
Download size 2.45 MB
Installed size 15.30 MB
PyQt is a set of Python bindings for Trolltech's Qt application
framework and runs on all platforms supported by Qt including Windows,
MacOS/X and Linux. There are two sets of bindings: PyQt v4 supports Qt
v4; and the older PyQt v3 supports Qt v3 and earlier. The bindings are
implemented as a set of Python modules and contain over 300 classes and
nearly 6,000 functions and methods.

Alternatives

Package Version Architecture Repository
python2-qt4-4.12.3-1.4.i586.rpm 4.12.3 i586 openSUSE Oss
python2-qt4 - - -

Requires

Name Value
libQtCore.so.4()(64bit) -
libQtDBus.so.4()(64bit) -
libQtDeclarative.so.4()(64bit) -
libQtDesigner.so.4()(64bit) -
libQtGui.so.4()(64bit) -
libQtHelp.so.4()(64bit) -
libQtMultimedia.so.4()(64bit) -
libQtNetwork.so.4()(64bit) -
libQtOpenGL.so.4()(64bit) -
libQtScript.so.4()(64bit) -
libQtScriptTools.so.4()(64bit) -
libQtSql.so.4()(64bit) -
libQtSvg.so.4()(64bit) -
libQtTest.so.4()(64bit) -
libQtXml.so.4()(64bit) -
libQtXmlPatterns.so.4()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libdbus-1.so.3()(64bit) -
libdbus-1.so.3(LIBDBUS_1_3)(64bit) -
libphonon.so.4()(64bit) -
libqt4-x11 >= 4.8.7
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
python(abi) = 2.7
python2-dbus-python >= 1.2.8
python2-qt4-utils -
python2-sip(api) = 12.6

Provides

Name Value
python-qt4 = 4.12.3-1.4
python2-PyQt4 = 4.12.3
python2-qt4 = 4.12.3-1.4
python2-qt4(x86-64) = 4.12.3-1.4

Obsoletes

Name Value
python-qt4 < 4.12.3-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-qt4-4.12.3-1.4.x86_64.rpm
Source Package python-qt4-4.12.3-1.4.src.rpm

Install Howto

Install python2-qt4 rpm package:

# zypper install python2-qt4

Files

Path
/usr/lib/python2.7/site-packages/dbus/mainloop/qt.so
/usr/lib64/python2.7/site-packages/PyQt4/Qt.so
/usr/lib64/python2.7/site-packages/PyQt4/QtCore.so
/usr/lib64/python2.7/site-packages/PyQt4/QtDBus.so
/usr/lib64/python2.7/site-packages/PyQt4/QtDeclarative.so
/usr/lib64/python2.7/site-packages/PyQt4/QtDesigner.so
/usr/lib64/python2.7/site-packages/PyQt4/QtGui.so
/usr/lib64/python2.7/site-packages/PyQt4/QtHelp.so
/usr/lib64/python2.7/site-packages/PyQt4/QtMultimedia.so
/usr/lib64/python2.7/site-packages/PyQt4/QtNetwork.so
/usr/lib64/python2.7/site-packages/PyQt4/QtOpenGL.so
/usr/lib64/python2.7/site-packages/PyQt4/QtScript.so
/usr/lib64/python2.7/site-packages/PyQt4/QtScriptTools.so
/usr/lib64/python2.7/site-packages/PyQt4/QtSql.so
/usr/lib64/python2.7/site-packages/PyQt4/QtSvg.so
/usr/lib64/python2.7/site-packages/PyQt4/QtTest.so
/usr/lib64/python2.7/site-packages/PyQt4/QtXml.so
/usr/lib64/python2.7/site-packages/PyQt4/QtXmlPatterns.so
/usr/lib64/python2.7/site-packages/PyQt4/__init__.py
/usr/lib64/python2.7/site-packages/PyQt4/phonon.so
/usr/lib64/python2.7/site-packages/PyQt4/uic/__init__.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/driver.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/exceptions.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/icon_cache.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/objcreator.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/properties.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/pyuic.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/uiparser.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Compiler/__init__.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Compiler/compiler.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Compiler/indenter.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Compiler/misc.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Compiler/proxy_metaclass.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Compiler/qobjectcreator.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Compiler/qtproxies.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Loader/__init__.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Loader/loader.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/Loader/qobjectcreator.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v2/__init__.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v2/as_string.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v2/ascii_upper.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v2/invoke.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v2/load_plugin.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v2/proxy_base.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v2/string_io.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v3/__init__.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v3/as_string.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v3/ascii_upper.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v3/invoke.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v3/load_plugin.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v3/proxy_base.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/port_v3/string_io.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/widget-plugins/phonon.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/widget-plugins/qaxcontainer.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/widget-plugins/qscintilla.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/widget-plugins/qtdeclarative.py
/usr/lib64/python2.7/site-packages/PyQt4/uic/widget-plugins/qtwebkit.py
/usr/share/doc/packages/python2-qt4/ChangeLog
/usr/share/doc/packages/python2-qt4/LICENSE
/usr/share/doc/packages/python2-qt4/NEWS
/usr/share/doc/packages/python2-qt4/README
/usr/share/doc/packages/python2-qt4/THANKS

Changelog

2018-12-08 - Todd R <toddrme2178@gmail.com>
- Remove QtWebkit again.
2018-12-07 - Todd R <toddrme2178@gmail.com>
- Update to version 4.12.3
- This is planned to be the last ever release of PyQt4.
- Bug fixes.
- Update to version 4.12.2
- A private copy of the sip module called PyQt4.sip is required.
- SIP v4.19.12 is now required.  SIP v5 is not supported.
- Fix python2 version calling python3 version.
- Build QtWebkit bindings, needed by some packages (e.g. Spyder)
2017-12-02 - fabian@ritter-vogt.de
- Do not build with Qt4 WebKit:
* Vade retro satana
2017-08-29 - toddrme2178@gmail.com
- Fix shebangs
2017-08-28 - toddrme2178@gmail.com
- Update to 4.12.1
* SIP v4.19.1 is now required.
* Bug fixes.
2017-06-04 - antoine.belvire@opensuse.org
- Move requirements for development package to correct place.
2017-05-22 - bwiedemann@suse.com
- Add reproducible.patch to sort input files to make build fully reproducible
2017-05-16 - toddrme2178@gmail.com
- Fix issues with requires.
Fixes bnc#1037475
2017-05-04 - toddrme2178@gmail.com
- Fix issues with update-alternatives.
2017-04-19 - toddrme2178@gmail.com
- Remove unneeded link-python.diff and link-python3.diff.

See Also

Package Description
python2-qt4-devel-4.12.3-1.4.i586.rpm PyQt - devel part of python bindings for Qt 4
python2-qt4-devel-4.12.3-1.4.x86_64.rpm PyQt - devel part of python bindings for Qt 4
python2-qt5-5.12.1-1.2.i586.rpm Python bindings for Qt 5
python2-qt5-5.12.1-1.2.x86_64.rpm Python bindings for Qt 5
python2-qt5-devel-5.12.1-1.2.i586.rpm PyQt - devel part of python bindings for Qt 5
python2-qt5-devel-5.12.1-1.2.x86_64.rpm PyQt - devel part of python bindings for Qt 5
python2-qtcharts-qt5-5.12-2.1.i586.rpm Python bindings for the Qt5 Charts library
python2-qtcharts-qt5-5.12-2.1.x86_64.rpm Python bindings for the Qt5 Charts library
python2-qtdatavis3d-qt5-5.12-2.1.i586.rpm Python bindings for the Qt5 Data Visualization library
python2-qtdatavis3d-qt5-5.12-2.1.x86_64.rpm Python bindings for the Qt5 Data Visualization library
python2-qtwebengine-qt5-5.12-1.1.i586.rpm Python bindings for the Qt5 WebEngine framework
python2-qtwebengine-qt5-5.12-1.1.x86_64.rpm Python bindings for the Qt5 WebEngine framework
python2-queuelib-1.5.0-2.2.noarch.rpm Collection of Persistent (Disk-Based) Queues
python2-quicktions-1.6-2.2.i586.rpm Fast fractions data type for rational numbers
python2-quicktions-1.6-2.2.x86_64.rpm Fast fractions data type for rational numbers
Advertisement
Advertisement