python2-pyzmq-devel-18.0.1-1.1.x86_64.rpm


Advertisement

Description

python2-pyzmq-devel - Development files for python2-pyzmq

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-pyzmq-devel-18.0.1-1.1.x86_64.rpm
Package name python2-pyzmq-devel
Package version 18.0.1
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Languages/Python
Homepage http://github.com/zeromq/pyzmq
License LGPL-3.0-or-later AND BSD-3-Clause
Maintainer -
Download size 20.16 KB
Installed size 27.14 KB
Development libraries and headers needed to build software using python2-pyzmq.

Alternatives

Package Version Architecture Repository
python2-pyzmq-devel-18.0.1-1.1.i586.rpm 18.0.1 i586 openSUSE Oss
python2-pyzmq-devel - - -

Requires

Name Value
python2-devel -
python2-pyzmq = 18.0.1
zeromq-devel -

Provides

Name Value
python-pyzmq-devel = 18.0.1-1.1
python2-pyzmq-devel = 18.0.1-1.1
python2-pyzmq-devel(x86-64) = 18.0.1-1.1

Obsoletes

Name Value
python-pyzmq-devel < 18.0.1-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-pyzmq-devel-18.0.1-1.1.x86_64.rpm
Source Package python-pyzmq-18.0.1-1.1.src.rpm

Install Howto

Install python2-pyzmq-devel rpm package:

# zypper install python2-pyzmq-devel

Files

Path
/usr/lib64/python2.7/site-packages/zmq/backend/cffi/_cdefs.h
/usr/lib64/python2.7/site-packages/zmq/backend/cffi/_verify.c
/usr/lib64/python2.7/site-packages/zmq/utils/getpid_compat.h
/usr/lib64/python2.7/site-packages/zmq/utils/ipcmaxlen.h
/usr/lib64/python2.7/site-packages/zmq/utils/mutex.h
/usr/lib64/python2.7/site-packages/zmq/utils/pyversion_compat.h
/usr/lib64/python2.7/site-packages/zmq/utils/zmq_compat.h
/usr/lib64/python2.7/site-packages/zmq/utils/zmq_constants.h

Changelog

2019-03-09 - Arun Persaud <arun@gmx.de>
- update to version 18.0.1:
* Fixes installation from source on non-unicode locales with Python
3. There are no code changes in this release.
2019-03-02 - Arun Persaud <arun@gmx.de>
- specfile:
* update copyright year
- update to version 18.0.0:
* Update bundled libzmq to 4.3.1 (fixes CVE-2019-6250)
* Added :func:`~zmq.proxy_steerable` and
:class:`zmq.devices.ProxySteerable`
* Added bind_{in|out|mon}_to_random_port variants for proxy device
methods
* Performance improvements for sends with asyncio
* Fix sending memoryviews/bytearrays with cffi backend
- changes from version 17.1.3:
* Fix compatibility with tornado 6 (removal of stack_context)
2018-08-18 - arun@gmx.de
- update to version 17.1.2:
* Fix possible hang when working with asyncio
* Remove some outdated workarounds for old Cython versions
* Fix some compilation with custom compilers
* Remove unneeded link of libstdc++ on PyPy
2018-07-13 - arun@gmx.de
- update to version 17.1.0:
* Bump bundled libzmq to 4.2.5
* Improve tornado 5.0 compatibility (use
:meth:`~tornado.ioloop.IOLoop.current` instead of
:meth:`~tornado.ioloop.IOLoop.instance` to get default loops in
:class:`.ZMQStream` and :class:`.IOLoopAuthenticator`)
* Add support for :func:`.curve_public`
* Remove delayed import of json in send/recv_json
* Add :meth:`.Authenticator.configure_curve_callback`
* Various build fixes
* sdist sources generated with Cython 0.28.3
* Stop building wheels for Python 3.4, start building wheels for
Python 3.7
2018-03-07 - aplanas@suse.com
- Allows Recommends and Suggest in Fedora
2018-02-27 - aplanas@suse.com
- Recommends only for SUSE
2018-02-10 - arun@gmx.de
- update to version 17.0.0:
* Add :meth:`zmq.Socket.send_serialized` and
:meth:`zmq.Socket.recv_serialized` for sending/receiving messages
with custom serialization.
* Add :attr:`zmq.Socket.copy_threshold` and
:const:`zmq.COPY_THRESHOLD`. Messages smaller than this are always
copied, regardless of copy=False, to avoid overhead of zero-copy
bookkeeping on small messages.
* Added visible deprecation warnings to bundled tornado
IOLoop. Tornado eventloop integration shouldn't be used without a
proper tornado install since pyzmq 14.
* Allow pyzmq asyncio/tornado integration to run without installing
:func:`zmq_poll` implementation. The following methods and classes
are deprecated and no longer required:
:func:`zmq.eventloop.ioloop.install`
:class:`zmq.eventloop.ioloop.IOLoop`
:func:`zmq.asyncio.install`
:class:`zmq.asyncio.ZMQEventLoop`
* Set RPATH correctly when building on macOS.
* Compatibility fixes with tornado 5.0.dev (may not be quite enough
for 5.0 final, which is not yet released as of pyzmq 17).
* Draft support for CLIENT-SERVER routing_id and group.
2018-01-28 - arun@gmx.de
- specfile:
* update copyright year
- update to version 16.0.4:
* Regenerate Cython sources in sdists with Cython 0.27.3, fixing
builds on CPython 3.7.
* Add warning when using bundled tornado, which was deprecated too
quietly in 14.x.
2017-11-02 - arun@gmx.de
- update to version 16.0.3:
* Regenerate Cython sources in sdists with Cython 0.27.2, fixing
builds on CPython 3.7.
2017-08-06 - toddrme2178@gmail.com
- Remove docs. They aren't being built so they are not useful,
and they break the build.

See Also

Package Description
python2-qrcode-6.1-1.1.noarch.rpm QR Code image generator
python2-qscintilla-qt5-2.11.1-1.1.i586.rpm Python Bindings for the C++ Editor Class Library
python2-qscintilla-qt5-2.11.1-1.1.x86_64.rpm Python Bindings for the C++ Editor Class Library
python2-qt3d-qt5-5.12-1.1.i586.rpm Python bindings for the Qt5 3D framework
python2-qt3d-qt5-5.12-1.1.x86_64.rpm Python bindings for the Qt5 3D framework
python2-qt4-4.12.3-1.4.i586.rpm PyQt - python bindings for Qt 4
python2-qt4-4.12.3-1.4.x86_64.rpm PyQt - python bindings for Qt 4
python2-qt4-devel-4.12.3-1.4.i586.rpm PyQt - devel part of python bindings for Qt 4
python2-qt4-devel-4.12.3-1.4.x86_64.rpm PyQt - devel part of python bindings for Qt 4
python2-qt5-5.12.1-1.2.i586.rpm Python bindings for Qt 5
python2-qt5-5.12.1-1.2.x86_64.rpm Python bindings for Qt 5
python2-qt5-devel-5.12.1-1.2.i586.rpm PyQt - devel part of python bindings for Qt 5
python2-qt5-devel-5.12.1-1.2.x86_64.rpm PyQt - devel part of python bindings for Qt 5
python2-qtcharts-qt5-5.12-2.1.i586.rpm Python bindings for the Qt5 Charts library
python2-qtcharts-qt5-5.12-2.1.x86_64.rpm Python bindings for the Qt5 Charts library
Advertisement
Advertisement