python2-pysrt-1.1.1-1.4.noarch.rpm


Advertisement

Description

python2-pysrt - SubRip (.srt) subtitle parser and writer

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-pysrt-1.1.1-1.4.noarch.rpm
Package name python2-pysrt
Package version 1.1.1
Package release 1.4
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/byroot/pysrt
License GPL-3.0
Maintainer -
Download size 30.62 KB
Installed size 73.76 KB
pysrt is a python library to search and download subtitles.
It comes with an easy to use CLI suitable for direct use or cron jobs.

Alternatives

Package Version Architecture Repository
python2-pysrt - - -

Requires

Name Value
python(abi) = 2.7
python2-chardet -

Provides

Name Value
python-pysrt = 1.1.1-1.4
python2-pysrt = 1.1.1-1.4

Obsoletes

Name Value
python-pysrt < 1.1.1-1.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-pysrt-1.1.1-1.4.noarch.rpm
Source Package python-pysrt-1.1.1-1.4.src.rpm

Install Howto

Install python2-pysrt rpm package:

# zypper install python2-pysrt

Files

Path
/usr/lib/python2.7/site-packages/pysrt/__init__.py
/usr/lib/python2.7/site-packages/pysrt/__init__.pyc
/usr/lib/python2.7/site-packages/pysrt/__init__.pyo
/usr/lib/python2.7/site-packages/pysrt/commands.py
/usr/lib/python2.7/site-packages/pysrt/commands.pyc
/usr/lib/python2.7/site-packages/pysrt/commands.pyo
/usr/lib/python2.7/site-packages/pysrt/comparablemixin.py
/usr/lib/python2.7/site-packages/pysrt/comparablemixin.pyc
/usr/lib/python2.7/site-packages/pysrt/comparablemixin.pyo
/usr/lib/python2.7/site-packages/pysrt/compat.py
/usr/lib/python2.7/site-packages/pysrt/compat.pyc
/usr/lib/python2.7/site-packages/pysrt/compat.pyo
/usr/lib/python2.7/site-packages/pysrt/srtexc.py
/usr/lib/python2.7/site-packages/pysrt/srtexc.pyc
/usr/lib/python2.7/site-packages/pysrt/srtexc.pyo
/usr/lib/python2.7/site-packages/pysrt/srtfile.py
/usr/lib/python2.7/site-packages/pysrt/srtfile.pyc
/usr/lib/python2.7/site-packages/pysrt/srtfile.pyo
/usr/lib/python2.7/site-packages/pysrt/srtitem.py
/usr/lib/python2.7/site-packages/pysrt/srtitem.pyc
/usr/lib/python2.7/site-packages/pysrt/srtitem.pyo
/usr/lib/python2.7/site-packages/pysrt/srttime.py
/usr/lib/python2.7/site-packages/pysrt/srttime.pyc
/usr/lib/python2.7/site-packages/pysrt/srttime.pyo
/usr/lib/python2.7/site-packages/pysrt/version.py
/usr/lib/python2.7/site-packages/pysrt/version.pyc
/usr/lib/python2.7/site-packages/pysrt/version.pyo
/usr/lib/python2.7/site-packages/pysrt-1.1.1-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/pysrt-1.1.1-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/pysrt-1.1.1-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/pysrt-1.1.1-py2.7.egg-info/entry_points.txt
/usr/lib/python2.7/site-packages/pysrt-1.1.1-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/pysrt-1.1.1-py2.7.egg-info/top_level.txt

Changelog

2017-03-31 - aloisio@gmx.com
- Set correct group
2017-03-29 - aloisio@gmx.com
- Fixed source URL
2017-03-28 - aloisio@gmx.com
- Converted to single-spec
- Added tests
- Dropped python-pysrt-rpmlintrc (those are pertinent warnings)
2016-12-15 - aloisio@gmx.com
- Update to version 1.1.1
* Include tests in release source tarball
changes introduced in version 1.1.0:
* Make character_per_seconds correctly deal with tags and
introduce text_without_tags property
* Get rid of unused builtin_str
* pep8
* Fix conding style
* Make str() method of SrtItem function properly in both
Python 2 and 3
* Make SrtFile.encoding be set when autodetecting encoding
* Handle division by zero in characters_per_second
* Implement SubRipItem.characters_per_second
* Add duration property to SubRipItem
2015-02-10 - aloisio@gmx.com
- Initial version 1.0.1

See Also

Package Description
python2-pyssim-0.4-1.1.noarch.rpm Structured Similarity Image Metric (SSIM)
python2-pystache-0.5.4-2.2.noarch.rpm Mustache for Python
python2-pysvn-1.9.6-1.2.i586.rpm Highlevel Subversion Python Bindings
python2-pysvn-1.9.6-1.2.x86_64.rpm Highlevel Subversion Python Bindings
python2-pytaglib-1.4.3-1.2.i586.rpm Metadata "tagging" library based on TagLib
python2-pytaglib-1.4.3-1.2.x86_64.rpm Metadata "tagging" library based on TagLib
python2-pyte-0.8.0-2.2.noarch.rpm VTXXX-compatible linux terminal emulator
python2-pytesseract-0.2.0-3.2.noarch.rpm Python wrapper for Google's Tesseract-OCR
python2-pytest-3.10.1-3.1.noarch.rpm Python testing tool with autodiscovery and detailed asserts
python2-pytest-arraydiff-0.2-1.2.noarch.rpm Pytest plugin to help with comparing array output from tests
python2-pytest-astropy-0.5.0-1.1.noarch.rpm Meta-package containing dependencies for testing
python2-pytest-attrib-0.1.3-3.1.noarch.rpm Pytest plugin to select tests based on attributes
python2-pytest-bdd-3.1.0-1.1.noarch.rpm BDD for pytest
python2-pytest-benchmark-3.2.2-1.2.noarch.rpm A py.test fixture for benchmarking code
python2-pytest-check-links-0.3.0-1.1.noarch.rpm Pytest plugin for checking links in files
Advertisement
Advertisement