python2-ptpython-2.0.3-3.1.noarch.rpm


Advertisement

Description

python2-ptpython - Python REPL build on top of prompt_toolkit

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-ptpython-2.0.3-3.1.noarch.rpm
Package name python2-ptpython
Package version 2.0.3
Package release 3.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/jonathanslenders/ptpython
License ISC
Maintainer -
Download size 85.45 KB
Installed size 373.32 KB
Ptpython is an advanced Python REPL.

Alternatives

Package Version Architecture Repository
python2-ptpython - - -

Requires

Name Value
/usr/bin/python2 -
python(abi) = 2.7
python2-Pygments -
python2-docopt -
python2-jedi >= 0.9.0
python2-prompt_toolkit >= 2.0.6

Provides

Name Value
python-ptpython = 2.0.3-3.1
python2-ptpython = 2.0.3-3.1

Obsoletes

Name Value
python-ptpython < 2.0.3-3.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-ptpython-2.0.3-3.1.noarch.rpm
Source Package python-ptpython-2.0.3-3.1.src.rpm

Install Howto

Install python2-ptpython rpm package:

# zypper install python2-ptpython

Files

Path
/usr/bin/ptpython2
/usr/bin/ptpython2.7
/usr/lib/python2.7/site-packages/ptpython/__init__.py
/usr/lib/python2.7/site-packages/ptpython/__init__.pyc
/usr/lib/python2.7/site-packages/ptpython/__init__.pyo
/usr/lib/python2.7/site-packages/ptpython/__main__.py
/usr/lib/python2.7/site-packages/ptpython/__main__.pyc
/usr/lib/python2.7/site-packages/ptpython/__main__.pyo
/usr/lib/python2.7/site-packages/ptpython/completer.py
/usr/lib/python2.7/site-packages/ptpython/completer.pyc
/usr/lib/python2.7/site-packages/ptpython/completer.pyo
/usr/lib/python2.7/site-packages/ptpython/eventloop.py
/usr/lib/python2.7/site-packages/ptpython/eventloop.pyc
/usr/lib/python2.7/site-packages/ptpython/eventloop.pyo
/usr/lib/python2.7/site-packages/ptpython/filters.py
/usr/lib/python2.7/site-packages/ptpython/filters.pyc
/usr/lib/python2.7/site-packages/ptpython/filters.pyo
/usr/lib/python2.7/site-packages/ptpython/history_browser.py
/usr/lib/python2.7/site-packages/ptpython/history_browser.pyc
/usr/lib/python2.7/site-packages/ptpython/history_browser.pyo
/usr/lib/python2.7/site-packages/ptpython/ipython.py
/usr/lib/python2.7/site-packages/ptpython/ipython.pyc
/usr/lib/python2.7/site-packages/ptpython/ipython.pyo
/usr/lib/python2.7/site-packages/ptpython/key_bindings.py
/usr/lib/python2.7/site-packages/ptpython/key_bindings.pyc
/usr/lib/python2.7/site-packages/ptpython/key_bindings.pyo
/usr/lib/python2.7/site-packages/ptpython/layout.py
/usr/lib/python2.7/site-packages/ptpython/layout.pyc
/usr/lib/python2.7/site-packages/ptpython/layout.pyo
/usr/lib/python2.7/site-packages/ptpython/prompt_style.py
/usr/lib/python2.7/site-packages/ptpython/prompt_style.pyc
/usr/lib/python2.7/site-packages/ptpython/prompt_style.pyo
/usr/lib/python2.7/site-packages/ptpython/python_input.py
/usr/lib/python2.7/site-packages/ptpython/python_input.pyc
/usr/lib/python2.7/site-packages/ptpython/python_input.pyo
/usr/lib/python2.7/site-packages/ptpython/repl.py
/usr/lib/python2.7/site-packages/ptpython/repl.pyc
/usr/lib/python2.7/site-packages/ptpython/repl.pyo
/usr/lib/python2.7/site-packages/ptpython/style.py
/usr/lib/python2.7/site-packages/ptpython/style.pyc
/usr/lib/python2.7/site-packages/ptpython/style.pyo
/usr/lib/python2.7/site-packages/ptpython/utils.py
/usr/lib/python2.7/site-packages/ptpython/utils.pyc
/usr/lib/python2.7/site-packages/ptpython/utils.pyo
/usr/lib/python2.7/site-packages/ptpython/validator.py
/usr/lib/python2.7/site-packages/ptpython/validator.pyc
/usr/lib/python2.7/site-packages/ptpython/validator.pyo
/usr/lib/python2.7/site-packages/ptpython-2.0.3-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/ptpython-2.0.3-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/ptpython-2.0.3-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/ptpython-2.0.3-py2.7.egg-info/entry_points.txt
/usr/lib/python2.7/site-packages/ptpython-2.0.3-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/ptpython-2.0.3-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/ptpython/contrib/__init__.py
/usr/lib/python2.7/site-packages/ptpython/contrib/__init__.pyc
/usr/lib/python2.7/site-packages/ptpython/contrib/__init__.pyo
/usr/lib/python2.7/site-packages/ptpython/contrib/asyncssh_repl.py
/usr/lib/python2.7/site-packages/ptpython/contrib/asyncssh_repl.pyc
/usr/lib/python2.7/site-packages/ptpython/contrib/asyncssh_repl.pyo
/usr/lib/python2.7/site-packages/ptpython/entry_points/__init__.py
/usr/lib/python2.7/site-packages/ptpython/entry_points/__init__.pyc
/usr/lib/python2.7/site-packages/ptpython/entry_points/__init__.pyo
/usr/lib/python2.7/site-packages/ptpython/entry_points/run_ptipython.py
/usr/lib/python2.7/site-packages/ptpython/entry_points/run_ptipython.pyc
/usr/lib/python2.7/site-packages/ptpython/entry_points/run_ptipython.pyo
/usr/lib/python2.7/site-packages/ptpython/entry_points/run_ptpython.py
/usr/lib/python2.7/site-packages/ptpython/entry_points/run_ptpython.pyc
/usr/lib/python2.7/site-packages/ptpython/entry_points/run_ptpython.pyo
/usr/share/doc/packages/python2-ptpython/CHANGELOG
/usr/share/doc/packages/python2-ptpython/README.rst
/usr/share/licenses/python2-ptpython/LICENSE

Changelog

2019-02-04 - Jan Engelhardt <jengelh@inai.de>
- Trim conjecture from descriptions.
2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-10-26 - Todd R <toddrme2178@gmail.com>
- Update to version 2.0.3
* Allow changing the min/max brightness.
* Some changes for compatibility with the latest prompt_toolkit.
- Update to version 2.0.2
* Don't crash the history browser when there was no history.
* Set last exception in the sys module, when an exception was
raised.
* Require prompt_toolkit 2.0.5.
- Update to version 2.0.1
* Upgrade to prompt_toolkit 2.0.x.
- Split IPython support into its own subpackage and make it
python3-only. Due to the python2 version of IPython using
prompt_toolkit 1.x and both the python3 version of IPython
and Ptpython using prompt_toolkit 2.x, the python2 version of
Ptpython cannot be used with IPython anymore.
2018-05-24 - toddrme2178@gmail.com
- spec file cleanups
2017-10-18 - toddrme2178@gmail.com
- Implement single-spec version
- Update to version 0.41
* See changelog at https://github.com/jonathanslenders/ptpython/blob/da2c5281f60c2d8a92749709219771ffaa84220f/CHANGELOG
2015-03-05 - toddrme2178@gmail.com
- Initial version

See Also

Package Description
python2-ptyprocess-0.6.0-2.2.noarch.rpm Run a subprocess in a pseudo terminal
python2-publicsuffixlist-0.6.5-1.1.noarch.rpm Public suffix list implementaion in Python
python2-pudb-2018.1-2.3.noarch.rpm A full-screen, console-based Python debugger
python2-pulsectl-17.12.2-2.2.noarch.rpm Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)
python2-pure-sasl-0.6.1-1.1.noarch.rpm Pure Python client SASL implementation
python2-pushy-0.5.4-2.2.noarch.rpm A library for transparently accessing objects in a remote Python interpreter
python2-pwquality-1.4.0-2.4.i586.rpm Python bindings for libpwquality
python2-pwquality-1.4.0-2.4.x86_64.rpm Python bindings for libpwquality
python2-py-1.8.0-1.1.noarch.rpm Library with cross-python path, ini-parsing, io, code, log facilities
python2-py-cpuinfo-3.1.0-3.1.noarch.rpm Python library and tool to get CPU info
python2-py-espeak-ng-0.1.8-1.1.noarch.rpm Python interface for eSpeak NG
python2-py-radix-0.10.0-1.4.i586.rpm Radix tree implementation
python2-py-radix-0.10.0-1.4.x86_64.rpm Radix tree implementation
python2-py-ubjson-0.13.0-1.1.i586.rpm Universal Binary JSON encoder/decoder
python2-py-ubjson-0.13.0-1.1.x86_64.rpm Universal Binary JSON encoder/decoder
Advertisement
Advertisement