python2-pbr-test-5.1.3-2.1.noarch.rpm


Advertisement

Description

python2-pbr-test - Python Build Reasonableness

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-pbr-test-5.1.3-2.1.noarch.rpm
Package name python2-pbr-test
Package version 5.1.3
Package release 2.1
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage http://pypi.python.org/pypi/pbr
License Apache-2.0
Maintainer -
Download size 27.15 KB
Installed size 9.91 KB
PBR is a library to automatically do a bunch of standard
things you want in your setup.py without you having to repeat
them every time. It will set versions, process requirements
files and generate AUTHORS and ChangeLog file all from git
information.

Alternatives

Package Version Architecture Repository
python2-pbr-test - - -

Requires

Name Value
python2-setuptools -
update-alternatives -

Provides

Name Value
python-pbr-test = 5.1.3-2.1
python2-pbr-test = 5.1.3-2.1

Obsoletes

Name Value
python-pbr-test < 5.1.3-2.1
python2-pbr-doc -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-pbr-test-5.1.3-2.1.noarch.rpm
Source Package python-pbr-test-5.1.3-2.1.src.rpm

Install Howto

Install python2-pbr-test rpm package:

# zypper install python2-pbr-test

Files

Path
/usr/share/licenses/python2-pbr-test/LICENSE

Changelog

2019-03-26 - John Vandenberg <jayvdb@gmail.com>
- Add Recomends for git-core and python-reno
- Add Suggests for python-Sphinx and python-nose
- Increase minimum dependency versions to match upstream
- Add build dependency pip, pyparsing, reno and testrepository
used by the test suite
- Remove unnecessary test dependencies coverage and hacking
- Use OS_TEST_TIMEOUT=60 in %check to fix sparodic failing tests
due to timeouts with the default 30 seconds
- Remove no longer needed steps in %prep due to upstream changes
- Replace build dependency git with smaller git-core
2019-03-01 - Ond?ej SĂșkup <mimi.vx@gmail.com>
- update to 5.1.3
- drop 0001-Skip-test-for-testr-hook-being-installed-when-testr-.patch
new_wheel.patch
* Resolve ``ValueError`` when mapping value contains a literal ``=``
* ignore ?find-links in requirements file
* Do not globally replace path prefix
* Use templates for cover and lower-constraints
* Special case long_description_content_type
* Support wheel 0.32.0+
2019-01-17 - Dominique Leuenberger <dimstar@opensuse.org>
- BuildIgnore python[23]-pyparsing: python-packaging requires it
for some actions it could perform, but we don't make use of these
here. Ignoring this dependency allows us to break open a
BuildCycle.
2018-12-11 - Mat?j Cepl <mcepl@suse.com>
- Actually, although the package is noarch, its test suite is not, so we
need python-devel at least for tests.
2018-12-04 - Matej Cepl <mcepl@suse.com>
- Remove superfluous devel dependency for noarch package
2018-11-07 - mmnelemane@suse.com
- Fix for error "invalid option --#" in SLE_12_SP4 build.
2018-10-15 - Matej Cepl <mcepl@suse.com>
- Update to 4.3.0:
* Remove my\_ip from generated wsgi script
* Fix typo in contribution instructions
* Add release note for fix to bug 1786306
* Move pbr-installation jobs in-tree
* Support subdirectory in the url
* remove pypy jobs
* add lib-forward-testing-python3 test job
* add python 3.6 unit test job
* switch documentation job to new PTI
* import zuul job settings from project-config
* Ignore Zuul when generating AUTHORS
* tox: Re-add cover target
- Add new_wheel.patch to make compatible with wheel = 0.32.1
2018-10-07 - mcepl@suse.com
- Revert previous commit.
2018-10-07 - Mat?j Cepl <mcepl@suse.com>
- Partially switch off tests requiring testscenarios and stestr.
2018-09-14 - dmueller@suse.com
- add 0001-Skip-test-for-testr-hook-being-installed-when-testr-.patch

See Also

Package Description
python2-pdfkit-0.6.1-3.2.noarch.rpm Python wrapper for wkhtmltopdf, a HTML-to-PDF converter that uses Qt/WebKit
python2-pdfrw-0.4-3.1.noarch.rpm PDF file reader/writer library
python2-pecan-1.3.3-1.1.noarch.rpm A WSGI object-dispatching web framework
python2-peewee-3.9.3-1.1.i586.rpm An expressive ORM that supports multiple SQL backends
python2-peewee-3.9.3-1.1.x86_64.rpm An expressive ORM that supports multiple SQL backends
python2-pefile-2019.4.18-1.1.noarch.rpm A python module to work with PE (pertable executable) files
python2-pelican-4.0.1-2.2.noarch.rpm A tool to generate a static blog from reStructuredText or Markdown input files
python2-pem-18.2.0-1.1.noarch.rpm PEM file parsing in Python
python2-pep517-0.5.0-1.1.noarch.rpm Wrappers to build Python packages using PEP 517 hooks
python2-pep8-naming-0.8.2-1.1.noarch.rpm Flake8 plugin for checking PEP-8 naming conventions
python2-peppercorn-0.5-2.1.noarch.rpm Pyramid exceptions logger
python2-persistent-4.4.3-2.1.i586.rpm Translucent persistent objects
python2-persistent-4.4.3-2.1.x86_64.rpm Translucent persistent objects
python2-persistent-devel-4.4.3-2.1.i586.rpm Translucent persistent objects
python2-persistent-devel-4.4.3-2.1.x86_64.rpm Translucent persistent objects
Advertisement
Advertisement