python2-numpydoc-0.8.0-1.2.noarch.rpm


Advertisement

Description

python2-numpydoc - Sphinx extension to support docstrings in Numpy format

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-numpydoc-0.8.0-1.2.noarch.rpm
Package name python2-numpydoc
Package version 0.8.0
Package release 1.2
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://github.com/numpy/numpydoc
License BSD-3-Clause
Maintainer -
Download size 53.12 KB
Installed size 206.32 KB
Numpy's documentation uses several custom extensions to Sphinx.  These
are shipped in this numpydoc package, in case you want to make use
of them in third-party projects.

Alternatives

Package Version Architecture Repository
python2-numpydoc - - -

Requires

Name Value
python(abi) = 2.7
python2-Jinja2 >= 2.3
python2-Sphinx >= 1.0.1

Provides

Name Value
python-numpydoc = 0.8.0-1.2
python2-numpydoc = 0.8.0-1.2

Obsoletes

Name Value
python-numpydoc < 0.8.0-1.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-numpydoc-0.8.0-1.2.noarch.rpm
Source Package python-numpydoc-0.8.0-1.2.src.rpm

Install Howto

Install python2-numpydoc rpm package:

# zypper install python2-numpydoc

Files

Path
/usr/lib/python2.7/site-packages/numpydoc/__init__.py
/usr/lib/python2.7/site-packages/numpydoc/__init__.pyc
/usr/lib/python2.7/site-packages/numpydoc/__init__.pyo
/usr/lib/python2.7/site-packages/numpydoc/docscrape.py
/usr/lib/python2.7/site-packages/numpydoc/docscrape.pyc
/usr/lib/python2.7/site-packages/numpydoc/docscrape.pyo
/usr/lib/python2.7/site-packages/numpydoc/docscrape_sphinx.py
/usr/lib/python2.7/site-packages/numpydoc/docscrape_sphinx.pyc
/usr/lib/python2.7/site-packages/numpydoc/docscrape_sphinx.pyo
/usr/lib/python2.7/site-packages/numpydoc/numpydoc.py
/usr/lib/python2.7/site-packages/numpydoc/numpydoc.pyc
/usr/lib/python2.7/site-packages/numpydoc/numpydoc.pyo
/usr/lib/python2.7/site-packages/numpydoc-0.8.0-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/numpydoc-0.8.0-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/numpydoc-0.8.0-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/numpydoc-0.8.0-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/numpydoc-0.8.0-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/numpydoc/templates/numpydoc_docstring.rst
/usr/lib/python2.7/site-packages/numpydoc/tests/test_docscrape.py
/usr/lib/python2.7/site-packages/numpydoc/tests/test_docscrape.pyc
/usr/lib/python2.7/site-packages/numpydoc/tests/test_docscrape.pyo
/usr/share/doc/packages/python2-numpydoc/README.rst
/usr/share/licenses/python2-numpydoc/LICENSE.txt

Changelog

2018-04-29 - arun@gmx.de
- specfile:
* update copyright year
* require Jinja (from setup.py)
* always run tests
- update to version 0.8.0:
* DOC: update URL to documentation in setup.py
* Use isdatadescriptor instead of isgetsetdescriptor
* Ensure reference renaming is parallel-safe (#136)
* Simplify and restructure README
* Automatically load autosummary (#143)
* FIX Handle case where description is empty in returns (#148)
* FIX handling of parameter names ending '_'
* Handle case where description is empty (#140)
* Correct deduplication logic
* Make sure case when class + method docstrings are combined is not
reprocessed
* Avoid reprocessing already numpydocced docstrings
* DOC Use .. deprecated for deprecation instead of .. note (#120)
* Add required arg to setup so that nose does not call it
* Cosmetic and efficiency improvements to replace_referneces (#132)
* Remove comment autosummary from _str_param_list
* Flake8
* Make version available to Python without dependencies; and to
Sphinx metadata
* Test use_blockquotes config
* Leading and trailing blank lines in parameter description should
not affect output
* Stricter comparison of whitespace in testing
* Corret search syntax
* Use definition lists rather than blockquotes
* Support from matplotlib import as alias for import matplotlib
* only recommend inline form
* add documentation on hyperlinks
* DOC: fix syntax error in deprecated of numpydoc_edit_link (#122)
* DOC Note on section ordering, and add missing sections
* DOC Fix link
* DOC: Restore working conf.py
* DOC: cross-link to github from documentation
* Add doc build requirements file for readthedocs
* Corrected rtd url
* Older versions of sphinx do not have imgmath
* DOC: pipe README.rst contents into "long_description", for PyPI
frontpage
* MAINT: update ReST formatting in README.
* Basic docs based on Numpy's HOW_TO_DOCUMENT.rst.txt
* Allow see also object ref to incorporate ~ prefix
2017-09-30 - arun@gmx.de
- update to version 0.7.0:
* make tests run under python2.7
* less hacky solution to duplicate section error message, added
tests
* make getting filename python2 compatible
* add context to signature mangling errors
* MAINT: set version number to 0.7.0.dev0
* Fix regression in #81
* BUG: Make docscrape ParseError Python 3 compatible.
* TST: update test for change in gh-81.
* MAINT: set minimum Sphinx version to 1.2.3, remove linkcode
extension.
* TST: run tests on TravisCI with Python 3.6 instead of 3.5
* TST: run test suite after installing via sdist.
* BUG: fix installing numydoc, broken with missing templates after
gh-77.
* Added ..currentmodule:: before ..autosummary::
* Add dependency on jinja2
* MAINT: add PyPI classifier for Python 3.6, remove Python 2.6 / 3.3
* Render numpydoc strings from a template
* Add __version__ attribute
* ENH: use __text_signature__ if pydoc.doc does not reveal a
signature.
* Remove non Python3 compatible files
* add (possibly slightly off) source lines to mangled docstrings.
* FIX Unknow sections should not raise an error
* MAINT Added *.swp and *.swo to gitignore
* FIX raises an error if a section appears twice
* adjust tests
* bold attributes so we don't have to deal with trailing
underscores. Also looks better.
* BLD: fix sphinx version req
* Use setuptools 'install_requires' instead of 'requires' in
setup.py.
* change to deep copy for doc sections.
* allow extending NumpyDocString sections
* Make default citation pattern more general
* Make citation pattern configurable
* Avoid sorting references by length while renaming
* Factor out function to rename references
2017-05-17 - toddrme2178@gmail.com
- Implement single-spec version.
- Fix source URL.

See Also

Package Description
python2-oauth2-1.9.0.post1-4.1.noarch.rpm A fully tested, abstract interface to creating OAuth clients and servers
python2-oauth2client-4.1.3-1.1.noarch.rpm Pythob OAuth2 Client
python2-oauth2client-flask-4.1.3-1.1.noarch.rpm Flask extension
python2-oauth2client-gce-4.1.3-1.1.noarch.rpm GCE extension
python2-oauthlib-3.0.1-1.1.noarch.rpm A Generic Implementation of the OAuth Request-Signing Logic
python2-objgraph-3.4.0-3.2.noarch.rpm Python module to draw object reference graphs with graphviz
python2-oct2py-4.0.6-1.4.noarch.rpm Python to GNU Octave bridge
python2-octaviaclient-1.8.0-1.1.noarch.rpm Octavia Plugin for the OpenStack Command-line Client
python2-odfpy-1.4.0-1.1.noarch.rpm Python API and tools to manipulate OpenDocument files
python2-odorik-0.5-4.2.noarch.rpm Python module for Odorik API
python2-oic-0.15.1-2.1.noarch.rpm A complete OpenID Connect implementation in Python
python2-olefile-0.46-1.1.noarch.rpm Python package to read and write Microsoft OLE2 files
python2-openapi-spec-validator-0.2.4-3.2.noarch.rpm Python module for validating OpenAPI Specs against Swagger and OAS3
python2-opencv-3.4.3-1.5.i586.rpm Python 2 bindings for apps which use OpenCV
python2-opencv-3.4.3-1.5.x86_64.rpm Python 2 bindings for apps which use OpenCV
Advertisement
Advertisement