python2-notify2-0.3.1-3.2.noarch.rpm


Advertisement

Description

python2-notify2 - Python interface to DBus notifications

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-notify2-0.3.1-3.2.noarch.rpm
Package name python2-notify2
Package version 0.3.1
Package release 3.2
Package architecture noarch
Package type rpm
Category Development/Languages/Python
Homepage https://pypi.python.org/pypi/notify2/
License BSD-2-Clause
Maintainer -
Download size 16.98 KB
Installed size 32.43 KB
This is a pure-python replacement for notify-python, using python-dbus
to communicate with the notifications server directly. It's compatible
with Python 2 and 3, and its callbacks can work with Gtk 3 or Qt 4
applications.

Alternatives

Package Version Architecture Repository
python2-notify2 - - -

Requires

Name Value
dbus-1-python -
python(abi) = 2.7

Provides

Name Value
python-notify2 = 0.3.1-3.2
python2-notify2 = 0.3.1-3.2

Obsoletes

Name Value
python-notify2 < 0.3.1-3.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-notify2-0.3.1-3.2.noarch.rpm
Source Package python-notify2-0.3.1-3.2.src.rpm

Install Howto

Install python2-notify2 rpm package:

# zypper install python2-notify2

Files

Path
/usr/lib/python2.7/site-packages/notify2-0.3.1-py2.7.egg-info
/usr/lib/python2.7/site-packages/notify2.py
/usr/lib/python2.7/site-packages/notify2.pyc
/usr/lib/python2.7/site-packages/notify2.pyo
/usr/share/licenses/python2-notify2/LICENSE

Changelog

2018-12-10 - Tomá? Chvátal <tchvatal@suse.com>
- Fix fdupes call
- Use singlespec everywhere as we rather update packages on older
releases to be singlespeced instead of using py2 only variants
2017-07-02 - antoine.belvire@opensuse.org
- Fix build for Leap 42.3, which does not have a singlespec version
of python-dbus (boo#1046811).
2017-05-06 - antoine.belvire@opensuse.org
- Update to version 0.3.1:
* Wrap notifications_registry lookup in try block not to show
irrelevant errors.
* Add LICENSE file.
- Convert to singlespec.
- Fix license.
2016-12-28 - tbechtold@suse.com
- Use pypi.io as Source url
2016-02-12 - olaf@aepfle.de
- Avoid BuildArch noarch in SLE_11 to fix build
2015-07-30 - antoine.belvire@laposte.net
- Initial package (v0.3).

See Also

Package Description
python2-novaclient-13.0.0-1.1.noarch.rpm Python API and CLI for OpenStack Nova
python2-nss-1.0.1-2.1.i586.rpm Python bindings for mozilla-nss and mozilla-nspr
python2-nss-1.0.1-2.1.x86_64.rpm Python bindings for mozilla-nss and mozilla-nspr
python2-ntlm-auth-1.3.0-1.1.noarch.rpm NTLM low-level Python library
python2-ntplib-0.3.3-1.1.noarch.rpm Python NTP library
python2-num2words-0.5.6-2.2.noarch.rpm Modules to convert numbers to words
python2-numba-0.43.1-1.1.i586.rpm NumPy-aware optimizing compiler for Python using LLVM
python2-numba-0.43.1-1.1.x86_64.rpm NumPy-aware optimizing compiler for Python using LLVM
python2-numba-devel-0.43.1-1.1.i586.rpm Development files for numba applications
python2-numba-devel-0.43.1-1.1.x86_64.rpm Development files for numba applications
python2-numericalunits-1.22-1.4.noarch.rpm Python module for defining quantities with units
python2-numexpr-2.6.9-1.2.i586.rpm Numerical expression evaluator for NumPy
python2-numexpr-2.6.9-1.2.x86_64.rpm Numerical expression evaluator for NumPy
python2-numpy-1.16.2-3.1.i586.rpm NumPy array processing for numbers, strings, records and objects
python2-numpy-1.16.2-3.1.x86_64.rpm NumPy array processing for numbers, strings, records and objects
Advertisement
Advertisement