python2-matplotlib-web-2.2.3-3.1.x86_64.rpm


Advertisement

Description

python2-matplotlib-web - Web backend for python2-matplotlib

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-matplotlib-web-2.2.3-3.1.x86_64.rpm
Package name python2-matplotlib-web
Package version 2.2.3
Package release 3.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/Python
Homepage http://matplotlib.org
License BSD-2-Clause
Maintainer -
Download size 177.41 KB
Installed size 580.62 KB
This package includes the browser-based webagg backend
for the python2-matplotlib plotting package

Alternatives

Package Version Architecture Repository
python2-matplotlib-web-2.2.3-3.1.i586.rpm 2.2.3 i586 openSUSE Oss
python2-matplotlib-web - - -

Requires

Name Value
python(abi) = 2.7
python-tornado -
python2-matplotlib = 2.2.3

Provides

Name Value
python2-matplotlib-web = 2.2.3-3.1
python2-matplotlib-web(x86-64) = 2.2.3-3.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-matplotlib-web-2.2.3-3.1.x86_64.rpm
Source Package python2-matplotlib-2.2.3-3.1.src.rpm

Install Howto

Install python2-matplotlib-web rpm package:

# zypper install python2-matplotlib-web

Files

Path
/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_webagg.py
/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_webagg.pyc
/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_webagg.pyo
/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_webagg_core.py
/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_webagg_core.pyc
/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_webagg_core.pyo
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/all_figures.html
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/ipython_inline_figure.html
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/nbagg_uat.ipynb
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/single_figure.html
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/css/boilerplate.css
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/css/fbm.css
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/css/page.css
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/jquery-ui.min.css
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_diagonals-thick_18_b81900_40x40.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_diagonals-thick_20_666666_40x40.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_flat_10_000000_40x100.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_glass_100_f6f6f6_1x400.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_glass_100_fdf5ce_1x400.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_glass_65_ffffff_1x400.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_gloss-wave_35_f6a828_500x100.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_highlight-soft_100_eeeeee_1x100.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-bg_highlight-soft_75_ffe45c_1x100.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_222222_256x240.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_228ef1_256x240.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_ef8c08_256x240.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_ffd27a_256x240.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/css/themes/base/images/ui-icons_ffffff_256x240.png
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/js/jquery-1.11.3.min.js
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/jquery/js/jquery-ui.min.js
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/js/mpl.js
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/js/mpl_tornado.js
/usr/lib64/python2.7/site-packages/matplotlib/backends/web_backend/js/nbagg_mpl.js
/usr/share/licenses/python2-matplotlib-web/license.rst
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE.PIL
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_AMSFONTS
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_BAKOMA
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_COLORBREWER
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_CONDA
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_JQUERY
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_QT4_EDITOR
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_STIX
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_YORICK
/usr/share/licenses/python2-matplotlib-web/LICENSE/LICENSE_enthought.txt
/usr/share/licenses/python2-matplotlib-web/LICENSE/Solarized.txt
/usr/share/licenses/python2-matplotlib-web/LICENSE/pnpoly.license

Changelog

2019-02-27 - Fabian Vogt <fvogt@suse.com>
- Disable Qt4 support on Tumbleweed by default
2018-10-08 - Todd R <toddrme2178@gmail.com>
- Provide python-matplotlib for backwards-compatibility.
2018-09-19 - Todd R <toddrme2178@gmail.com>
- Create python2-only version.  Starting with matplotlib 3.0,
Python 2 support has been dropped.
2018-08-14 - toddrme2178@gmail.com
- Update to version 2.2.3
* Fix import failure on BSD systems
* Fix import errors in Qt shims for PyQt5 5.11 and PyQt4 4.12
* Fix import errors if bz2 module is not in standard library
* Fix overflow in _path.h
* Fix infinite recursion in transform repr
* Fix bug with XKCD style
* Remove unsafe usage of Popen
2018-06-02 - hpj@urpla.net
- don't use any lua expressions for suse_version < 1500
2018-06-01 - dimstar@opensuse.org
- Only recommend python-matplotlib-tk if tk is already flagged for
installation. On most systems there is no reason to have tk
available (those UIs are out of date and not well perceived
anyway).
2018-05-15 - tbechtold@suse.com
- Add missing Requires for python-backports.functools_lru_cache (boo#1074491)
2018-05-10 - toddrme2178@gmail.com
- Fix building on SLE which doesn't have qhull.
2018-03-17 - arun@gmx.de
- update to version 2.2.2:
* v2.2.1 did not actually restore matplotlib.verbose.
- changes from version 2.2.1:
* This release fixes a number of critical bugs:
+ restores matplotlib.verbose (fixing embedding in pycharm)
+ preserve precision when color mapping small portions of data
with extreme outliers
+ fixes saving long movies with ffmpeg
+ fixes UnbourdLocal error in contour labeling
+ fixes import failure on python 3.4.0 and 3.4.1
+ fixes compile time failures with clang on 32bit platforms
+ fixes an icon in the Tk backends
+ fixes several issues with Tables
+ fixes expanding offset boxes with tight_layout
+ revert changes to the font caching to avoid a possible bug in
backports.lru_cache
+ numerous docstring and documentation fixes
* We have reverted the deprecation of `font_manager.TempCache`.
2018-03-08 - arun@gmx.de
- specfile:
* require kiwisolver
* update required version for dateutil
- update to version 2.2.0:
* The first release of the v2.2 LTS series and the last version of
Matplotlib to support python2.  There will be bug-fix release for
this series until 2020.
* This release includes new features including:
+ An experimental constrained layout manager
+ Color blind friendly color map (cividis) and color cycle
(tableau-colorblind10)
+ native support for numpy.datetime64 types
+ animated gif writing via pillow
+ TkAgg now works with pypy
+ cairo based backends for Qt, Tk, and WX
* There are several API changes in this release:
+ To support the constrained layout Matplotlib has a new required
dependency (kiwisolver).
+ The `matplotlib.finance` module has been removed, development
has moved to a stand-alone project.

See Also

Package Description
python2-matplotlib-wx-2.2.3-3.1.i586.rpm WxWidgets backend for python2-matplotlib
python2-matplotlib-wx-2.2.3-3.1.x86_64.rpm WxWidgets backend for python2-matplotlib
python2-matrix-synapse-0.34.1.1-2.1.noarch.rpm Matrix protocol reference homeserver
python2-matrix-synapse-ldap3-0.1.2-1.3.noarch.rpm An LDAP3 auth provider for Synapse
python2-maxminddb-1.4.1-1.2.i586.rpm Reader for the MaxMind DB format
python2-maxminddb-1.4.1-1.2.x86_64.rpm Reader for the MaxMind DB format
python2-mccabe-0.6.1-1.4.noarch.rpm McCabe checker, plugin for flake8
python2-mechanize-0.4.1-1.1.noarch.rpm Stateful programmatic web browsing
python2-meld3-1.0.2-3.2.noarch.rpm HTML/XML templating engine for Python
python2-memory_profiler-0.55.0-2.1.noarch.rpm A module for monitoring memory usage of a python program
python2-metaextract-1.0.5-3.1.noarch.rpm get metadata for python modules
python2-mhash-1.4-1.3.i586.rpm Python interface to the mhash library
python2-mhash-1.4-1.3.x86_64.rpm Python interface to the mhash library
python2-minio-4.0.13-1.1.noarch.rpm Minio library for Amazon S3 compatible cloud storage
python2-miniupnpc-2.1-3.2.i586.rpm Universal Plug'n'Play (UPnP) Client Module for Python
Advertisement
Advertisement