python2-gpgme-0.3-2.5.x86_64.rpm


Advertisement

Description

python2-gpgme - A Python module for working with OpenPGP messages

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename python2-gpgme-0.3-2.5.x86_64.rpm
Package name python2-gpgme
Package version 0.3
Package release 2.5
Package architecture x86_64
Package type rpm
Category Development/Libraries/Python
Homepage http://pypi.python.org/pypi/pygpgme
License LGPL-2.1+
Maintainer -
Download size 60.71 KB
Installed size 191.35 KB
PyGPGME is a Python module that lets you sign, verify, encrypt and
decrypt messages using the OpenPGP format.
It is built on top of the GNU Privacy Guard and the GPGME library.

Alternatives

Package Version Architecture Repository
python2-gpgme-0.3-2.5.i586.rpm 0.3 i586 openSUSE Oss
python2-gpgme - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libgpgme.so.11()(64bit) -
libgpgme.so.11(GPGME_1.0)(64bit) -
libgpgme.so.11(GPGME_1.1)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpython2.7.so.1.0()(64bit) -
python(abi) = 2.7

Provides

Name Value
python-gpgme = 0.3-2.5
python2-gpgme = 0.3-2.5
python2-gpgme(x86-64) = 0.3-2.5

Obsoletes

Name Value
python-gpgme < 0.3-2.5

Download

Type URL
Mirror widehat.opensuse.org
Binary Package python2-gpgme-0.3-2.5.x86_64.rpm
Source Package python-gpgme-0.3-2.5.src.rpm

Install Howto

Install python2-gpgme rpm package:

# zypper install python2-gpgme

Files

Path
/usr/lib64/python2.7/site-packages/pygpgme-0.3-py2.7.egg-info
/usr/lib64/python2.7/site-packages/gpgme/__init__.py
/usr/lib64/python2.7/site-packages/gpgme/__init__.pyc
/usr/lib64/python2.7/site-packages/gpgme/__init__.pyo
/usr/lib64/python2.7/site-packages/gpgme/_gpgme.so
/usr/lib64/python2.7/site-packages/gpgme/editutil.py
/usr/lib64/python2.7/site-packages/gpgme/editutil.pyc
/usr/lib64/python2.7/site-packages/gpgme/editutil.pyo
/usr/share/doc/packages/python2-gpgme/README
/usr/share/doc/packages/python2-gpgme/examples/encrypt.py
/usr/share/doc/packages/python2-gpgme/tests/__init__.py
/usr/share/doc/packages/python2-gpgme/tests/test_context.py
/usr/share/doc/packages/python2-gpgme/tests/test_delete.py
/usr/share/doc/packages/python2-gpgme/tests/test_editkey.py
/usr/share/doc/packages/python2-gpgme/tests/test_encrypt_decrypt.py
/usr/share/doc/packages/python2-gpgme/tests/test_export.py
/usr/share/doc/packages/python2-gpgme/tests/test_genkey.py
/usr/share/doc/packages/python2-gpgme/tests/test_import.py
/usr/share/doc/packages/python2-gpgme/tests/test_keylist.py
/usr/share/doc/packages/python2-gpgme/tests/test_keys.py
/usr/share/doc/packages/python2-gpgme/tests/test_passphrase.py
/usr/share/doc/packages/python2-gpgme/tests/test_progress.py
/usr/share/doc/packages/python2-gpgme/tests/test_sign_verify.py
/usr/share/doc/packages/python2-gpgme/tests/util.py
/usr/share/doc/packages/python2-gpgme/tests/keys/key1.pub
/usr/share/doc/packages/python2-gpgme/tests/keys/key1.sec
/usr/share/doc/packages/python2-gpgme/tests/keys/key2.pub
/usr/share/doc/packages/python2-gpgme/tests/keys/key2.sec
/usr/share/doc/packages/python2-gpgme/tests/keys/passphrase.pub
/usr/share/doc/packages/python2-gpgme/tests/keys/passphrase.sec
/usr/share/doc/packages/python2-gpgme/tests/keys/revoked.pub
/usr/share/doc/packages/python2-gpgme/tests/keys/signonly.pub
/usr/share/doc/packages/python2-gpgme/tests/keys/signonly.sec

Changelog

2018-01-11 - tchvatal@suse.com
- Use python macros to not directly pull both develpackages
2017-06-06 - ngompa13@gmail.com
- Update to 0.3
- Add patches from Fedora to fix pygpgme with new gpgme
* 0001-reflect-2.1-reporting-for-key-imports.patch
* 0002-passphrase_cb-is-deprecated.patch
* 0003-handle-generic-error-when-no-passphrase-callback-pre.patch
* 0004-add-pubkey_algo-and-hash_algo-attributes-to-signatur.patch
* 0005-add-ENCRYPT_NO_ENCRYPT_TO-constant.patch
* 0006-ignore-STATUS_KEY_CONSIDERED-when-editing.patch
- Drop old patches for pygpgme 0.1
* pygpgme-0.1-py23.patch
* pygpgme-0.1-context.patch
- Convert to singlespec to build for Python 2 and Python 3
2012-02-22 - fcrozat@suse.com
- Fix incorrect gpgme initialization (bnc#745257), patch extracted
by Benjamin Haskell.
2008-02-01 - cthiel@suse.de
- initial package (version 0.1)

See Also

Package Description
python2-gphoto2-2.0.0-1.1.i586.rpm Python interface to libgphoto2
python2-gphoto2-2.0.0-1.1.x86_64.rpm Python interface to libgphoto2
python2-gpod-0.8.3-8.3.i586.rpm Python bindings for libgpod, a library to edit songs and playlists on an iPod
python2-gpod-0.8.3-8.3.x86_64.rpm Python bindings for libgpod, a library to edit songs and playlists on an iPod
python2-gprof2dot-2017.9.19-3.2.noarch.rpm Script to generate a dot graph from the output of several profilers
python2-gpsd-3.18.1-1.4.i586.rpm Client libraries in C and Python for talking to a running gpsd or GPS
python2-gpsd-3.18.1-1.4.x86_64.rpm Client libraries in C and Python for talking to a running gpsd or GPS
python2-grab-0.6.41-1.2.noarch.rpm A mock implementation of python-ldap
python2-graphviz-0.10.1-3.1.noarch.rpm Python interface for Graphviz
python2-greenlet-0.4.15-1.2.i586.rpm Lightweight in-process concurrent programming
python2-greenlet-0.4.15-1.2.x86_64.rpm Lightweight in-process concurrent programming
python2-greenlet-devel-0.4.15-1.2.noarch.rpm C development headers for python-greenlet
python2-grpc-google-iam-v1-0.11.4-1.1.noarch.rpm GRPC library for the google-iam-v1 service
python2-grpcio-1.19.1-2.1.i586.rpm Python language bindings for grpc, a HTTP/2 Remote Procedure Call implementation
python2-grpcio-1.19.1-2.1.x86_64.rpm Python language bindings for grpc, a HTTP/2 Remote Procedure Call implementation
Advertisement
Advertisement