postgresql10-plpython-10.7-2.3.i586.rpm


Advertisement

Description

postgresql10-plpython - The PL/Python Procedural Languages for PostgreSQL

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename postgresql10-plpython-10.7-2.3.i586.rpm
Package name postgresql10-plpython
Package version 10.7
Package release 2.3
Package architecture i586
Package type rpm
Category Productivity/Databases/Servers
Homepage https://www.postgresql.org/
License PostgreSQL
Maintainer -
Download size 92.23 KB
Installed size 278.54 KB
PostgreSQL is an advanced object-relational database management system
that supports an extended subset of the SQL standard, including
transactions, foreign keys, subqueries, triggers, and user-defined
types and functions.
This package contains the PL/Python procedural language for PostgreSQL.
With this module one can use Python to write stored procedures,
functions, and triggers.
PostgreSQL also offers the built-in procedural language PL/SQL which is
included in the postgresql-server package.

Alternatives

Package Version Architecture Repository
postgresql10-plpython-10.7-2.3.x86_64.rpm 10.7 x86_64 openSUSE Oss
postgresql10-plpython - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libpython3.7m.so.1.0 -
postgresql-plpython-noarch >= 10
postgresql10-server = 10.7-2.3
python -

Provides

Name Value
postgresql-plpython-implementation = 10.7-2.3
postgresql10-plpython = 10.7-2.3
postgresql10-plpython(x86-32) = 10.7-2.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package postgresql10-plpython-10.7-2.3.i586.rpm
Source Package postgresql10-10.7-2.3.src.rpm

Install Howto

Install postgresql10-plpython rpm package:

# zypper install postgresql10-plpython

Files

Path
/usr/lib/postgresql10/lib/plpython3.so
/usr/share/locale/cs/LC_MESSAGES/plpython-10.mo
/usr/share/locale/de/LC_MESSAGES/plpython-10.mo
/usr/share/locale/es/LC_MESSAGES/plpython-10.mo
/usr/share/locale/fr/LC_MESSAGES/plpython-10.mo
/usr/share/locale/it/LC_MESSAGES/plpython-10.mo
/usr/share/locale/ja/LC_MESSAGES/plpython-10.mo
/usr/share/locale/ko/LC_MESSAGES/plpython-10.mo
/usr/share/locale/pl/LC_MESSAGES/plpython-10.mo
/usr/share/locale/pt_BR/LC_MESSAGES/plpython-10.mo
/usr/share/locale/ru/LC_MESSAGES/plpython-10.mo
/usr/share/locale/sv/LC_MESSAGES/plpython-10.mo
/usr/share/locale/tr/LC_MESSAGES/plpython-10.mo
/usr/share/locale/zh_CN/LC_MESSAGES/plpython-10.mo
/usr/share/postgresql10/extension/plpython3u--1.0.sql
/usr/share/postgresql10/extension/plpython3u--unpackaged--1.0.sql
/usr/share/postgresql10/extension/plpython3u.control

Changelog

2019-02-25 - Reinhard Max <max@suse.com>
- Update to 10.7:
* https://www.postgresql.org/docs/10/release-10-7.html
* https://www.postgresql.org/about/news/1920/
* By default, panic instead of retrying after fsync() failure,
to avoid possible data corruption.
* Ensure that NOT NULL constraints of a partitioned table are
honored within its partitions.
* Numerous other bug fixes.
- Overhaul README.SUSE
- Make the server-devel package exclusive across versions.
2018-11-09 - Reinhard Max <max@suse.com>
- Update to 10.6:
* CVE-2018-16850, bsc#1114837: Improper quoting of transition
table names when pg_dump emits CREATE TRIGGER can cause
privilege escalation
* Numerous bug fixes, see the release notes:
https://www.postgresql.org/docs/10/release-10-6.html
* Remove unneeded library dependencies from PGXS.
2018-10-22 - Reinhard Max <max@suse.com>
- Stop building the client libraries as they will henceforth be
provided by PostgreSQL 11.
2018-10-17 - Marcus Rueckert <mrueckert@suse.de>
- add provides for the new server-devel package that will be
introduced in postgresql 11
2018-08-10 - max@suse.com
- Update to 10.5:
https://www.postgresql.org/docs/current/static/release-10-5.html
* CVE-2018-10915, bsc#1104199: Fix failure to reset libpq's state
fully between connection attempts.
* CVE-2018-10925, bsc#1104202: Fix INSERT ... ON CONFLICT UPDATE
through a view that isn't just SELECT * FROM ...
2018-05-08 - max@suse.com
- Update to 10.4:
https://www.postgresql.org/about/news/1851/
https://www.postgresql.org/docs/current/static/release-10-4.html
A dump/restore is not required for those running 10.X.
However, if you use the adminpack extension, you should update
it as per the first changelog entry below.
Also, if the function marking mistakes mentioned in the second
and third changelog entries below affect you, you will want to
take steps to correct your database catalogs.
* CVE-2018-1115, bsc#1091610: Remove public execute privilege
from contrib/adminpack's pg_logfile_rotate() function
pg_logfile_rotate() is a deprecated wrapper for the core
function pg_rotate_logfile(). When that function was changed
to rely on SQL privileges for access control rather than a
hard-coded superuser check, pg_logfile_rotate() should have
been updated as well, but the need for this was missed. Hence,
if adminpack is installed, any user could request a logfile
rotation, creating a minor security issue.
After installing this update, administrators should update
adminpack by performing ALTER EXTENSION adminpack UPDATE in
each database in which adminpack is installed.
* Fix incorrect volatility markings on a few built-in functions
* Fix incorrect parallel-safety markings on a few built-in
functions.
2018-05-02 - max@suse.com
- bsc#1091412: server prerequires server-noarch to make sure that
the postgresql user and group exist.
2018-03-09 - mrueckert@suse.de
- Update to 10.3
* https://www.postgresql.org/docs/current/static/release-10-3.html
A dump/restore is not required for those running 10.X.
However, if you run an installation in which not all users are
mutually trusting, or if you maintain an application or
extension that is intended for use in arbitrary situations, it
is strongly recommended that you read the documentation changes
described in the first changelog entry in the link above, and
take suitable steps to ensure that your installation or code is
secure.
Also, the changes described in the second changelog entry in
the link above may cause functions used in index expressions or
materialized views to fail during auto-analyze, or when
reloading from a dump. After upgrading, monitor the server logs
for such problems, and fix affected functions.
* CVE-2018-1058 bsc#1081925 Uncontrolled search path element in
pg_dump and other client applications

See Also

Package Description
postgresql10-plr-8.3.0.17-1.3.i586.rpm PL/R - R Procedural Language for PostgreSQL
postgresql10-plr-8.3.0.17-1.3.x86_64.rpm PL/R - R Procedural Language for PostgreSQL
postgresql10-plr-doc-8.3.0.17-1.3.i586.rpm Documentation for PL/R - R Procedural Language for PostgreSQL
postgresql10-plr-doc-8.3.0.17-1.3.x86_64.rpm Documentation for PL/R - R Procedural Language for PostgreSQL
postgresql10-pltcl-10.7-2.3.i586.rpm PL/Tcl Procedural Language for PostgreSQL
postgresql10-pltcl-10.7-2.3.x86_64.rpm PL/Tcl Procedural Language for PostgreSQL
postgresql10-server-10.7-2.3.i586.rpm The Programs Needed to Create and Run a PostgreSQL Server
postgresql10-server-10.7-2.3.x86_64.rpm The Programs Needed to Create and Run a PostgreSQL Server
postgresql10-test-10.7-2.3.i586.rpm The test suite for PostgreSQL
postgresql10-test-10.7-2.3.x86_64.rpm The test suite for PostgreSQL
postgresql10-timescaledb-1.2.0-2.1.i586.rpm A time-series database extension for PostgreSQL
postgresql10-timescaledb-1.2.0-2.1.x86_64.rpm A time-series database extension for PostgreSQL
postgresql11-11.2-1.3.i586.rpm Basic Clients and Utilities for PostgreSQL
postgresql11-11.2-1.3.x86_64.rpm Basic Clients and Utilities for PostgreSQL
postgresql11-contrib-11.2-1.3.i586.rpm Contributed Extensions and Additions to PostgreSQL
Advertisement
Advertisement