perl-Glib-1.328-2.2.x86_64.rpm


Advertisement

Description

perl-Glib - Perl wrappers for the GLib utility and Object libraries

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename perl-Glib-1.328-2.2.x86_64.rpm
Package name perl-Glib
Package version 1.328
Package release 2.2
Package architecture x86_64
Package type rpm
Category Development/Libraries/Perl
Homepage https://metacpan.org/pod/Glib
License LGPL-2.1-or-later
Maintainer -
Download size 401.82 KB
Installed size 1.05 MB
This wrapper attempts to provide a perlish interface while remaining as
true as possible to the underlying C API, so that any reference materials
you can find on using GLib may still apply to using the libraries from
perl. This module also provides facilities for creating wrappers for other
GObject-based libraries. The SEE ALSO section contains pointers to all
sorts of good information.

Alternatives

Package Version Architecture Repository
perl-Glib-1.328-2.2.i586.rpm 1.328 i586 openSUSE Oss
perl-Glib - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
perl(:MODULE_COMPAT_5.28.1) -
perl(ExtUtils::Depends) >= 0.300
perl(ExtUtils::PkgConfig) >= 1.000000

Provides

Name Value
perl(Glib) = 1.328
perl(Glib::Bytes) -
perl(Glib::CodeGen) = 1.328
perl(Glib::Error) -
perl(Glib::Flags) -
perl(Glib::GenPod) = 1.328
perl(Glib::Install::Files) -
perl(Glib::MakeHelper) = 1.328
perl(Glib::Object) -
perl(Glib::Object::Property) -
perl(Glib::Object::Property::ReadWrite) -
perl(Glib::Object::Property::Readable) -
perl(Glib::Object::Property::Writable) -
perl(Glib::Object::Subclass) = 1.328
perl(Glib::Object::_LazyLoader) -
perl(Glib::ParseXSDoc) = 1.328
perl(Glib::Variant) -
perl(MY) -
perl-Glib = 1.328-2.2
perl-Glib(x86-64) = 1.328-2.2
perl-Glib-devel = 1.328

Download

Type URL
Mirror widehat.opensuse.org
Binary Package perl-Glib-1.328-2.2.x86_64.rpm
Source Package perl-Glib-1.328-2.2.src.rpm

Install Howto

Install perl-Glib rpm package:

# zypper install perl-Glib

Files

Path
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib.pm
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/BookmarkFile.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Boxed.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Bytes.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/CodeGen.pm
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Error.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Flags.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/GenPod.pm
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/KeyFile.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Log.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/MainLoop.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/MakeHelper.pm
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Markup.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Object.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/OptionContext.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/OptionGroup.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/ParamSpec.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/ParseXSDoc.pm
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Signal.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Type.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Utils.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Variant.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/VariantDict.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/VariantType.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/devel.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/index.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/version.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/xsapi.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Install/Files.pm
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Install/doctypes
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Install/gperl.h
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Install/gperl_marshal.h
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Install/typemap
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Object/Subclass.pm
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/Boolean.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/Double.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/Enum.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/Flags.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/GType.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/Int.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/Int64.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/String.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/UInt.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/UInt64.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/Glib/Param/Unichar.pod
/usr/lib/perl5/vendor_perl/5.28.1/x86_64-linux-thread-multi/auto/Glib/Glib.so
/usr/share/doc/packages/perl-Glib/AUTHORS
/usr/share/doc/packages/perl-Glib/ChangeLog.pre-git
/usr/share/doc/packages/perl-Glib/Glib.exports
/usr/share/doc/packages/perl-Glib/NEWS
/usr/share/doc/packages/perl-Glib/README
/usr/share/doc/packages/perl-Glib/TODO
/usr/share/doc/packages/perl-Glib/doctypes
/usr/share/doc/packages/perl-Glib/perl-Glib.doap
/usr/share/doc/packages/perl-Glib/xsapi.pod.foot
/usr/share/doc/packages/perl-Glib/xsapi.pod.head
/usr/share/licenses/perl-Glib/LICENSE
/usr/share/man/man3/Glib.3pm.gz
/usr/share/man/man3/Glib::BookmarkFile.3pm.gz
/usr/share/man/man3/Glib::Boxed.3pm.gz
/usr/share/man/man3/Glib::Bytes.3pm.gz
/usr/share/man/man3/Glib::CodeGen.3pm.gz
/usr/share/man/man3/Glib::Error.3pm.gz
/usr/share/man/man3/Glib::Flags.3pm.gz
/usr/share/man/man3/Glib::GenPod.3pm.gz
/usr/share/man/man3/Glib::KeyFile.3pm.gz
/usr/share/man/man3/Glib::Log.3pm.gz
/usr/share/man/man3/Glib::MainLoop.3pm.gz
/usr/share/man/man3/Glib::MakeHelper.3pm.gz
/usr/share/man/man3/Glib::Markup.3pm.gz
/usr/share/man/man3/Glib::Object.3pm.gz
/usr/share/man/man3/Glib::Object::Subclass.3pm.gz
/usr/share/man/man3/Glib::OptionContext.3pm.gz
/usr/share/man/man3/Glib::OptionGroup.3pm.gz
/usr/share/man/man3/Glib::Param::Boolean.3pm.gz
/usr/share/man/man3/Glib::Param::Double.3pm.gz
/usr/share/man/man3/Glib::Param::Enum.3pm.gz
/usr/share/man/man3/Glib::Param::Flags.3pm.gz
/usr/share/man/man3/Glib::Param::GType.3pm.gz
/usr/share/man/man3/Glib::Param::Int.3pm.gz
/usr/share/man/man3/Glib::Param::Int64.3pm.gz
/usr/share/man/man3/Glib::Param::String.3pm.gz
/usr/share/man/man3/Glib::Param::UInt.3pm.gz
/usr/share/man/man3/Glib::Param::UInt64.3pm.gz
/usr/share/man/man3/Glib::Param::Unichar.3pm.gz
/usr/share/man/man3/Glib::ParamSpec.3pm.gz
/usr/share/man/man3/Glib::ParseXSDoc.3pm.gz
/usr/share/man/man3/Glib::Signal.3pm.gz
/usr/share/man/man3/Glib::Type.3pm.gz
/usr/share/man/man3/Glib::Utils.3pm.gz
/usr/share/man/man3/Glib::Variant.3pm.gz
/usr/share/man/man3/Glib::VariantDict.3pm.gz
/usr/share/man/man3/Glib::VariantType.3pm.gz
/usr/share/man/man3/Glib::devel.3pm.gz
/usr/share/man/man3/Glib::index.3pm.gz
/usr/share/man/man3/Glib::version.3pm.gz
/usr/share/man/man3/Glib::xsapi.3pm.gz

Changelog

2019-03-15 - Bjørn Lie <bjorn.lie@gmail.com>
- Add perl-Glib-1.328-glib2.59-comment-linebreaks.patch: Fix build
with new glib2. Patch from fedora.
2018-10-08 - Dirk Stoecker <opensuse@dstoecker.de>
- Fix autogenerated changes
2018-09-27 - Stephan Kulow <coolo@suse.com>
- updated to 1.328
see /usr/share/doc/packages/perl-Glib/ChangeLog.pre-git
2018-09-12 - pmonrealgonzalez@suse.com
- Update to version 1.326
* Fix typo in pod: s/atomical/atomic/ (Bugzilla #784155)
2018-03-05 - bwiedemann@suse.com
- Update to version 1.326
* Allow overriding of current time in generated man-pages (boo#1047218)
2017-05-09 - sor.alexei@meowr.ru
- Update to version 1.325 (changes since 1.321):
* Fix typos (bgo#760065).
* Docs: Add missing blurbs for the benefit of "whatis"
(bgo#753466).
* Fix a POD error in the Glib::ParamSpec whatis entry.
* Fix POD for the benefit of "whatis" (bgo#772329).
* Fix typos in error message and POD (bgo#772328).
* Try to avoid a possible hang in t/9.t.
* Handle removing '.' in @INC for perl-5.26.0 compatibility.
- Provide perl-Glib-devel as there are some header files in the
package.
2016-02-11 - sor.alexei@meowr.ru
- Update to 1.321:
* GBoxed.xs: Check Glib version prior to enabling GBoxed types.
2015-12-29 - sor.alexei@meowr.ru
- Update to 1.320:
* Makefile.PL: Add IRC link to metadata block.
* Glib::GenPod: Supply default namespace blurbs.
* Properly escape dash in generated API index POD.
2015-10-10 - sor.alexei@meowr.ru
- Update to 1.314:
* Fix compilation on libglib < 2.26.
* Add Glib::Bytes, a wrapper for GBytes.
* Sort the output of podify_signals in a deterministic way.
2015-08-20 - sor.alexei@meowr.ru
- Update to 1.313:
* Fix compilation and test issues with Glib::Variant::ParseError.
* Add a short explanatory comment to the lazy-loading system.

See Also

Package Description
perl-Glib-Object-Introspection-0.046-1.3.i586.rpm GObject Introspection bindings for Perl
perl-Glib-Object-Introspection-0.046-1.3.x86_64.rpm GObject Introspection bindings for Perl
perl-Gnome2-1.047-1.5.i586.rpm Perl interface to the 2.x series of the GNOME libraries
perl-Gnome2-1.047-1.5.x86_64.rpm Perl interface to the 2.x series of the GNOME libraries
perl-Gnome2-Canvas-1.002-1.13.i586.rpm Gnome2-Canvas Perl module
perl-Gnome2-Canvas-1.002-1.13.x86_64.rpm Gnome2-Canvas Perl module
perl-Gnome2-VFS-1.083-1.3.i586.rpm Perl interface to the 2.x series of the GNOME VFS library
perl-Gnome2-VFS-1.083-1.3.x86_64.rpm Perl interface to the 2.x series of the GNOME VFS library
perl-Gnome2-Wnck-0.16-1.13.i586.rpm Perl interface to the Window Navigator Construction Kit
perl-Gnome2-Wnck-0.16-1.13.x86_64.rpm Perl interface to the Window Navigator Construction Kit
perl-GnuPG-Interface-0.52-1.1.noarch.rpm Perl interface to GnuPG
perl-Graph-0.9704-1.8.noarch.rpm Graph Data Structures and Algorithms
perl-GraphViz-2.24-1.3.noarch.rpm Interface to AT&T's GraphViz. Deprecated. See GraphViz2
perl-GraphicsMagick-1.3.31-2.2.i586.rpm Perl interface for the GraphicsMagick image conversion library
perl-GraphicsMagick-1.3.31-2.2.x86_64.rpm Perl interface for the GraphicsMagick image conversion library
Advertisement
Advertisement