perl-ExtUtils-Depends-0.8000-1.1.noarch.rpm


Advertisement

Description

perl-ExtUtils-Depends - Easily build XS extensions that depend on XS extensions

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename perl-ExtUtils-Depends-0.8000-1.1.noarch.rpm
Package name perl-ExtUtils-Depends
Package version 0.8000
Package release 1.1
Package architecture noarch
Package type rpm
Category Development/Libraries/Perl
Homepage https://metacpan.org/release/ExtUtils-Depends
License Artistic-1.0 OR GPL-1.0-or-later
Maintainer -
Download size 28.32 KB
Installed size 37.31 KB
This module tries to make it easy to build Perl extensions that use
functions and typemaps provided by other perl extensions. This means that a
perl extension is treated like a shared library that provides also a C and
an XS interface besides the perl one.
This works as long as the base extension is loaded with the RTLD_GLOBAL
flag (usually done with a
sub dl_load_flags {0x01}
in the main .pm file) if you need to use functions defined in the module.
The basic scheme of operation is to collect information about a module in
the instance, and then store that data in the Perl library where it may be
retrieved later. The object can also reformat this information into the
data structures required by ExtUtils::MakeMaker's WriteMakefile function.
For information on how to make your module fit into this scheme, see
"hashref = ExtUtils::Depends::load (name)".
When creating a new Depends object, you give it a name, which is the name
of the module you are building. You can also specify the names of modules
on which this module depends. These dependencies will be loaded
automatically, and their typemaps, header files, etc merged with your new
object's stuff. When you store the data for your object, the list of
dependencies are stored with it, so that another module depending on your
needn't know on exactly which modules yours depends.
For example:
Gtk2 depends on Glib
Gnome2::Canvas depends on Gtk2
ExtUtils::Depends->new ('Gnome2::Canvas', 'Gtk2');
this command automatically brings in all the stuff needed
for Glib, since Gtk2 depends on it.
When the configuration information is saved, it also includes a class
method called 'Inline', inheritable by your module. This allows you in your
module to simply say at the top:
package Mymod;
use parent 'Mymod::Install::Files'; # to inherit 'Inline' method
And users of 'Mymod' who want to write inline code (using Inline) will
simply be able to write:
use Inline with => 'Mymod';
And all the necessary header files, defines, and libraries will be added
for them.
The 'Mymod::Install::Files' will also implement a 'deps' method, which will
return a list of any modules that 'Mymod' depends on - you will not
normally need to use this:
require Mymod::Install::Files;
@deps = Mymod::Install::Files->deps;

Alternatives

Package Version Architecture Repository
perl-ExtUtils-Depends - - -

Requires

Name Value
perl(:MODULE_COMPAT_5.28.1) -

Provides

Name Value
perl(ExtUtils::Depends) = 0.8000
perl-ExtUtils-Depends = 0.8000-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package perl-ExtUtils-Depends-0.8000-1.1.noarch.rpm
Source Package perl-ExtUtils-Depends-0.8000-1.1.src.rpm

Install Howto

Install perl-ExtUtils-Depends rpm package:

# zypper install perl-ExtUtils-Depends

Files

Path
/usr/lib/perl5/vendor_perl/5.28.1/ExtUtils/Depends.pm
/usr/share/doc/packages/perl-ExtUtils-Depends/Changes
/usr/share/doc/packages/perl-ExtUtils-Depends/README
/usr/share/man/man3/ExtUtils::Depends.3pm.gz

Changelog

2019-04-10 - Stephan Kulow <coolo@suse.com>
- updated to 0.8000
see /usr/share/doc/packages/perl-ExtUtils-Depends/Changes
0.8000
- Bump version so https://metacpan.org/pod/ExtUtils::Depends shows the
correct _ExtUtils::Depends_ module
- Quote directories with spaces
2015-12-02 - coolo@suse.com
- updated to 0.405
see /usr/share/doc/packages/perl-ExtUtils-Depends/Changes
0.405
- Remove MYMETA.* from MANIFEST file; closes autogenerated RT ticket
[#108554]
2015-02-03 - coolo@suse.com
- updated to 0.404
- Depends.pm: sort deps in save_config() and get_makefile_vars(); patch
submitted by Debian's reproducible build team for RT#101602
- Use / to make ::load filename, not File::Spec - perldoc -f require
0.403
- Avoid using Test::More::done_testing() for to support building
out-of-the-box on older perls.
0.402 Sat Oct 18 18:06:19 EEST 2014
- Set Data::Dumper::Sortkeys = 1 in ExtUtils::Depends->save_config();
patch submitted by Niko Tyni of the Debian Perl Group; fixes RT#99260
2014-09-19 - coolo@suse.com
- updated to 0.401
- Add README changes created by 'make dist' from the POD
- Rename test modules
- Test old/new schemes with .pm files
- Move old/new scheme tests from middle of other stuff to end
- Rename test packages to 8.3 unique
0.400 Sun Aug 10 13:58:24 CEST 2014
- In addition to the package variables $inc, $libs and @typemaps, write an
'Inline' method to <package>::Install::Files for easier interoperability
with the Inline module.
- Accompany the 'Inline' method with a 'deps' method in
<package>::Install::Files in addition to the @deps package variable.
- Make ExtUtils::Depends->load use the 'Inline' and 'deps' methods by
default, falling back to the package variables if the methods are not
defined.
- Make the docs recommend the 'Inline' and 'deps' approach for creating
<package>::Install::Files manually, without
ExtUtils::Depends::save_config.
0.309 Sat Aug  2 15:23:03 PDT 2014
- Depends.pm: use $DLEXT instead of $SO for library filename extensions
- MANIFEST: remove MYMETA.* files
- use DynaLoader::mod2fname if available
- Added Android support
0.308 Sun May 18 16:22:11 PDT 2014
- Fix win32 test failure in t/02_save_load.t (closes RT#95301)
0.307 Mon Apr 28 22:04:38 PDT 2014
- $Data::Dumper::Terse set to 1 broke save_config
- Document API expected by ::load function
2013-10-04 - coolo@suse.com
- updated to 0.306
- Fixed typo in RT queue URL; fixes RT#88960
- Makefile.PL: converted to CPAN::Meta::Spec v2
- Updated license in RPM spec file; closes RT#88196
- Updated contact info and added git repo info to POD
- Add comments for find_extra_libs method (closes RT#43900)
- Fixed typo (closes RT#86572)
2011-01-27 - vcizek@novell.com
- update to 0.304
- More robust detection of gcc toolchains on Win32
(Closes: RT#62455) (sisyphus).
- Don't assume dlltool is called 'dlltool' on Win32+gcc. Ask Config.pm
instead (Closes: RT#62455) (sisyphus).
2010-12-10 - coolo@novell.com
- fix buildrequires
2010-12-02 - anicka@suse.cz
- update to 0.303
* Fix a race condition when running the tests in parallel.
2010-11-30 - coolo@novell.com
- switch to perl_requires macro
2010-11-24 - chris@computersalat.de
- recreated by cpanspec 1.78
o fix deps
- noarch pkg

See Also

Package Description
perl-ExtUtils-F77-1.23-1.2.noarch.rpm Simple interface to F77 libs
perl-ExtUtils-Helpers-0.026-1.5.noarch.rpm Various portability utilities for module builders
perl-ExtUtils-InstallPaths-0.012-1.3.noarch.rpm Build.PL install path logic made easy
perl-ExtUtils-LibBuilder-0.08-1.8.noarch.rpm Tool to Build C Libraries
perl-ExtUtils-MakeMaker-7.34-1.3.noarch.rpm Create a module Makefile
perl-ExtUtils-MakeMaker-CPANfile-0.09-1.2.noarch.rpm Cpanfile Support for Eumm
perl-ExtUtils-Manifest-1.72-1.1.noarch.rpm Utilities to write and check a MANIFEST file
perl-ExtUtils-PkgConfig-1.160000-1.5.noarch.rpm Simplistic Interface to Pkg-Config
perl-ExtUtils-Typemaps-Default-1.05-3.8.noarch.rpm A set of useful typemaps
perl-ExtUtils-XSpp-0.18-3.9.i586.rpm XS for C++
perl-ExtUtils-XSpp-0.18-3.9.x86_64.rpm XS for C++
perl-FastCGI-2.4.0-172.5.i586.rpm A scalable, open extension to CGI
perl-FastCGI-2.4.0-172.5.x86_64.rpm A scalable, open extension to CGI
perl-Fennec-Lite-0.004-9.9.noarch.rpm Minimalist Fennec, the commonly used bits.
perl-File-BaseDir-0.08-1.3.noarch.rpm Use the Freedesktop.org base directory specification
Advertisement
Advertisement