password-store-dmenu-1.7.3-2.1.noarch.rpm


Advertisement

Description

password-store-dmenu - A dmenu interface to the "pass" program

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename password-store-dmenu-1.7.3-2.1.noarch.rpm
Package name password-store-dmenu
Package version 1.7.3
Package release 2.1
Package architecture noarch
Package type rpm
Category Productivity/Other
Homepage https://zx2c4.com/projects/password-store/
License GPL-2.0-or-later
Maintainer -
Download size 12.82 KB
Installed size 1.08 KB
A dmenu interface to "pass", a password manager.

Alternatives

Package Version Architecture Repository
password-store-dmenu - - -

Requires

Name Value
/bin/bash -
dmenu -

Provides

Name Value
password-store-dmenu = 1.7.3-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package password-store-dmenu-1.7.3-2.1.noarch.rpm
Source Package password-store-1.7.3-2.1.src.rpm

Install Howto

Install password-store-dmenu rpm package:

# zypper install password-store-dmenu

Files

Path
/usr/bin/passmenu
/usr/share/doc/packages/password-store-dmenu/README.md

Changelog

2019-04-11 - Dan ?ermák <dcermak@suse.com>
- small fixes to the pass spec file:
* cleanup rpmlint warnings
* require xclip instead of recommending it
* preserve timestamps of fish completion files during installation
2018-08-06 - kbabioch@suse.com
- Update to 1.7.3 (bugfix release)
* Simplify filename matching in redact_pass.vim
* Do not put passwords in herestrings
* Do not set foreground color for generated password
* Add custom bash completion for extensions
* show: do not store binary data in bash vars
2018-07-29 - jengelh@inai.de
- Use noun phrase in summary. Fix double meaning of "pass".
2018-06-15 - kbabioch@suse.com
- Update to 1.7.2
* Large number of bug fixes
* Fixed the signature verification routine that parses the output of GnuPG.
Previously, it was prone to spoofing of file signatures and allowed
attackers to inject additional encryption keys (bsc#1097774
CVE-2018-12356).
- Applied spec-cleaner
2017-11-09 - aavindraa@gmail.com
- Version bump 1.7.1
* Bug Fixes
* Add compatibility with GnuPG 2.2.19
* Uniformly use the $GPG variable
* Do the correct thing with subkeys when reencrypting
* Fix test suite on OS X
- Drop password-store-gpg-2.1.patch
* merged in 6f867674272a03273212259b9039c9356a6ed90
- clean spec file with spec-cleaner
- use %make_install macro
2017-03-20 - werner@suse.de
- Update password-store-gpg-2.1.patch to upstream version done
by Andreas Stieger
2017-03-10 - werner@suse.de
- Version bump 1.7
* Features
* Extensions: pass can now load user-defined extensions from a system
directory or a user directory. There's already a nice ecosystem of
extensions being built, even at this early stage. See the pass man page for
more information.
* Signatures: there is now an option to enforce signatures of the .gpg-id file
and extensions using an environment variable.
* QRCodes: generate and show have now learned the --qrcode/-q switch. Note to
package maintainers: this adds a dependency on the popular qrencode package.
* Password generation: rather than use pwgen, we now use /dev/urandom more
directly, which results in more assured password security, as well as
customizable character sets, via an environment variable. See the pass man
page for more information on this customization. Package maintainers: you
may now drop the dependency on pwgen.
* Importers: there now are several more importers. More and more folks are
moving to pass!
* Selectable clipping: you can now specify which line you wish to copy to the
clipboard or display with a qrcode when using -c or -q.
* Git discovery: The PASSWORD_STORE_GIT environment variable has been removed,
and instead pass will automatically choose the git repository closest to the
file being modified (but not out of the actual password store itself). This
should help people who like to nest git repos for different organizations.
* Bug fixes: too many to count.
- New dependency qrencode
- Make pwgen a recommended tool
- Add patch password-store-gpg-2.1.patch to be able to handle new gpg behaviour
boo#1028867
2015-01-29 - tampakrap@opensuse.org
- Add conditionals on dependencies that don't exist on older distros
- Disable tests in older distros where the dependencies don't satisfy them

See Also

Package Description
pasystray-0.7.1-2.1.i586.rpm PulseAudio system tray
pasystray-0.7.1-2.1.x86_64.rpm PulseAudio system tray
patch-2.7.6-3.9.i586.rpm GNU patch
patch-2.7.6-3.9.x86_64.rpm GNU patch
patch2mail-1.1.2-3.3.noarch.rpm Patch and package update notification via mail
patchelf-0.9-3.2.i586.rpm A utility for patching ELF binaries
patchelf-0.9-3.2.x86_64.rpm A utility for patching ELF binaries
patchutils-0.3.4-1.14.i586.rpm A Collection of Tools for Manipulating Patch Files
patchutils-0.3.4-1.14.x86_64.rpm A Collection of Tools for Manipulating Patch Files
patool-1.12-1.4.noarch.rpm Portable Command Line Archive File Manager
patool-bash-completion-1.12-1.4.noarch.rpm Bash Completion for patool
patterns-base-32bit-20190206-5.1.x86_64.rpm 32-Bit Runtime Environment
patterns-base-apparmor-20190206-5.1.i586.rpm AppArmor
patterns-base-apparmor-20190206-5.1.x86_64.rpm AppArmor
patterns-base-apparmor-32bit-20190206-5.1.i586.rpm AppArmor
Advertisement
Advertisement