pam_yubico-2.26-1.3.x86_64.rpm


Advertisement

Description

pam_yubico - Yubico Pluggable Authentication Module (PAM)

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename pam_yubico-2.26-1.3.x86_64.rpm
Package name pam_yubico
Package version 2.26
Package release 1.3
Package architecture x86_64
Package type rpm
Category Productivity/Networking/Security
Homepage https://developers.yubico.com/yubico-pam/
License BSD-2-Clause
Maintainer -
Download size 67.17 KB
Installed size 173.69 KB
This module allows you to use the Yubikey device to authenticate to the PAM system.

Alternatives

Package Version Architecture Repository
pam_yubico-2.26-18.11.x86_64.rpm 2.26 x86_64 Security
pam_yubico-2.26-18.11.i586.rpm 2.26 i586 Security
pam_yubico-2.26-1.3.i586.rpm 2.26 i586 openSUSE Oss
pam_yubico - - -

Requires

Name Value
libc.so.6(GLIBC_2.27)(64bit) -
liblber-2.4.so.2()(64bit) -
libldap_r-2.4.so.2()(64bit) -
libpam.so.0()(64bit) -
libpam.so.0(LIBPAM_1.0)(64bit) -
libpam.so.0(LIBPAM_MODUTIL_1.1.3)(64bit) -
libykclient.so.3()(64bit) -
libykclient.so.3(Base)(64bit) -
libykclient.so.3(YKCLIENT_2.12)(64bit) -
libykclient.so.3(YKCLIENT_2.15)(64bit) -
libykpers-1.so.1()(64bit) -
libykpers-1.so.1(LIBYKPERS_1.0)(64bit) -
libykpers-1.so.1(LIBYKPERS_1.5)(64bit) -
libykpers-1.so.1(LIBYKPERS_1.8)(64bit) -
libykpers-1.so.1(LIBYKPERS_1.9)(64bit) -
libyubikey.so.0()(64bit) -
libyubikey.so.0(YUBIKEY_1.0)(64bit) -
libyubikey.so.0(YUBIKEY_1.5)(64bit) -

Provides

Name Value
pam_yubico = 2.26-1.3
pam_yubico(x86-64) = 2.26-1.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package pam_yubico-2.26-1.3.x86_64.rpm
Source Package pam_yubico-2.26-1.3.src.rpm

Install Howto

Install pam_yubico rpm package:

# zypper install pam_yubico

Files

Path
/lib64/security/pam_yubico.so
/usr/bin/ykpamcfg
/usr/share/doc/packages/pam_yubico/AUTHORS
/usr/share/doc/packages/pam_yubico/Authentication_Using_Challenge-Response.adoc
/usr/share/doc/packages/pam_yubico/MacOS_X_Challenge-Response.adoc
/usr/share/doc/packages/pam_yubico/NEWS
/usr/share/doc/packages/pam_yubico/README
/usr/share/doc/packages/pam_yubico/Two_Factor_PAM_Configuration.adoc
/usr/share/doc/packages/pam_yubico/Ubuntu_FreeRadius_YubiKey.adoc
/usr/share/doc/packages/pam_yubico/YubiKey_and_FreeRADIUS_1FA_via_PAM.adoc
/usr/share/doc/packages/pam_yubico/YubiKey_and_FreeRADIUS_via_PAM.adoc
/usr/share/doc/packages/pam_yubico/YubiKey_and_OpenVPN_via_PAM.adoc
/usr/share/doc/packages/pam_yubico/Yubikey_and_Radius_via_PAM.adoc
/usr/share/doc/packages/pam_yubico/Yubikey_and_SELinux_on_Fedora_18_and_up.adoc
/usr/share/doc/packages/pam_yubico/Yubikey_and_SSH_via_PAM.adoc
/usr/share/licenses/pam_yubico/COPYING
/usr/share/man/man1/ykpamcfg.1.gz
/usr/share/man/man8/pam_yubico.8.gz

Changelog

2018-04-20 - kbabioch@suse.com
- Version 2.26 (released 2018-04-20)
- Make sure to close authfile (CVE-2018-9275 bsc#1088027).
- Fix compiler warnings.
- Open file descriptors with O_CLOEXEC.
- Use mkostemp() instead of mkstemp().
- Dropped patches that are included upstream:
- cloexec.patch
- compiler-warnings-format-strings.patch
- compiler-warnings-pointer.patch
- leaking-file-descriptor.patch
- util_test-mkdtemp.patch
2018-04-13 - kbabioch@suse.com
- Added patches:
- cloexec.patch: Harden file descriptor handling (boo#1089517)
- compiler-warnings-pointer.patch: Fix compiler warnings due to wrong pointer
casts (boo#1089518)
- compiler-warnings-format-strings.patch: Fix compiler warnings due to wrong
format string specifiers (boo#1089519)
- util_test-mkdtemp.patch: Use mkdtemp() instead of tempnam() (boo#1089520)
2018-04-04 - kbabioch@suse.com
- leaking-file-descriptor.patch: Close the authfile before returning
to make sure no file descriptors are leaked (bsc#1088027).
2018-03-27 - kbabioch@suse.com
- Version 2.25 (released 2018-03-27):
- Security: Storage of challenges in path with restricted permissions
- Perform OTP validation only if token is authorized
- Return early if the user has no authorized tokens
- Compare OTP IDs against `yubi_attr` only
- Add nullok support to challenge-response mode
- Several improvements to the documentation
- Improved debugging output and test cases
2017-11-27 - meissner@suse.com
- Version 2.24 (released 2016-11-25) (bsc#1067191)
- Debug mode changed, allows file output with debug_file.
- Fixup returning user-unknown correctly.
- Version 2.23 (released 2016-06-15)
- Fix an issue where a failure to set permissions was wrongly outputted.
2016-06-09 - t.gruner@katodev.de
- Version 2.22 (released 2016-05-23)
- Documentation improvements.
- Retain ownership and permission of challenge files (issue #92).
- Make dependency on yubico-c-client 2.15 clearer.
2016-04-25 - t.gruner@katodev.de
- Version 2.21 (released 2016-02-19)
- Add proxy support for yubico-c-client.
- Check that conv is set before trying to use it fixes a crash bug with the osx loginwindow.
- Add building of a mac installer.
2015-10-05 - t.gruner@katodev.de
- Version 2.20 (released 2015-09-22)
- Add cainfo option to allow usage of a cabundle instead of path.
- Support comments in authfile.
- For challenge response with system-wide directory, write the files as root instead of the user.
- add baselib.conf
2015-03-26 - t.gruner@katodev.de
- Version 2.19 (released 2015-03-23)
- Add new ldap functionality ldap_bind_user and ldap_bind_password
for authenticated binds ldap_filter for using subtree search and
a filter ldap_cacertfile to use a specific cacert for ldaps
2015-02-16 - t.gruner@katodev.de
- Version 2.18 (released 2015-02-12)
- Fix a memory leak of the pam response data.
- Add more tests.
- Add version flag to ykpamcfg.
- Remove "make check" in spec-file. ( BuildRequires: perl(Net::LDAP::Server) )

See Also

Package Description
pamix-1.6-1.4.i586.rpm "alsamixer" for pulseaudio
pamix-1.6-1.4.x86_64.rpm "alsamixer" for pulseaudio
pamixer-1.3.1-1.8.i586.rpm PulseAudio commandline mixer
pamixer-1.3.1-1.8.x86_64.rpm PulseAudio commandline mixer
pan-0.145-1.4.i586.rpm A Newsreader for GNOME
pan-0.145-1.4.x86_64.rpm A Newsreader for GNOME
pan-lang-0.145-1.4.noarch.rpm Translations for package pan
pandoc-2.7.2-1.1.i586.rpm Conversion between markup formats
pandoc-2.7.2-1.1.x86_64.rpm Conversion between markup formats
pandoc-pdf-2.7.2-1.1.i586.rpm Meta package for support generating pdf with pandoc
pandoc-pdf-2.7.2-1.1.x86_64.rpm Meta package for support generating pdf with pandoc
pango-devel-1.43.0-1.1.i586.rpm Development files for pango, a library for text layout and rendering
pango-devel-1.43.0-1.1.x86_64.rpm Development files for pango, a library for text layout and rendering
pango-devel-32bit-1.43.0-1.1.x86_64.rpm Development files for pango, a library for text layout and rendering
pango-tools-1.43.0-1.1.i586.rpm Tools for pango, a library for text layout and rendering
Advertisement
Advertisement