openEMS-devel-0.0.35-5.6.i586.rpm


Advertisement

Description

openEMS-devel - openEMS development files

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename openEMS-devel-0.0.35-5.6.i586.rpm
Package name openEMS-devel
Package version 0.0.35
Package release 5.6
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage http://openems.de
License GPL-3.0-only
Maintainer -
Download size 13.60 KB
Installed size 10.50 KB
This package contains libraries for developing applications
that use openEMS.

Alternatives

Package Version Architecture Repository
openEMS-devel-0.0.35-30.11.x86_64.rpm 0.0.35 x86_64 Science
openEMS-devel-0.0.35-30.11.i586.rpm 0.0.35 i586 Science
openEMS-devel-0.0.35-5.6.x86_64.rpm 0.0.35 x86_64 openSUSE Oss
openEMS-devel - - -

Requires

Name Value
libnf2ff0 = 0.0.35
libopenEMS0 = 0.0.35

Provides

Name Value
openEMS-devel = 0.0.35-5.6
openEMS-devel(x86-32) = 0.0.35-5.6

Download

Type URL
Mirror widehat.opensuse.org
Binary Package openEMS-devel-0.0.35-5.6.i586.rpm
Source Package openEMS-0.0.35-5.6.src.rpm

Install Howto

Install openEMS-devel rpm package:

# zypper install openEMS-devel

Files

Path
/usr/include/openEMS/nf2ff.h
/usr/include/openEMS/nf2ff_calc.h
/usr/include/openEMS/openems.h
/usr/lib/libnf2ff.so
/usr/lib/libopenEMS.so

Changelog

2018-12-15 - Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
- Update 0001-Fix-linking-for-VTK-6.3.patch, avoid pulling in dependencies
of unused VTK modules during build.
- Drop MPI environment setup, VTK no longer depends on MPI.
- Do not force AVX for x86, SSE is sufficient for XMM intrinsics
- specfile cleanup
2018-06-25 - stefan.bruens@rwth-aachen.de
- Use mpic++ as C++ compiler, otherwise we end up with missing MPI
symbols when linking
- Always use Qt5, as all current VTK builds use Qt5 as well
2018-03-27 - stefan.bruens@rwth-aachen.de
- Fix build on e.g. ARM, use x86 intrinsics only on x86
add 0001-Guard-xmmintrin.h-include-so-it-is-only-used-when-ne.patch
2018-03-27 - stefan.bruens@rwth-aachen.de
- Change the Qt BuildRequires: for older distributions, Leap 42.x
has a VTK build with Qt4, use the same conditional as the VTK
package (i.e. Qt4 on Leap 42.x, Qt5 on TW and Leap 15.x)
- Fix build when using -std=gnu++11 and glibc <= 2.25
add 0001-Fix-build-error-due-to-ambigous-overload-of-isnan-is.patch
2018-01-17 - adam.majer@suse.de
- Fix boost build dependencies (boo#1062789)
2017-12-27 - kkaempf@suse.com
- Update to 0.0.35
* build fixes
* critical bug fix in waveguide ports
* fix for boxes defined in different coordinate systems
* other smaller fixes
- patch rename and cleanop, now based on git format-patch
* openEMS-vtk.patch to 0001-Fix-linking-for-VTK-6.3.patch
* openEMS-octave-openEMS-load.patch to 0002-Fix-openEMS.sh-load.patch
* openEMS-octave-nf2ff-load.patch to 0003-Fix-nf2ff-load.patch
* openEMS-readme-octave-package.patch to 0004-Add-correct-instruction-about-Octave-and-MATLAB-pack.patch
* openEMS-hdf5.patch to 0005-Fix-build-with-HDF5.patch
* openEMS-no-return.patch to 0006-Add-missing-return-statement.patch
2017-10-26 - badshah400@gmail.com
- Source mpi variables before building to prevent build failures
on openSUSE > 1320.
- Add BuildRequires: sz2-devel, needed for building for openSUSE
>= 1320.
2017-09-13 - stefan.bruens@rwth-aachen.de
- Add explicit BuildRequires for vtk-java, vtk-tcl and python3-vtk,
and Qt5Sql/Qt5Widgets devel packages, as these are no longer
implicitly required by vtk-devel
2017-01-01 - jengelh@inai.de
- Correct RPM group selection
2016-08-26 - dmitry_r@opensuse.org
- Update to version 0.0.34
* Bugfix release
* Update openEMS-vtk.patch
- Drop obsolete
* openEMS-vtk7-support.patch
- Fix build with HDF5
* openEMS-hdf5.patch
- Fix GCC no-return-in-nonvoid-function
* openEMS-no-return.patch

See Also

Package Description
openEMS-matlab-0.0.35-5.6.i586.rpm MATLAB interface for openEMS
openEMS-matlab-0.0.35-5.6.x86_64.rpm MATLAB interface for openEMS
openQA-4.6.1555478309.f6dfdd9b-1.1.noarch.rpm The openQA web-frontend, scheduler and tools
openQA-bootstrap-4.6.1555478309.f6dfdd9b-1.1.noarch.rpm Automated openQA setup
openQA-client-4.6.1555478309.f6dfdd9b-1.1.noarch.rpm Client tools for remote openQA management
openQA-common-4.6.1555478309.f6dfdd9b-1.1.noarch.rpm The openQA common tools for web-frontend and workers
openQA-doc-4.6.1555478309.f6dfdd9b-1.1.noarch.rpm The openQA documentation
openQA-local-db-4.6.1555478309.f6dfdd9b-1.1.noarch.rpm Helper package to ease setup of postgresql DB
openQA-worker-4.6.1555478309.f6dfdd9b-1.1.noarch.rpm The openQA worker
openSUSE-EULAs-84.87.20190314.743685c-1.1.noarch.rpm Collection of EULAs for openSUSE
openSUSE-MicroOS-release-20190505-125.1.i586.rpm openSUSE MicroOS
openSUSE-MicroOS-release-20190505-125.1.x86_64.rpm openSUSE MicroOS
openSUSE-MicroOS-release-appliance-20190505-125.1.i586.rpm openSUSE MicroOS
openSUSE-MicroOS-release-appliance-20190505-125.1.x86_64.rpm openSUSE MicroOS
openSUSE-MicroOS-release-appliance-kubic-20190505-125.1.i586.rpm openSUSE MicroOS
Advertisement
Advertisement