ocaml-x11-4.05.0-7.1.x86_64.rpm


Advertisement

Description

ocaml-x11 - X11 support for OCaml

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ocaml-x11-4.05.0-7.1.x86_64.rpm
Package name ocaml-x11
Package version 4.05.0
Package release 7.1
Package architecture x86_64
Package type rpm
Category Development/Languages/OCaml
Homepage http://www.ocaml.org
License SUSE-LGPL-2.0-with-linking-exception
Maintainer -
Download size 12.05 KB
Installed size 2.13 KB
OCaml is a high-level, strongly-typed, functional and object-oriented
programming language from the ML family of languages.
This package contains X11 support for OCaml.

Alternatives

Package Version Architecture Repository
ocaml-x11-4.05.0-7.1.i586.rpm 4.05.0 i586 openSUSE Oss
ocaml-x11 - - -

Requires

Name Value
ocaml(CamlinternalFormatBasics) = cbd5f2d6b649925222e1e9fb63b89db6
ocaml(Pervasives) = 07ea9e20ae94d62c35cfecbe7d66d3ea

Provides

Name Value
ocaml(GraphicsX11) = 30e7b6b35550c30e7eef47adf30a8b81
ocaml-x11 = 4.05.0-7.1
ocaml-x11(x86-64) = 4.05.0-7.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ocaml-x11-4.05.0-7.1.x86_64.rpm
Source Package ocaml-4.05.0-7.1.src.rpm

Install Howto

Install ocaml-x11 rpm package:

# zypper install ocaml-x11

Files

Path
/usr/lib64/ocaml/graphicsX11.cmi
/usr/lib64/ocaml/graphicsX11.mli

Changelog

2019-04-24 - ohering@suse.de
- Disable LTO (bsc#1133269)
2018-07-02 - guillaume.gardet@opensuse.org
- Tag license files with %license, not %doc
- Backport patch to fix build on aarch64: 'AArch64 GOT fixed'
https://github.com/ocaml/ocaml/pull/1330:
* ocaml-fix_aarch64_build.patch
2018-04-24 - kstreitova@suse.com
- update ocaml-4.05.0-CVE-2018-9838.patch that causes "undefined
reference to `caml_umul_overflow`" build failure. Replace this
function that is not available in ocaml 4.05 (added in ocaml
4.06) with the present caml_ba_multov() that is basically the
same [bnc#1088591] [CVE-2018-9838]
2018-04-13 - kstreitova@suse.com
- add ocaml-4.05.0-CVE-2018-9838.patch to fix integer overflows
when unmarshaling a bigarray. Malicious or corrupted marshaled
data can result in a bigarray with impossibly large dimensions
that cause overflow when computing the in-memory size of the
bigarray. Disaster ensues when the data is read in a too small
memory area [bnc#1088591] [CVE-2018-9838]
2018-04-04 - kstreitova@suse.com
- run spec-cleaner
- update URL to www.ocaml.org
- the language is officially called OCaml and not Objective Caml,
rename it in summaries and descriptions
- tweak summaries and descriptions
- remove definition of %{_rpmconfigdir} macro - it should be
defined on all distros by default now
2018-04-04 - ohering@suse.de
- Remove info and html documentation because it is not as free
as it should be. Drop ocaml-docs package. (bsc#1080640)
- adjust ocaml-3.09-emacs_localcompile.patch and
ocaml-3.08.3-gcc4.patch for autosetup
2017-08-10 - ohering@suse.de
- Provide ocaml(ocaml_base_version) for camlp4
2017-07-25 - ohering@suse.de
- Use Group: Development/Languages/OCaml
2017-07-17 - ohering@suse.de
- update version 4.05.0
* http://caml.inria.fr/pub/distrib/ocaml-4.05/notes/Changes
- build with -no-cplugins (CVE-2017-9772)
2017-07-17 - ohering@suse.de
- Remove autodeps for pre openSUSE 12.1 releases

See Also

Package Description
ocaml-xml-light-2.4.20160613.2bc42e8-3.3.i586.rpm Minimal XML parser and printer for OCaml
ocaml-xml-light-2.4.20160613.2bc42e8-3.3.x86_64.rpm Minimal XML parser and printer for OCaml
ocaml-xml-light-devel-2.4.20160613.2bc42e8-3.3.i586.rpm Development files for ocaml-xml-light
ocaml-xml-light-devel-2.4.20160613.2bc42e8-3.3.x86_64.rpm Development files for ocaml-xml-light
ocamlify-0.0.2-2.3.i586.rpm Verbatim file inclusion as OCaml code
ocamlify-0.0.2-2.3.x86_64.rpm Verbatim file inclusion as OCaml code
ocamlmod-0.0.8-2.3.i586.rpm Generate OCaml modules
ocamlmod-0.0.8-2.3.x86_64.rpm Generate OCaml modules
occt-7.3.0-2.1.i586.rpm OpenCASCADE Official Edition
occt-7.3.0-2.1.x86_64.rpm OpenCASCADE Official Edition
occt-DRAWEXE-7.3.0-2.1.i586.rpm Development files for occt
occt-DRAWEXE-7.3.0-2.1.x86_64.rpm Development files for occt
occt-devel-7.3.0-2.1.i586.rpm Development files for occt
occt-devel-7.3.0-2.1.x86_64.rpm Development files for occt
occt-devel-doc-7.3.0-2.1.noarch.rpm Development files for occt
Advertisement
Advertisement