ndpi-tools-2.8-1.1.i586.rpm


Advertisement

Description

ndpi-tools - Tools for nNDPI

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename ndpi-tools-2.8-1.1.i586.rpm
Package name ndpi-tools
Package version 2.8
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage https://github.com/ntop/nDPI
License LGPL-3.0-only
Maintainer -
Download size 179.36 KB
Installed size 512.50 KB
nDPI is a ntop-maintained superset of the OpenDPI library. It extends
the original library by adding new protocols that are otherwise
available only on the paid version of OpenDPI.
This package contains the ndpiReader binary.

Alternatives

Package Version Architecture Repository
ndpi-tools-2.8-1.1.x86_64.rpm 2.8 x86_64 openSUSE Oss
ndpi-tools - - -

Requires

Name Value
libc.so.6(GLIBC_2.7) -
libgcc_s.so.1 -
libgcc_s.so.1(GLIBC_2.0) -
libhs.so.5 -
libpcap.so.1 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -

Provides

Name Value
ndpi-tools = 2.8-1.1
ndpi-tools(x86-32) = 2.8-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package ndpi-tools-2.8-1.1.i586.rpm
Source Package ndpi-2.8-1.1.src.rpm

Install Howto

Install ndpi-tools rpm package:

# zypper install ndpi-tools

Files

Path
/usr/bin/ndpiReader
/usr/share/doc/packages/ndpi-tools/
/usr/share/doc/packages/ndpi-tools/wireshark/README.md
/usr/share/doc/packages/ndpi-tools/wireshark/ndpi.lua

Changelog

2019-03-30 - Martin Hauke <mardnh@gmx.de>
- Update to version 2.8
New Supported Protocols and Services
* Added Modbus over TCP dissector
Improvements
* Wireshark Lua plugin compatibility with Wireshark 3
* Improved MDNS dissection
* Improved HTTP response code handling
* Full dissection of HTTP responses
Fixes
* Fixed false positive mining detection
* Fixed invalid TCP DNS dissection
* Releasing buffers upon realloc failures
* ndpiReader: Prevents references after free
* Endianness fixes
* Fixed IPv6 HTTP traffic dissection
* Fixed H.323 detection
Other
* Disabled ookla statistics which need to be improved
* Support for custom protocol files of arbitrary length
* Update radius.c to RFC2865
2019-02-24 - schwab@suse.de
- override prefix and libdir during install
- ndpi-fix-build.patch: don't install multiple copies of the library
2019-01-08 - Jan Engelhardt <jengelh@inai.de>
- Compact descriptions of all but the most promiment package
(libndpi2) for size. Trim bias and metadata redundancies, too.
2019-01-07 - mardnh@gmx.de
- Add wireshark/ndpi.lua to the doc section of ndpi-tools
- Add a comment to clarify the license of wireshark/ndpi.lua
2018-12-28 - mardnh@gmx.de
- Rename files according to the package name nDPI -> ndpi
2018-12-22 - mardnh@gmx.de
- Update to version 2.6
See /usr/share/doc/packages/libndpi2/CHANGELOG.md for the full
changelog
2017-10-22 - mardnh@gmx.de
- Initial package, version 2.0

See Also

Package Description
ndpmon-2.1.0-1.2.i586.rpm IPv6 Neighbor Discovery Protocol Monitor
ndpmon-2.1.0-1.2.x86_64.rpm IPv6 Neighbor Discovery Protocol Monitor
ndppd-0.2.5.43-2.2.i586.rpm Neighbor Discovery Protocol Proxy Daemon
ndppd-0.2.5.43-2.2.x86_64.rpm Neighbor Discovery Protocol Proxy Daemon
neard-0.15-2.5.i586.rpm NFC for Linux
neard-0.15-2.5.x86_64.rpm NFC for Linux
neard-devel-0.15-2.5.i586.rpm Files needed for NFC development
neard-devel-0.15-2.5.x86_64.rpm Files needed for NFC development
neard-test-0.15-2.5.i586.rpm Files needed for NFC development
neard-test-0.15-2.5.x86_64.rpm Files needed for NFC development
nedit-5.7-2.7.i586.rpm A GUI text editor
nedit-5.7-2.7.x86_64.rpm A GUI text editor
neko-2.2.0-1.7.i586.rpm A cross-platform lightweight virtual machine and language
neko-2.2.0-1.7.x86_64.rpm A cross-platform lightweight virtual machine and language
neko-devel-2.2.0-1.7.i586.rpm Development files for the Neko virtual machine
Advertisement
Advertisement