libyui9-3.4.2-3.1.x86_64.rpm


Advertisement

Description

libyui9 - Libyui - GUI-abstraction library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libyui9-3.4.2-3.1.x86_64.rpm
Package name libyui9
Package version 3.4.2
Package release 3.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://github.com/libyui/
License LGPL-2.1-only OR LGPL-3.0-only
Maintainer -
Download size 284.80 KB
Installed size 1015.78 KB
This is the user interface engine that provides the abstraction from
graphical user interfaces (Qt, Gtk) and text based user interfaces
(ncurses).
Originally developed for YaST, it can now be used independently of
YaST for generic (C++) applications. This package has very few
dependencies.

Alternatives

Package Version Architecture Repository
libyui9-3.4.2-3.1.i586.rpm 3.4.2 i586 openSUSE Oss
libyui9 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
yui_backend = 9

Provides

Name Value
libyui.so.9()(64bit) -
libyui9 = 3.4.2-3.1
libyui9(x86-64) = 3.4.2-3.1
yast2-libyui = 2.42.0

Obsoletes

Name Value
yast2-libyui < 2.42.0

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libyui9-3.4.2-3.1.x86_64.rpm
Source Package libyui-3.4.2-3.1.src.rpm

Install Howto

Install libyui9 rpm package:

# zypper install libyui9

Files

Path
/usr/lib64/libyui.so.9
/usr/lib64/libyui.so.9.0.0
/usr/lib64/yui/
/usr/share/doc/packages/libyui9/COPYING.gpl-3
/usr/share/doc/packages/libyui9/COPYING.lgpl-2.1
/usr/share/doc/packages/libyui9/COPYING.lgpl-3
/usr/share/libyui/

Changelog

2018-08-21 - schubi@suse.de
- Changed dir of COPYING file.
2018-07-26 - lslezak@suse.cz
- Improved the FSize class to handle arbitrary sizes, use the boost
multiprecision library instead of `long long` which overflows for
values > 8EiB (bsc#991090)
- 3.4.2
2018-05-09 - mliska@suse.cz
- Fix GCC 8 warning: -Werror=catch-value (boo#1084636).
- 3.4.1
2017-11-15 - shundhammer@suse.de
- Support for sending a widget ID with Shift-F6 for automated testing
(fate#324098)
- 3.4.0
2017-08-03 - besser82@fedoraproject.org
- CMake 3.9 warns about CMP0028 being obsolete
- 3.3.3
2017-04-14 - besser82@fedoraproject.org
- Add $(ENV:YUI_PREFERED_BACKEND) to set prefered UI-backend
- Avoid several warnings from CMake
- 3.3.2
2017-04-13 - besser82@fedoraproject.org
- Fix detection of Desktop Environments
- 3.3.1
2017-04-13 - besser82@fedoraproject.org
- Add YSettings::loadedUI option (gh#libyui/libyui#35)
- Prefer Gtk-UI on Gtk-based desktop enviroments
- Bump SO-name and minor version for API-change
- 3.3.0
2016-11-25 - jreidinger@suse.com
- implement shortcut conflicts resolver for menu buttons
(bsc#940817)
- 3.2.9
2016-10-14 - jreidinger@suse.com
- Fixed a Wmismatched-tags warning on clang/OSX (gh#libyui/libyui#33)
- 3.2.8

See Also

Package Description
libz1-1.2.11-6.1.i586.rpm Library implementing the DEFLATE compression algorithm
libz1-1.2.11-6.1.x86_64.rpm Library implementing the DEFLATE compression algorithm
libz1-32bit-1.2.11-6.1.x86_64.rpm Library implementing the DEFLATE compression algorithm
libz3-4_8-4.8.3+git.20181121-1.3.i586.rpm Library for the Z3 SMT theorem prover
libz3-4_8-4.8.3+git.20181121-1.3.x86_64.rpm Library for the Z3 SMT theorem prover
libzapojit-0_0-0-0.0.3-6.5.i586.rpm Library for the SkyDrive and Hotmail REST APIs
libzapojit-0_0-0-0.0.3-6.5.x86_64.rpm Library for the SkyDrive and Hotmail REST APIs
libzapojit-devel-0.0.3-6.5.i586.rpm Library for the SkyDrive and Hotmail REST APIs -- Development Files
libzapojit-devel-0.0.3-6.5.x86_64.rpm Library for the SkyDrive and Hotmail REST APIs -- Development Files
libzbar-devel-0.22-1.1.i586.rpm Development environment for the ZBar library
libzbar-devel-0.22-1.1.x86_64.rpm Development environment for the ZBar library
libzbar0-0.22-1.1.i586.rpm Bar code reading library
libzbar0-0.22-1.1.x86_64.rpm Bar code reading library
libzbar0-32bit-0.22-1.1.x86_64.rpm Bar code reading library
libzbarqt-devel-0.22-1.1.i586.rpm Development environment for the ZBar Qt bindings library
Advertisement
Advertisement