libvdpau1-1.2-1.1.i586.rpm


Advertisement

Description

libvdpau1 - VDPAU wrapper library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libvdpau1-1.2-1.1.i586.rpm
Package name libvdpau1
Package version 1.2
Package release 1.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.freedesktop.org/wiki/Software/VDPAU/
License MIT
Maintainer -
Download size 25.40 KB
Installed size 48.08 KB
This package contains the libvdpau wrapper library and the libvdpau_trace
debugging library, along with the header files needed to build VDPAU
applications.  To actually use a VDPAU device, you need a vendor-specific
implementation library.  Currently, this is always libvdpau_nvidia.  You can
override the driver name by setting the VDPAU_DRIVER environment variable.

Alternatives

Package Version Architecture Repository
libvdpau1-1.2-1.1.x86_64.rpm 1.2 x86_64 openSUSE Oss
libvdpau1 - - -

Requires

Name Value
/sbin/ldconfig -
libX11.so.6 -
libXext.so.6 -
libc.so.6(GLIBC_2.17) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -

Provides

Name Value
config(libvdpau1) = 1.2-1.1
libvdpau = 1.2-1.1
libvdpau.so.1 -
libvdpau1 = 1.2-1.1
libvdpau1(x86-32) = 1.2-1.1

Obsoletes

Name Value
libvdpau < 1.2-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libvdpau1-1.2-1.1.i586.rpm
Source Package libvdpau-1.2-1.1.src.rpm

Install Howto

Install libvdpau1 rpm package:

# zypper install libvdpau1

Files

Path
/etc/vdpau_wrapper.cfg
/usr/bin/vdpauinfo
/usr/lib/libvdpau.so.1
/usr/lib/libvdpau.so.1.0.0
/usr/lib/vdpau/

Changelog

2019-03-01 - Stefan Dirsch <sndirsch@suse.com>
- Update libvdpau to version 1.2
* This version of libvdpau adds new chroma types defining whether
surfaces contain frames or fields, and a new picture parameter
structure that supports HEVC 4:4:4 pictures.
- supersedes U_Add_missing_include_of_config_h_to_define_GNU_SOURCE.patch
2018-12-12 - Jan Engelhardt <jengelh@inai.de>
- Update RPM groups and %make(_)install call.
2018-12-12 - Dominique Leuenberger <dimstar@opensuse.org>
- Drop graphviz BuildRequires: we lose the doc with this, but
manage to break a build cycle.
2017-05-30 - sndirsch@suse.com
- includes everything needed for missing sle issue entries:
* fate #315643-315645, 319159-319161, 319618 (bsc#1041623)
* bnc#943967, bnc#943968, bnc#943969 (bsc#1041623)
* CVE-2015-5198, CVE-2015-5199, CVE-2015-5200 (bsc#1041623)
2015-09-07 - sndirsch@suse.com
- replaced u_src-mesa_dri2.c-define-_GNU_SOURCE.patch with upstream
U_Add_missing_include_of_config_h_to_define_GNU_SOURCE.patch
2015-09-02 - sndirsch@suse.com
- added missing BuildRequires for pkgconfig(dri2proto)
- u_src-mesa_dri2.c-define-_GNU_SOURCE.patch
* Without having defined _GNU_SOURCE __USE_GNU isn't defined
either. Though secure_getenv() in stdlib.h isn't declared.
2015-09-01 - sndirsch@suse.com
- Update libvdpau to version 1.1.1 (bnc#943967,#943968,#943969)
libvdpau versions 1.1 and earlier, when used in setuid or setgid
applications, contain vulnerabilities related to environment
variable handling that could allow an attacker to execute
arbitrary code or overwrite arbitrary files.  See CVE-2015-5198,
CVE-2015-5199, and CVE-2015-5200 for more details.
This release uses the secure_getenv() function, when available,
to fix these problems. The updated libvdpau will instead use a
fallback implementation of secure_getenv() when the platform
doesn't provide one.
If you use the NVIDIA .run installer packages, please see
https://devtalk.nvidia.com/default/topic/873035 for additional
information.
This release also adds tracing of HEVC picture structures to
libvdpau_trace.
- supersedes patch: libvdpau-nopdftex.patch
2015-03-17 - sndirsch@suse.com
- Update libvdpau to version 1.1
* This release fixes a bug in the new VdpPictureInfoHEVC structure:
the column_width_minus1 and row_height_minus1 arrays had the wrong
dimensions. To avoid the incorrect structure being used, the profile
numbers for the HEVC profiles have been changed. Please use the new
profiles rather than the ones from libvdpau 1.0.
2015-03-16 - sndirsch@suse.com
- Update libvdpau to version 1.0
* This release adds support for the following HEVC / H.265 profiles:
VDP_DECODER_PROFILE_HEVC_MAIN
VDP_DECODER_PROFILE_HEVC_MAIN_10
VDP_DECODER_PROFILE_HEVC_MAIN_STILL
VDP_DECODER_PROFILE_HEVC_MAIN_12
VDP_DECODER_PROFILE_HEVC_MAIN_444
- Updated vdpauinfo to version 0.9
* This release adds support for querying the new profiles added in
libvdpau 1.0 (see above)
- cleanup: removed empty patch 'vdpauinfo-missing-lX11.diff'

See Also

Package Description
libvdpau1-32bit-1.2-1.1.x86_64.rpm VDPAU wrapper library
libvdpau_nouveau-19.0.3-219.1.i586.rpm XVMC state tracker for Nouveau
libvdpau_nouveau-19.0.3-219.1.x86_64.rpm XVMC state tracker for Nouveau
libvdpau_nouveau-32bit-19.0.3-219.1.x86_64.rpm XVMC state tracker for Nouveau
libvdpau_r300-19.0.3-219.1.i586.rpm XVMC state tracker for R300
libvdpau_r300-19.0.3-219.1.x86_64.rpm XVMC state tracker for R300
libvdpau_r300-32bit-19.0.3-219.1.x86_64.rpm XVMC state tracker for R300
libvdpau_r600-19.0.3-219.1.i586.rpm XVMC state tracker for R600
libvdpau_r600-19.0.3-219.1.x86_64.rpm XVMC state tracker for R600
libvdpau_r600-32bit-19.0.3-219.1.x86_64.rpm XVMC state tracker for R600
libvdpau_radeonsi-19.0.3-219.1.i586.rpm XVMC state tracker for radeonsi
libvdpau_radeonsi-19.0.3-219.1.x86_64.rpm XVMC state tracker for radeonsi
libvdpau_radeonsi-32bit-19.0.3-219.1.x86_64.rpm XVMC state tracker for radeonsi
libvdpau_trace1-1.2-1.1.i586.rpm VDPAU trace library
libvdpau_trace1-1.2-1.1.x86_64.rpm VDPAU trace library
Advertisement
Advertisement