libulfius2_5-2.5.4-1.1.x86_64.rpm


Advertisement

Description

libulfius2_5 - Web Framework for REST Applications in C

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libulfius2_5-2.5.4-1.1.x86_64.rpm
Package name libulfius2_5
Package version 2.5.4
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://github.com/babelouest/ulfius
License MIT
Maintainer -
Download size 53.98 KB
Installed size 129.06 KB
The library is based on GNU libmicrohttpd for the backend web server, jansson
for the json manipulation library, and libcurl for the HTTP/SMTP client API.
It can be used to create web applications in C programs.

Alternatives

Package Version Architecture Repository
libulfius2_5-2.5.4-1.1.i586.rpm 2.5.4 i586 openSUSE Oss
libulfius2_5 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.17)(64bit) -
libcurl.so.4()(64bit) -
libgnutls.so.30()(64bit) -
libgnutls.so.30(GNUTLS_3_4)(64bit) -
libjansson.so.4()(64bit) -
libmicrohttpd.so.12()(64bit) -
liborcania.so.1.2()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libyder.so.1.4()(64bit) -

Provides

Name Value
libulfius.so.2.5()(64bit) -
libulfius2_5 = 2.5.4-1.1
libulfius2_5(x86-64) = 2.5.4-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libulfius2_5-2.5.4-1.1.x86_64.rpm
Source Package ulfius-2.5.4-1.1.src.rpm

Install Howto

Install libulfius2_5 rpm package:

# zypper install libulfius2_5

Files

Path
/usr/lib64/libulfius.so.2.5
/usr/lib64/libulfius.so.2.5.4
/usr/share/doc/packages/libulfius2_5/CHANGELOG.md
/usr/share/doc/packages/libulfius2_5/README.md
/usr/share/licenses/libulfius2_5/LICENSE

Changelog

2019-04-07 - Martin Hauke <mardnh@gmx.de>
- Update to version 2.5.4
* Align PKGCONF_REQ_PRIVATE required versions
* Backport ulfius_copy_request, ulfius_duplicate_request,
ulfius_copy_response and ulfius_duplicate_response from Ulfius 2.6
2019-01-12 - mardnh@gmx.de
- Update to version 2.5.3
- Add flag to build Ulfius with GnuTLS support but without
Websockets.
- Fix CMake build process that didn't obviously linked Ulfius
with pthreads.
2018-12-28 - mardnh@gmx.de
- Update to version 2.5.2
* Fix utf8 check on NULL value
- Update to version 2.5.1
* Fix uwsc crash on some systems
- Update to version 2.5.0
* Add struct _u_endpoint.check_utf8 to check all request parameters
and values to be valid utf8 strings.
* Add client certificate authentication for webservice and send
request library.
* Add support for SameSite attribute in response cookies
- Update to version 2.4.4
* CMake scripts improvements
- Update to version 2.4.3
* Add config file ulfius-cfg.h dynamically built with the options
* Adapt examples with new ulfius-cfg.h file
- Update to version 2.4.2
* Fix #79 where yuarel should be hidden from the outside world
- Update to version 2.4.1
* Fix #78 where gnutls is not required if websocket is disabled
- Update to version 2.4.0
* Fix Websocket fragmented messages
* Fix CMake script that installed Orcania twice
* Fix cppcheck warnings
* Add timeout for http connections
* Allow to use MHD_RESPMEM_MUST_COPY for different memory manager
* Add websocket client framework
* Add uwsc - Ulfius WebSocket Client
A simple command-line websocket client program
- Remove patches (included/fixed upstream):
* 0001-Fix-pkg-config-information-add-requires-fields-as-me.patch
* ulfius-fix-cmake-path.patch
- Create subpackage "uwsc" for the Ulfius WebSocket Client program
2018-08-11 - jengelh@inai.de
- Description update.
2018-07-29 - mardnh@gmx.de
- Initial package, version 2.3.8

See Also

Package Description
libulockmgr1-2.9.8-3.1.i586.rpm Library of FUSE, the User space File System for GNU/Linux and BSD
libulockmgr1-2.9.8-3.1.x86_64.rpm Library of FUSE, the User space File System for GNU/Linux and BSD
libumfpack5-5.7.8-32.1.i586.rpm Sparse Multifrontal LU Factorization
libumfpack5-5.7.8-32.1.x86_64.rpm Sparse Multifrontal LU Factorization
libuna-devel-0~20190102-1.1.i586.rpm Development files for libuna, a library to support Unicode/ASCII conversions
libuna-devel-0~20190102-1.1.x86_64.rpm Development files for libuna, a library to support Unicode/ASCII conversions
libuna-tools-0~20190102-1.1.i586.rpm Utilities from libuna for Unicode/ASCII Byte Stream conversions
libuna-tools-0~20190102-1.1.x86_64.rpm Utilities from libuna for Unicode/ASCII Byte Stream conversions
libuna1-0~20190102-1.1.i586.rpm Library to support Unicode and ASCII (byte string) conversions
libuna1-0~20190102-1.1.x86_64.rpm Library to support Unicode and ASCII (byte string) conversions
libunbound-devel-mini-1.9.1-2.1.i586.rpm Just a devel package for build loops
libunbound-devel-mini-1.9.1-2.1.x86_64.rpm Just a devel package for build loops
libunbound2-1.9.1-2.1.i586.rpm Shared library from unbound
libunbound2-1.9.1-2.1.x86_64.rpm Shared library from unbound
libunibilium4-2.0.0-1.4.i586.rpm A terminfo parsing library
Advertisement
Advertisement