libtexluajit2-2.1.0beta3-56.1.i586.rpm


Advertisement

Description

libtexluajit2 - Libraries of Just-In-Time compiler for Lua

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libtexluajit2-2.1.0beta3-56.1.i586.rpm
Package name libtexluajit2
Package version 2.1.0beta3
Package release 56.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://www.tug.org/texlive/
License MIT
Maintainer -
Download size 248.63 KB
Installed size 513.73 KB
LuaJIT is a Just-In-Time (JIT) compiler for the Lua programming language

Alternatives

Package Version Architecture Repository
libtexluajit2-2.1.0beta3-56.1.x86_64.rpm 2.1.0beta3 x86_64 openSUSE Oss
libtexluajit2 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.7) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.3) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.29) -

Provides

Name Value
libtexluajit.so.2 -
libtexluajit2 = 2.1.0beta3-56.1
libtexluajit2(x86-32) = 2.1.0beta3-56.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libtexluajit2-2.1.0beta3-56.1.i586.rpm
Source Package texlive-2018.20180414-56.1.src.rpm

Install Howto

Install libtexluajit2 rpm package:

# zypper install libtexluajit2

Files

Path
/usr/lib/libtexluajit.so.2
/usr/lib/libtexluajit.so.2.1.0

Changelog

2019-04-24 - Martin Li?ka <mliska@suse.cz>
- Disable LTO (boo#1133287).
2018-12-21 - Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
- Add patches for poppler 0.72:
* Rebase/extend source-fix-const-poppler0.66.0.patch and apply for
all versions using pdf*-newpoppler.cc
* source-fix-bool-poppler.patch
* source-poppler-use-std_string.patch
* source-poppler-fix-dict-memleak.patch
- Add source-lua-fix-bad-compare.patch
- Drop source-lua-poppler0640.dif, instead of casting the const's
away, add const where appropriate
2018-09-26 - Dr. Werner Fink <werner@suse.de>
- Add patch source-bsc1109673.dif to fix bsc#1109673 for CVE-2018-17407
which is about buffer overflow in the handling of Type 1 fonts
allowing arbitrary code execution
2018-07-19 - alarrosa@suse.com
- Add source-fix-const-poppler0.66.0.patch to fix several const
issues that broke the build of texlive with poppler 0.66.0.
2018-07-16 - werner@suse.de
- Add a view dependencies to perl-biber
2018-05-10 - werner@suse.de
- Let texlive-kpathsea-bin Pre Require texlive-tetex-bin
2018-05-08 - werner@suse.de
- Respect rename of texconfig to tetex
2018-05-07 - werner@suse.de
- Add patch source-tounicode.difto fix tounicode entries for
ligatures in pdf output of xelatex
2018-05-07 - idonmez@suse.com
- Add freetype-use-pkg-config.patch to fix build with new Freetype:
use pkgconfig to find Freetype libraries.
2018-05-04 - werner@suse.de
- Shorten reautoconfig a bit that is only reconfigure trees with
changed ac files

See Also

Package Description
libthai-data-0.1.27-2.3.i586.rpm Data files for the Thai language support library
libthai-data-0.1.27-2.3.x86_64.rpm Data files for the Thai language support library
libthai-devel-0.1.27-2.3.i586.rpm Development files for the Thai language support library
libthai-devel-0.1.27-2.3.x86_64.rpm Development files for the Thai language support library
libthai0-0.1.27-2.3.i586.rpm Thai Language Support Routines
libthai0-0.1.27-2.3.x86_64.rpm Thai Language Support Routines
libthai0-32bit-0.1.27-2.3.x86_64.rpm Thai Language Support Routines
libtheora-devel-1.1.1-29.15.i586.rpm Theora video compression codec
libtheora-devel-1.1.1-29.15.x86_64.rpm Theora video compression codec
libtheora0-1.1.1-29.15.i586.rpm Theora video compression codec
libtheora0-1.1.1-29.15.x86_64.rpm Theora video compression codec
libtheora0-32bit-1.1.1-29.15.x86_64.rpm Theora video compression codec
libtheoradec1-1.1.1-29.15.i586.rpm Theora video decompression library
libtheoradec1-1.1.1-29.15.x86_64.rpm Theora video decompression library
libtheoradec1-32bit-1.1.1-29.15.x86_64.rpm Theora video decompression library
Advertisement
Advertisement