libsss_idmap0-2.1.0-1.1.x86_64.rpm


Advertisement

Description

libsss_idmap0 - FreeIPA ID mapping library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libsss_idmap0-2.1.0-1.1.x86_64.rpm
Package name libsss_idmap0
Package version 2.1.0
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://pagure.io/SSSD/sssd
License LGPL-3.0+
Maintainer -
Download size 52.05 KB
Installed size 34.30 KB
A utility library for FreeIPA to map Windows SIDs to Unix user/group IDs.

Alternatives

Package Version Architecture Repository
libsss_idmap0-2.1.0-1.1.i586.rpm 2.1.0 i586 openSUSE Oss
libsss_idmap0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -

Provides

Name Value
libsss_idmap.so.0()(64bit) -
libsss_idmap.so.0(SSS_IDMAP_0.4)(64bit) -
libsss_idmap.so.0(SSS_IDMAP_0.5)(64bit) -
libsss_idmap0 = 2.1.0-1.1
libsss_idmap0(x86-64) = 2.1.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libsss_idmap0-2.1.0-1.1.x86_64.rpm
Source Package sssd-2.1.0-1.1.src.rpm

Install Howto

Install libsss_idmap0 rpm package:

# zypper install libsss_idmap0

Files

Path
/usr/lib64/libsss_idmap.so.0
/usr/lib64/libsss_idmap.so.0.5.1

Changelog

2019-03-16 - Jan Engelhardt <jengelh@inai.de>
- Update to new upstream release 2.1.0
* Any provider can now match and map certificates to user
identities.
* pam_sss can now be configured to only perform Smart Card
authentication or return an error if this is not possible.
* pam_sss can also prompt the user to insert a Smart Card if,
during an authentication it is not available.
* A new configuration option ad_gpo_implicit_deny was added.
This option (when set to True) can be used to deny access to
users even if there is not applicable GPO.
* The dynamic DNS update can now batch DNS updates to include
all address family updates in a single transaction.
2019-02-20 - Samuel Cabrero <scabrero@suse.de>
- Install systemd service unit file created from source's template
(bsc#1120852)
- Install logrotate configuration (bsc#1004220)
- Set journald as system logger
2019-02-15 - Jan Engelhardt <jengelh@inai.de>
- Add krb-noversion.diff so sssd_pac builds even with newer krb.
2018-10-01 - ckowalczyk@suse.com
- Add dependency to adcli for sssd-ad
(SLE15: fate#326619, bsc#1109849)
(SLE12SP4: fate#326620, bsc#1110121)
2018-09-07 - Jan Engelhardt <jengelh@inai.de>
- Update to new upstream release 2.0.0
* The Python API for managing users and groups in local domains
(id_provider=local) was removed completely. The local
provider (id_provider=local) and the command line tools to
manage users and groups in the local domains, such as
sss_useradd is not built anymore.
* The LDAP provider had a special-case branch for evaluating
group memberships with the RFC2307bis schema when group
nesting was explicitly disabled. This codepath is removed.
* The "ldap_sudo_include_regexp" option changed its default
value from true to false. Wildcards in the sudoHost LDAP
attribute are no longer evaluated. This was costly to
evaluate on the LDAP server side and at the same time rarely
used.
* The list of PAM services which are allowed to authenticate
using a Smart Card is now configurable using a new option
pam_p11_allowed_services.
2018-08-31 - kbabioch@suse.com
- Update to upstream release 1.16.3
* New Features:
* kdcinfo files for informing krb5 about discovered KDCs are
now also generated for trusted domains in setups that use
id_provider=ad and IPA masters in a trust relationship with
an AD domain.
* The Kerberlos locator plugin can now process multiple
address if SSSD generates more than one. A
* Bug fixes:
* Fixed information leak due to incorrect permissions on
/var/lib/sss/pipes/sudo [CVE-2018-10852, bsc#1098377]
* Cached password are now stored with a salt. Old ones will be
regenerated on next authentication, and the auth server needs
to be reachable for that.
* The sss_ssh proces leaked file descriptors when converting
more than one X.509 certificate to an SSH public key.
* The PAC responder is now able to process Domain Local in case
the PAC uses SID compression (Windows Server 2012+).
* Address the issue that some versions of OpenSSH would close
the pipe towards sss_ssh_authorizedkeys when the matching key
is found before the rest of the output is read.
* User lookups no longer fail if user's e-mail address
conflicts with another user's fully qualified name.
* The override_shell and override_homedir options are no longer
applied to entries from the files domain.
* The grace logins with an expired password when authenticating
against certain newer versions of the 389DS/RHDS LDAP server
did not work.
- Removed patches that are included upstream now:
0001-SUDO-Create-the-socket-with-stricter-permissions.patch,
0002-intg-Do-not-hardcode-nsslibdir.patch,
0003-Fix-build-for-1-16-2-version.patch
2018-07-01 - ckowalczyk@suse.com
- Fixed patch name.

See Also

Package Description
libsss_nss_idmap-devel-2.1.0-1.1.i586.rpm Development files for the FreeIPA idmap library
libsss_nss_idmap-devel-2.1.0-1.1.x86_64.rpm Development files for the FreeIPA idmap library
libsss_nss_idmap0-2.1.0-1.1.i586.rpm FreeIPA ID mapping library
libsss_nss_idmap0-2.1.0-1.1.x86_64.rpm FreeIPA ID mapping library
libsss_simpleifp-devel-2.1.0-1.1.i586.rpm Development files for the SSSD D-Bus responder helper library
libsss_simpleifp-devel-2.1.0-1.1.x86_64.rpm Development files for the SSSD D-Bus responder helper library
libsss_simpleifp0-2.1.0-1.1.i586.rpm The SSSD D-Bus responder helper library
libsss_simpleifp0-2.1.0-1.1.x86_64.rpm The SSSD D-Bus responder helper library
libstaroffice-0_0-0-0.0.6-1.4.i586.rpm A library for import of StarOffice documents
libstaroffice-0_0-0-0.0.6-1.4.x86_64.rpm A library for import of StarOffice documents
libstaroffice-devel-0.0.6-1.4.i586.rpm A library for import of StarOffice documents
libstaroffice-devel-0.0.6-1.4.x86_64.rpm A library for import of StarOffice documents
libstaroffice-devel-doc-0.0.6-1.4.noarch.rpm Documentation for the libstaroffice API
libstaroffice-tools-0.0.6-1.4.i586.rpm Tools to work with documents in StarOffice formats
libstaroffice-tools-0.0.6-1.4.x86_64.rpm Tools to work with documents in StarOffice formats
Advertisement
Advertisement