libspeechd2-32bit-0.9.0-2.1.x86_64.rpm


Advertisement

Description

libspeechd2-32bit - Device independent layer for speech synthesis - Client library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libspeechd2-32bit-0.9.0-2.1.x86_64.rpm
Package name libspeechd2-32bit
Package version 0.9.0
Package release 2.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://devel.freebsoft.org/speechd
License GPL-2.0-or-later
Maintainer -
Download size 26.88 KB
Installed size 41.64 KB
The goal of Speech Dispatcher project is to provide a high-level device
independent layer for speech synthesis through a simple, stable and
well documented interface.
What is a very high level GUI library to graphics, Speech Dispatcher is
to speech synthesis. The application neither needs to talk to the
devices directly nor to handle concurrent access, sound output and other
tricky aspects of the speech subsystem.

Alternatives

Package Version Architecture Repository
libspeechd2-32bit-0.9.0-70.2.x86_64.rpm 0.9.0 x86_64 Hardware
libspeechd2-32bit - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libglib-2.0.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -

Provides

Name Value
libspeechd.so.2 -
libspeechd2-32bit = 0.9.0-2.1
libspeechd2-32bit(x86-32) = 0.9.0-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libspeechd2-32bit-0.9.0-2.1.x86_64.rpm
Source Package speech-dispatcher-0.9.0-2.1.src.rpm

Install Howto

Install libspeechd2-32bit rpm package:

# zypper install libspeechd2-32bit

Files

Path
/usr/lib/libspeechd.so.2
/usr/lib/libspeechd.so.2.6.0

Changelog

2019-03-28 - Jan Engelhardt <jengelh@inai.de>
- Reduce scriptlets' hard dependency by switching to
%systemd_ordering.
- Modernize specfile a bit: make use of %make_install, and drop
redundant "--sysconfdir=%_sysconfdir" from the %configure call.
2019-03-27 - Dominique Leuenberger <dimstar@opensuse.org>
- Revert setting includedir explicitly: upstream had this fixed in
2015 in the build system directly (bsc#1129586 is thus no longer
applicable since speech-dispatcher 0.8.4).
2019-03-19 - ro@suse.de
- set includedir to fix the entries in the pkg-config file
(bsc#1129586).
2019-02-28 - mgorse@suse.com
- Update to version 0.9.0:
* Add modules for non-free Baratinoo (VoxyGen) and Kali speech
syntheses.
* Add configuration file for the Mary-TTS system.
* Add configuration file for espeak-ng + mbrola.
* Set the pulse client name when using the generic module with
paplay.
* espeak-*-mbrola-generic: Update voice list.
* Auto-detect module availability.
* Make generic module provide voice list.
* Add systemd service file.
- Update docs
- Mark COPYING.LGPL with %license
- Update source URL.
2018-08-03 - mgorse@suse.com
- Fix enabling of espeak-ng  in speechd.conf to use
espeak-ng.conf, rather than espeak.conf.
2018-03-05 - aloisio@gmx.com
- Use espeak-ng when available
2018-02-07 - aloisio@gmx.com
- Update to version 0.8.8
* Add German translation, thanks to Chris Leick for the patch
* Fix some spelling mistakes, thanks to Paul Gevers for the patch
* Some slight code improvements
2018-01-03 - dimstar@opensuse.org
- Add baselibs.conf: create libspeechd2-32bit, required by
libQt5TextToSpeech5-32bit.
2017-11-30 - dimstar@opensuse.org
- Drop py_requires: this is a static python2-dependency on a
python3 package.
2017-09-15 - mgorse@suse.com
- Update to version 0.8.7:
+ Further fixes to spd-conf, which should now work properly.
+ Split the espeak-ng driver code into its own source file.
+ Add a work-around to the espeak-ng driver to account for spaces
in voice names which recently appeared in espeak-ng git master.
This will properly be fixed in 0.9.
+ Voice names are not forced to lower case, due to espeak-ng
git master now having multi-case voice names.
+ Fix stripped audio output from the flite module.
+ Further code and build improvements.
- Changes from version 0.8.6:
+ Various internal code improvements.
+ Fix more compiler warnings.
+ Python bug fixes with thanks to Sebastian Humenda.
- Changes from version 0.8.5:
+ Use GLib main loop for the main server thread
+ Implement a shutdown timer in the server
+ Add support for espeak-ng.
+ Document an ibmtts configuration option
+ Removal of configuration options in the code that were not
actually being used.
+ Added a command-line argument to allow for custom modules
location.
- Add ANNOUNCE; remove ChangeLog (no longer shipped)

See Also

Package Description
libspeex1-1.2-1.6.i586.rpm An Open Source, Patent Free Speech Codec Library
libspeex1-1.2-1.6.x86_64.rpm An Open Source, Patent Free Speech Codec Library
libspeex1-32bit-1.2-1.6.x86_64.rpm An Open Source, Patent Free Speech Codec Library
libspeexdsp1-1.2~rc3-4.4.i586.rpm An Open Source, Patent Free Speech Codec Library
libspeexdsp1-1.2~rc3-4.4.x86_64.rpm An Open Source, Patent Free Speech Codec Library
libspeexdsp1-32bit-1.2~rc3-4.4.x86_64.rpm An Open Source, Patent Free Speech Codec Library
libspf2-2-1.2.10-3.13.i586.rpm Development Package for libspf2
libspf2-2-1.2.10-3.13.x86_64.rpm Development Package for libspf2
libspf2-devel-1.2.10-3.13.i586.rpm Development files for libspf
libspf2-devel-1.2.10-3.13.x86_64.rpm Development files for libspf
libspf2-tools-1.2.10-3.13.i586.rpm Tools to work with libspf2
libspf2-tools-1.2.10-3.13.x86_64.rpm Tools to work with libspf2
libsphinxbase1-0.8-3.1.i586.rpm Sphinxbase speech recognizer library
libsphinxbase1-0.8-3.1.x86_64.rpm Sphinxbase speech recognizer library
libsphinxclient-0_0_1-2.2.11-4.1.i586.rpm Pure C searchd client API library
Advertisement
Advertisement