libspatialite-devel-4.3.0a-3.1.x86_64.rpm


Advertisement

Description

libspatialite-devel - Development files for libspatialite

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libspatialite-devel-4.3.0a-3.1.x86_64.rpm
Package name libspatialite-devel
Package version 4.3.0a
Package release 3.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/C and C++
Homepage http://www.gaia-gis.it/spatialite/
License MPL-1.1
Maintainer -
Download size 74.16 KB
Installed size 533.64 KB
This package contains all necessary include files and libraries needed
to compile and develop applications that use libspatialite.

Alternatives

Package Version Architecture Repository
libspatialite-devel-4.3.0a-15.1.x86_64.rpm 4.3.0a x86_64 Science
libspatialite-devel-4.3.0a-15.1.i586.rpm 4.3.0a i586 Science
libspatialite-devel-4.3.0a-3.1.i586.rpm 4.3.0a i586 openSUSE Oss
libspatialite-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libspatialite7 = 4.3.0a

Provides

Name Value
libspatialite-devel = 4.3.0a-3.1
libspatialite-devel(x86-64) = 4.3.0a-3.1
pkgconfig(spatialite) = 4.3.0a

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libspatialite-devel-4.3.0a-3.1.x86_64.rpm
Source Package libspatialite-4.3.0a-3.1.src.rpm

Install Howto

Install libspatialite-devel rpm package:

# zypper install libspatialite-devel

Files

Path
/usr/include/spatialite.h
/usr/include/spatialite/control_points.h
/usr/include/spatialite/debug.h
/usr/include/spatialite/gaiaaux.h
/usr/include/spatialite/gaiaexif.h
/usr/include/spatialite/gaiageo.h
/usr/include/spatialite/gaiamatrix.h
/usr/include/spatialite/geopackage.h
/usr/include/spatialite/gg_advanced.h
/usr/include/spatialite/gg_const.h
/usr/include/spatialite/gg_core.h
/usr/include/spatialite/gg_dxf.h
/usr/include/spatialite/gg_dynamic.h
/usr/include/spatialite/gg_formats.h
/usr/include/spatialite/gg_mbr.h
/usr/include/spatialite/gg_structs.h
/usr/include/spatialite/gg_wfs.h
/usr/include/spatialite/gg_xml.h
/usr/include/spatialite/spatialite.h
/usr/include/spatialite/sqlite.h
/usr/lib64/libspatialite.so
/usr/lib64/mod_spatialite.so
/usr/lib64/pkgconfig/spatialite.pc
/usr/share/doc/packages/libspatialite-devel/README
/usr/share/doc/packages/libspatialite-devel/README.coverage
/usr/share/licenses/libspatialite-devel/COPYING

Changelog

2019-03-17 - Mykola Krachkovsky <w01dnick@gmail.com>
- fixed build with newer libproj (using of deprecated API)
* added libspatialite-deprecated-proj-api.patch
2017-12-04 - mpluskal@suse.com
- Do not build documentation
- Small spec file cleanup
2015-11-08 - p.drouand@gmail.com
- Update to version 4.3.0a
* No changelog provided
- Add graphviz build requires; new dependency
2015-03-07 - mpluskal@suse.com
- Remove unknown configure flags
- Don't fail build because of failing test
2015-02-04 - mpluskal@suse.com
- Fix library category
- Actually try to use fdupes
2015-02-04 - kukuk@suse.de
- Fix library package name according shared library policy
2015-01-31 - mpluskal@suse.com
- Minor spec file cleanup
- Use url for source
- Install LICENCE, README and README.coverage
- Build documentation and bundle it with -devel package
- Enable and execute tests
- Update to version 4.2.0 (no changelog provided)
2013-07-07 - tzotsos@opensuse.org
- Updated to version 4.1.1
2013-02-10 - behrisch@users.sourceforge.net
- Added CFLAGS="-std=c99" for older compilers
2012-11-26 - tzotsos@opensuse.org
- Updated to version 4.0.0

See Also

Package Description
libspatialite7-4.3.0a-3.1.i586.rpm Spatial SQLite
libspatialite7-4.3.0a-3.1.x86_64.rpm Spatial SQLite
libspdylay7-1.4.0-3.4.i586.rpm SPDY C Library
libspdylay7-1.4.0-3.4.x86_64.rpm SPDY C Library
libspectre-devel-0.2.8-2.11.i586.rpm Library for Rendering PostScript Documents
libspectre-devel-0.2.8-2.11.x86_64.rpm Library for Rendering PostScript Documents
libspectre1-0.2.8-2.11.i586.rpm Library for Rendering PostScript Documents
libspectre1-0.2.8-2.11.x86_64.rpm Library for Rendering PostScript Documents
libspeechd-devel-0.9.0-2.1.i586.rpm Device independent layer for speech synthesis - Development files
libspeechd-devel-0.9.0-2.1.x86_64.rpm Device independent layer for speech synthesis - Development files
libspeechd2-0.9.0-2.1.i586.rpm Device independent layer for speech synthesis - Client library
libspeechd2-0.9.0-2.1.x86_64.rpm Device independent layer for speech synthesis - Client library
libspeechd2-32bit-0.9.0-2.1.x86_64.rpm Device independent layer for speech synthesis - Client library
libspeex1-1.2-1.6.i586.rpm An Open Source, Patent Free Speech Codec Library
libspeex1-1.2-1.6.x86_64.rpm An Open Source, Patent Free Speech Codec Library
Advertisement
Advertisement