libsigsegv2-2.12-2.1.x86_64.rpm


Advertisement

Description

libsigsegv2 - Library for Handling Page Faults in User Mode

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libsigsegv2-2.12-2.1.x86_64.rpm
Package name libsigsegv2
Package version 2.12
Package release 2.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://www.gnu.org/software/libsigsegv/
License GPL-2.0-or-later
Maintainer -
Download size 14.25 KB
Installed size 18.16 KB
This is a library for handling page faults in user mode. A page fault occurs
when a program tries to access to a region of memory that is currently not
available.

Alternatives

Package Version Architecture Repository
libsigsegv2-2.12-2.1.i586.rpm 2.12 i586 openSUSE Oss
libsigsegv2 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -

Provides

Name Value
libsigsegv.so.2()(64bit) -
libsigsegv2 = 2.12-2.1
libsigsegv2(x86-64) = 2.12-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libsigsegv2-2.12-2.1.x86_64.rpm
Source Package libsigsegv-2.12-2.1.src.rpm

Install Howto

Install libsigsegv2 rpm package:

# zypper install libsigsegv2

Files

Path
/usr/lib64/libsigsegv.so.2
/usr/lib64/libsigsegv.so.2.0.5

Changelog

2019-04-26 - Dr. Werner Fink <werner@suse.de>
- Allow LTO but only FAT LTO OBJECTS (boo#1133245)
2019-04-25 - Dr. Werner Fink <werner@suse.de>
- Add patch libsigsegv-2.12-lto.dif
* Avoid redefinition of structures of <bits/sigcontext.h> by
<asm/sigcontext.h>
* Avoid moved logic in resulting assembler code for LTO objects
in signal handler for segmentation faults
2019-04-25 - Dr. Werner Fink <werner@suse.de>
- Avoid none debugging libsigsegv, that is add -fno-lto (boo#1133245)
- Use %license if known
2019-04-24 - Martin Li?ka <mliska@suse.cz>
- Disable LTO (boo#1133245).
2018-02-01 - astieger@suse.com
- update to 2.12:
* updates for platform other than GNU/Linux
* Reliability improvements
2017-05-22 - mpluskal@suse.com
- Add gpg signature
- Small spec file cleanup with spec-cleaner
- Trim dependencies
2017-02-22 - werner@suse.de
- Update to version 2.11
* Added support for catching stack overflow on Linux/SPARC.
* Provide a correct value for SIGSTKSZ on 64-bit AIX and on HP-UX. The one
defined by these systems is too small.
* Updated build infrastructure.
* Compilation now requires the <stdint.h> include file. Platforms which
don't have this include file (such as IRIX) are no longer supported.
* NOTE: Support for Cygwin and native Windows is currently not up-to-date.
- Update URL that is use https://www.gnu.org/software/libsigsegv/
2013-07-03 - schwab@suse.de
- fix-build-in-qemu.patch: Remove, set XFAIL_TESTS instead
- Reenable testsuite on armv7
2013-05-08 - werner@suse.de
- Update to version 2.10
- Adopt patch fix-build-in-qemu.patch
2012-01-31 - jengelh@medozas.de
- Remove redundant tags/sections per specfile guideline suggestions
- Parallel building using %_smp_mflags

See Also

Package Description
libsingularity1-2.6.1-3.1.i586.rpm Libraries for Singularity
libsingularity1-2.6.1-3.1.x86_64.rpm Libraries for Singularity
libskk-devel-1.2.0+git20171110+1.0.3-1.4.i586.rpm Development Files for libskk
libskk-devel-1.2.0+git20171110+1.0.3-1.4.x86_64.rpm Development Files for libskk
libskk0-1.2.0+git20171110+1.0.3-1.4.i586.rpm A statistical language model based Japanese input method engine
libskk0-1.2.0+git20171110+1.0.3-1.4.x86_64.rpm A statistical language model based Japanese input method engine
libskk0-32bit-1.2.0+git20171110+1.0.3-1.4.x86_64.rpm A statistical language model based Japanese input method engine
libslang2-2.3.1a-6.2.i586.rpm Programming Library and Embeddable Extension Language
libslang2-2.3.1a-6.2.x86_64.rpm Programming Library and Embeddable Extension Language
libslang2-32bit-2.3.1a-6.2.x86_64.rpm Programming Library and Embeddable Extension Language
libslopy7_4-7.4-1.2.i586.rpm Screen region selection library
libslopy7_4-7.4-1.2.x86_64.rpm Screen region selection library
libslurm33-18.08.5-2.1.i586.rpm Libraries for SLURM
libslurm33-18.08.5-2.1.x86_64.rpm Libraries for SLURM
libsmartcols-devel-2.33.1-2.1.i586.rpm Development files for libsmartcols
Advertisement
Advertisement