libshibsp8-3.0.4-2.1.x86_64.rpm


Advertisement

Description

libshibsp8 - Shared Library for Shibboleth

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libshibsp8-3.0.4-2.1.x86_64.rpm
Package name libshibsp8
Package version 3.0.4
Package release 2.1
Package architecture x86_64
Package type rpm
Category Productivity/Networking/Security
Homepage http://shibboleth.net/
License Apache-2.0
Maintainer -
Download size 728.49 KB
Installed size 2.83 MB
Shibboleth is a Web Single Sign-On implementations based on OpenSAML
that supports multiple protocols, federated identity, and the extensible
exchange of rich attributes subject to privacy controls.
This package contains just the shared library.

Alternatives

Package Version Architecture Repository
libshibsp8-3.0.4-2.1.i586.rpm 3.0.4 i586 openSUSE Oss
libshibsp8 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.15)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgssapi_krb5.so.2()(64bit) -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT)(64bit) -
liblog4shib.so.2()(64bit) -
libsaml.so.10()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libxerces-c-3.2.so()(64bit) -
libxml-security-c.so.20()(64bit) -
libxmltooling.so.8()(64bit) -

Provides

Name Value
libshibsp.so.8()(64bit) -
libshibsp8 = 3.0.4-2.1
libshibsp8(x86-64) = 3.0.4-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libshibsp8-3.0.4-2.1.x86_64.rpm
Source Package shibboleth-sp-3.0.4-2.1.src.rpm

Install Howto

Install libshibsp8 rpm package:

# zypper install libshibsp8

Files

Path
/usr/lib64/libshibsp.so.8
/usr/lib64/libshibsp.so.8.0.4

Changelog

2019-04-26 - mvetter@suse.com
- bsc#1130588: Require shadow instead of old pwdutils
2019-03-20 - Kristýna Streitová <kstreitova@suse.com>
- update to 3.0.4
* list of fixes and enhancements
https://issues.shibboleth.net/jira/browse/SSPCPP-851?filter=12771
- update xmltooling and opensaml versions in "Requires"
2019-02-11 - Jan Engelhardt <jengelh@inai.de>
- Trim redundancies from summary
2019-02-11 - kstreitova@suse.com
- update to 3.0.3
* list of fixes and enhancements
https://issues.shibboleth.net/jira/browse/SSPCPP-845?filter=12573
2018-11-28 - kstreitova@suse.com
- update to 3.0.2
* list of fixes and enhancements
https://wiki.shibboleth.net/confluence/display/SP3/ReleaseNotes
- remove shibboleth-sp-2.5.6-libsystemd-daemon.patch that is no
longer needed
- update package filelist
- change library soname from 7 to 8
- update dependencies versions
2017-11-15 - kstreitova@suse.com
- update to 2.6.1
* list of fixes and enhancements
https://issues.shibboleth.net/jira/browse/SSPCPP-760?filter=12270
* fixes [bsc#1068689] [CVE-2017-16852]
2017-09-21 - kstreitova@suse.com
- update to 2.6.0
* list of fixes and enhancements
https://issues.shibboleth.net/jira/browse/SSPCPP-716?filter=11475
- update soname for libshibsp from 6 to 7
- adjust BuildRequires of boost
* libboost_headers-devel for openSUSE:Factory
* boost-devel for older distros
- update versions of BuildRequires for opensaml (>= 2.6.0) and
libxmltooling (>= 1.6.0)
- shibd.service: increase TimeoutStartSec to 150s (as upstream did)
- remove %{_sysconfdir}/%{realname}/*.xsl from filelist (it is no
longer present)
- run spec-cleaner
2017-03-16 - kstreitova@suse.com
- fix build for openSUSE:Leap:42.1 by adding %define for
tmpfiles_create as this macro doesn't exist there
2017-02-14 - kstreitova@suse.com
- add shibboleth-sp-2.5.6-libsystemd-daemon.patch to fix configure
to use libsystemd instead of obsolete libsystemd-daemon.
Regenerate configure via autoreconf and add autoconf and automake
BuildRequires.
2016-07-19 - dimstar@opensuse.org
- Use %tmpfiles_create macro: gracefully fails in case of missing
binaries (e.g. container setups).

See Also

Package Description
libshine-devel-3.1.0-1.7.i586.rpm Development files for libshine, an MP3 encoding library
libshine-devel-3.1.0-1.7.x86_64.rpm Development files for libshine, an MP3 encoding library
libshine3-3.1.0-1.7.i586.rpm MP3 encoding library
libshine3-3.1.0-1.7.x86_64.rpm MP3 encoding library
libshout-devel-2.4.1-2.3.i586.rpm Development files for libshout, an Icecast communication library
libshout-devel-2.4.1-2.3.x86_64.rpm Development files for libshout, an Icecast communication library
libshout3-2.4.1-2.3.i586.rpm Library for communicating with Icecast servers
libshout3-2.4.1-2.3.x86_64.rpm Library for communicating with Icecast servers
libshout3-32bit-2.4.1-2.3.x86_64.rpm Library for communicating with Icecast servers
libshp-devel-1.5.0-1.1.i586.rpm Development Environment for shapelib
libshp-devel-1.5.0-1.1.x86_64.rpm Development Environment for shapelib
libshp2-1.5.0-1.1.i586.rpm Library for ESRI Shapefile Handling
libshp2-1.5.0-1.1.x86_64.rpm Library for ESRI Shapefile Handling
libsidplayfp-devel-1.8.7-1.6.i586.rpm Development files for libsidplayfp
libsidplayfp-devel-1.8.7-1.6.x86_64.rpm Development files for libsidplayfp
Advertisement
Advertisement