libsanlock1-3.7.1-1.1.i586.rpm


Advertisement

Description

libsanlock1 - A shared disk lock manager library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libsanlock1-3.7.1-1.1.i586.rpm
Package name libsanlock1
Package version 3.7.1
Package release 1.1
Package architecture i586
Package type rpm
Category Development/Libraries/C and C++
Homepage https://pagure.io/sanlock
License GPL-2.0-only AND GPL-2.0-or-later AND LGPL-2.1-or-later
Maintainer -
Download size 69.60 KB
Installed size 203.84 KB
The runtime libraries for sanlock, a shared disk lock manager.
Hosts connected to a common SAN can use this to synchronize their
access to the shared disks.

Alternatives

Package Version Architecture Repository
libsanlock1-3.7.1-1.1.x86_64.rpm 3.7.1 x86_64 openSUSE Oss
libsanlock1 - - -

Requires

Name Value
/sbin/ldconfig -
libaio.so.1 -
libaio.so.1(LIBAIO_0.1) -
libaio.so.1(LIBAIO_0.4) -
libblkid.so.1 -
libblkid.so.1(BLKID_2.15) -
libblkid.so.1(BLKID_2.17) -
libc.so.6(GLIBC_2.7) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -

Provides

Name Value
libsanlock.so.1 -
libsanlock1 = 3.7.1-1.1
libsanlock1(x86-32) = 3.7.1-1.1
libsanlock_client.so.1 -
libwdmd.so.1 -
sanlock-lib = 3.7.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libsanlock1-3.7.1-1.1.i586.rpm
Source Package sanlock-3.7.1-1.1.src.rpm

Install Howto

Install libsanlock1 rpm package:

# zypper install libsanlock1

Files

Path
/usr/lib/libsanlock.so.1
/usr/lib/libsanlock.so.1.0
/usr/lib/libsanlock_client.so.1
/usr/lib/libsanlock_client.so.1.0
/usr/lib/libwdmd.so.1
/usr/lib/libwdmd.so.1.0

Changelog

2019-04-09 - Jim Fehlig <jfehlig@suse.com>
- Update to sanlock 3.7.1
- Fix bugs in read_resource_owners
2019-03-21 - Jim Fehlig <jfehlig@suse.com>
- Update to sanlock 3.7.0
- Allow setting max_sectors_kb
- Configurable sector size and align size
- Support SANLOCK_RUN_DIR and SANLOCK_PRIVILEGED environment
variables
- Revert upstream commit forcing use of python2
revert-5d535c0d-py2.patch
- Dropped patches:
sanlock-old_blkid.patch, suse-fix-link-errors.patch
2018-03-26 - jfehlig@suse.com
- Fix module initialization to work with both python2 and python3
Updated sanlock-python3.patch
bsc#1076414
2018-03-21 - tchvatal@suse.com
- Add code to build with both python2 and python3 bindings with
provided condition so we can later on optionalize python2 builds
sanlock-python3.patch
bsc#1076414
2018-03-21 - tchvatal@suse.com
- Cleanup with spec-cleaner (only support SLE12 and newer)
- Add -fno-strict-aliasing to python subpkg
- Create rcsanlk-resetd link for the service control
2017-12-05 - jfehlig@suse.com
- Update to sanlock 3.6.0
- preserve dblock values when setting shared flag
- fix detection of shared lease
- fix release interference with paxos
- retry ballot when new lver is seen
- add a NOWAIT flag for convert
2017-11-23 - rbrown@suse.com
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)
2017-06-07 - jfehlig@suse.com
- Update to sanlock 3.5.0
- increase open file limit to 2048
- add option to log UTC timestamps
- doc improvements
- Remove support for old, non-systemd distros
2017-04-07 - jengelh@inai.de
- Remove redundant %if guards around %package and scriptlets.
They are only really needed for %files.
- Replace $RPM_ shell vars by modern macros.
- Trim descriptions a little.
2017-04-03 - jfehlig@suse.com
- spec: fix permissions on config files

See Also

Package Description
libsasl2-3-2.1.27-1.2.i586.rpm Simple Authentication and Security Layer (SASL) library
libsasl2-3-2.1.27-1.2.x86_64.rpm Simple Authentication and Security Layer (SASL) library
libsasl2-3-32bit-2.1.27-1.2.x86_64.rpm Simple Authentication and Security Layer (SASL) library
libsass-3_5_3-1-3.5.3-1.3.i586.rpm Compiler library for A CSS preprocessor language
libsass-3_5_3-1-3.5.3-1.3.x86_64.rpm Compiler library for A CSS preprocessor language
libsass-devel-3.5.3-1.3.i586.rpm Development files for libsass, a library for a CSS preprocessor language
libsass-devel-3.5.3-1.3.x86_64.rpm Development files for libsass, a library for a CSS preprocessor language
libsbc1-1.4-1.2.i586.rpm Bluetooth Low-Complexity, Sub-Band Codec Library
libsbc1-1.4-1.2.x86_64.rpm Bluetooth Low-Complexity, Sub-Band Codec Library
libsbc1-32bit-1.4-1.2.x86_64.rpm Bluetooth Low-Complexity, Sub-Band Codec Library
libsblim-cmpiutil1-1.0.1-24.12.i586.rpm Utility library for cmpi development
libsblim-cmpiutil1-1.0.1-24.12.x86_64.rpm Utility library for cmpi development
libscalapack2-gnu-mpich-hpc-2.0.2-11.2.i586.rpm Dependency package for libscalapack2_2_0_2-gnu-mpich-hpc
libscalapack2-gnu-mpich-hpc-2.0.2-11.2.x86_64.rpm Dependency package for libscalapack2_2_0_2-gnu-mpich-hpc
libscalapack2-gnu-mpich-hpc-devel-2.0.2-11.2.i586.rpm Dependency package for libscalapack2_2_0_2-gnu-mpich-hpc-devel
Advertisement
Advertisement