libqt5-qtstyleplugins-devel-5.0.0+git20170311-6.7.i586.rpm


Advertisement

Description

libqt5-qtstyleplugins-devel - Qt 5 Style Plugins Development Files

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libqt5-qtstyleplugins-devel-5.0.0+git20170311-6.7.i586.rpm
Package name libqt5-qtstyleplugins-devel
Package version 5.0.0+git20170311
Package release 6.7
Package architecture i586
Package type rpm
Category Development/Libraries/X11
Homepage https://qt.io/
License LGPL-2.1-with-Qt-Company-Qt-exception-1.1 or LGPL-3.0-only
Maintainer -
Download size 10.65 KB
Installed size 1.20 KB
You need this package, if you want to compile programs with qtstyleplugins.

Alternatives

Package Version Architecture Repository
libqt5-qtstyleplugins-devel-5.0.0+git20170311-28.15.x86_64.rpm 5.0.0+git20170311 x86_64 KDE 5
libqt5-qtstyleplugins-devel-5.0.0+git20170311-28.15.i586.rpm 5.0.0+git20170311 i586 KDE 5
libqt5-qtstyleplugins-devel-5.0.0+git20170311-6.7.x86_64.rpm 5.0.0+git20170311 x86_64 openSUSE Oss
libqt5-qtstyleplugins-devel-5.0.0+git20170311-ku.34.7.x86_64.rpm 5.0.0+git20170311 x86_64 KDE Unstable
libqt5-qtstyleplugins-devel-5.0.0+git20170311-ku.34.7.i586.rpm 5.0.0+git20170311 i586 KDE Unstable
libqt5-qtstyleplugins-devel - - -

Requires

Name Value
libqt5-qtstyleplugins = 5.0.0+git20170311
libqt5-qtstyleplugins-platformtheme-gtk2 = 5.0.0+git20170311

Provides

Name Value
libqt5-qtstyleplugins-devel = 5.0.0+git20170311-6.7
libqt5-qtstyleplugins-devel(x86-32) = 5.0.0+git20170311-6.7

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libqt5-qtstyleplugins-devel-5.0.0+git20170311-6.7.i586.rpm
Source Package libqt5-qtstyleplugins-5.0.0+git20170311-6.7.src.rpm

Install Howto

Install libqt5-qtstyleplugins-devel rpm package:

# zypper install libqt5-qtstyleplugins-devel

Files

Path
/usr/lib/cmake/Qt5Gui/Qt5Gui_QGtk2ThemePlugin.cmake
/usr/lib/cmake/Qt5Widgets/Qt5Widgets_QBB10StylePlugin.cmake
/usr/lib/cmake/Qt5Widgets/Qt5Widgets_QCleanlooksStylePlugin.cmake
/usr/lib/cmake/Qt5Widgets/Qt5Widgets_QGtk2StylePlugin.cmake
/usr/lib/cmake/Qt5Widgets/Qt5Widgets_QMotifStylePlugin.cmake
/usr/lib/cmake/Qt5Widgets/Qt5Widgets_QPlastiqueStylePlugin.cmake

Changelog

2018-03-13 - christophe@krop.fr
- Fix the license tag.
2017-12-11 - christophe@krop.fr
- Update the license tag (boo#967696)
2017-04-27 - sor.alexei@meowr.ru
- Update to version 5.0.0+git20170311 (changes since
5.0.0+git20170119):
* Plastique, Motif/CDE: Fix QSpinBox height in layout.
* Fix Plastique, Cleanlooks and Motif animation timer.
2017-01-24 - sor.alexei@meowr.ru
- Update to version 5.0.0+git20170119 (changes since
5.0.0+git20161215):
* Use Use QCommonStyle instead of QProxyStyle in QCleanlooksStyle
and QPlastiqueStyle: this allows to use correct colour
(non-white) for label text in a QComboBox. Also improves
progress bar drawing - now looks like in Qt4, the progress bar
content fills the entire groove vertically.
2016-12-15 - sor.alexei@meowr.ru
- Update to version 5.0.0+git20161215 (changes since
5.0.0+git20161024):
* Remove obsolete and unused QBB10StylePlugin::keys().
* Remove unused sync.profile.
* Fix building with Qt 5.8+.
- Remove 58.diff: fixed upstream.
2016-12-14 - hrvoje.senjan@gmail.com
- Bump to 5.7.1
* For more details please see:
https://blog.qt.io/blog/2016/12/14/qt-5-7-1-released/
and https://www.qt.io/qt5-7/
2016-11-28 - sor.alexei@meowr.ru
- Update to version 5.0.0+git20161024:
* Set plugin class name for styles.
- Remove libqt5-qtstyleplugins-class-names.patch: fixed upstream.
2016-11-28 - hrvoje.senjan@gmail.com
- Add 58.diff: private Qt platformsupport module got splited into
many pieces in 5.8. Use the appropriate module with Qt >= 5.8
2016-10-24 - sor.alexei@meowr.ru
- Update to version 5.0.0+git20161022 (changes since
5.0.0+git20161005):
* Remove usage of deprecated QStyleOption*V<N>.
* Add Q_DECL_OVERRIDE.
* Build the BB10 style only with Qt 5.7 or later.
- Remove the conflict with libqt5-qtbase-platformtheme-gtk3 in
libqt5-qtstyleplugins-platformtheme-gtk2: it causes the gtk2
platform theme to practically never get installed.
The reason for the conflict in the first place is overrated
anyway: in order to get a segfault, a user would have to manually
make an envvar "QT_STYLE_OVERRIDE=gtk2" with also having Gtk3
Platform Theme triggered ("QT_QPA_PLATFORMTHEME=gtk3").
2016-10-08 - sor.alexei@meowr.ru
- Initial package.

See Also

Package Description
libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-6.7.i586.rpm Qt 5 gtk2 plugin
libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-6.7.x86_64.rpm Qt 5 gtk2 plugin
libqt5-qtsvg-devel-32bit-5.12.3-1.1.x86_64.rpm Development files for the Qt5 SVG library
libqt5-qtsvg-devel-5.12.3-1.1.i586.rpm Development files for the Qt5 SVG library
libqt5-qtsvg-devel-5.12.3-1.1.x86_64.rpm Development files for the Qt5 SVG library
libqt5-qtsvg-examples-5.12.3-1.1.i586.rpm Qt5 SVG examples
libqt5-qtsvg-examples-5.12.3-1.1.x86_64.rpm Qt5 SVG examples
libqt5-qtsvg-private-headers-devel-5.12.3-1.1.noarch.rpm Non-ABI stable experimental API for the Qt5 SVG library
libqt5-qttools-32bit-5.12.3-1.1.x86_64.rpm Qt 5 QtTools Module
libqt5-qttools-5.12.3-1.1.i586.rpm Qt 5 QtTools Module
libqt5-qttools-5.12.3-1.1.x86_64.rpm Qt 5 QtTools Module
libqt5-qttools-devel-32bit-5.12.3-1.1.x86_64.rpm Development files for the Qt5 Tools library
libqt5-qttools-devel-5.12.3-1.1.i586.rpm Development files for the Qt5 Tools library
libqt5-qttools-devel-5.12.3-1.1.x86_64.rpm Development files for the Qt5 Tools library
libqt5-qttools-doc-5.12.3-1.1.i586.rpm Qt 5 tool used by Qt Developers to generate documentation
Advertisement
Advertisement