libqt5-qt3d-imports-5.12.3-1.1.x86_64.rpm


Advertisement

Description

libqt5-qt3d-imports - Qt 5 3D Library - QML imports

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libqt5-qt3d-imports-5.12.3-1.1.x86_64.rpm
Package name libqt5-qt3d-imports
Package version 5.12.3
Package release 1.1
Package architecture x86_64
Package type rpm
Category Development/Libraries/X11
Homepage https://www.qt.io
License LGPL-2.1-with-Qt-Company-Qt-exception-1.1 or LGPL-3.0-only
Maintainer -
Download size 156.32 KB
Installed size 1.19 MB
Qt is a set of libraries for developing applications.
This Qt 3D module contains functionality to support near-realtime
simulation systems.

Alternatives

Package Version Architecture Repository
libqt5-qt3d-imports-5.12.3-1.1.i586.rpm 5.12.3 i586 openSUSE Oss
libqt5-qt3d-imports-5.12.3-1.1.x86_64.rpm 5.12.3 x86_64 KDE 5
libqt5-qt3d-imports-5.12.3-1.1.i586.rpm 5.12.3 i586 KDE 5
libqt5-qt3d-imports-5.12.3-ku.1.1.x86_64.rpm 5.12.3 x86_64 KDE Unstable
libqt5-qt3d-imports-5.12.3-ku.1.1.i586.rpm 5.12.3 i586 KDE Unstable
libqt5-qt3d-imports - - -

Requires

Name Value
libQt53DAnimation.so.5()(64bit) -
libQt53DAnimation.so.5(Qt_5)(64bit) -
libQt53DCore.so.5()(64bit) -
libQt53DCore.so.5(Qt_5)(64bit) -
libQt53DExtras.so.5()(64bit) -
libQt53DExtras.so.5(Qt_5)(64bit) -
libQt53DInput.so.5()(64bit) -
libQt53DInput.so.5(Qt_5)(64bit) -
libQt53DLogic.so.5()(64bit) -
libQt53DLogic.so.5(Qt_5)(64bit) -
libQt53DQuick.so.5()(64bit) -
libQt53DQuick.so.5(Qt_5)(64bit) -
libQt53DQuickAnimation.so.5()(64bit) -
libQt53DQuickAnimation.so.5(Qt_5)(64bit) -
libQt53DQuickExtras.so.5()(64bit) -
libQt53DQuickExtras.so.5(Qt_5)(64bit) -
libQt53DQuickInput.so.5()(64bit) -
libQt53DQuickInput.so.5(Qt_5)(64bit) -
libQt53DQuickRender.so.5()(64bit) -
libQt53DQuickRender.so.5(Qt_5)(64bit) -
libQt53DQuickScene2D.so.5()(64bit) -
libQt53DQuickScene2D.so.5(Qt_5)(64bit) -
libQt53DRender.so.5()(64bit) -
libQt53DRender.so.5(Qt_5)(64bit) -
libQt5Core.so.5()(64bit) -
libQt5Core.so.5(Qt_5)(64bit) -
libQt5Core.so.5(Qt_5.12)(64bit) -
libQt5Gui.so.5()(64bit) -
libQt5Gui.so.5(Qt_5)(64bit) -
libQt5Qml.so.5()(64bit) -
libQt5Qml.so.5(Qt_5)(64bit) -
libQt5Quick.so.5()(64bit) -
libQt5Quick.so.5(Qt_5)(64bit) -
libQt5Quick.so.5(Qt_5.12.3_PRIVATE_API)(64bit) -
libQtQuick5 >= 5.12.3
libc.so.6(GLIBC_2.14)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libqt5-qt3d-imports = 5.12.3-1.1
libqt5-qt3d-imports(x86-64) = 5.12.3-1.1
libqtquickscene2dplugin.so()(64bit) -
libqtquickscene3dplugin.so()(64bit) -
libquick3danimationplugin.so()(64bit) -
libquick3dcoreplugin.so()(64bit) -
libquick3dextrasplugin.so()(64bit) -
libquick3dinputplugin.so()(64bit) -
libquick3dlogicplugin.so()(64bit) -
libquick3drenderplugin.so()(64bit) -

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libqt5-qt3d-imports-5.12.3-1.1.x86_64.rpm
Source Package libqt5-qt3d-5.12.3-1.1.src.rpm

Install Howto

Install libqt5-qt3d-imports rpm package:

# zypper install libqt5-qt3d-imports

Files

Path
/usr/lib64/qt5/qml/Qt3D/
/usr/lib64/qt5/qml/Qt3D/Animation/libquick3danimationplugin.so
/usr/lib64/qt5/qml/Qt3D/Animation/plugins.qmltypes
/usr/lib64/qt5/qml/Qt3D/Animation/qmldir
/usr/lib64/qt5/qml/Qt3D/Core/libquick3dcoreplugin.so
/usr/lib64/qt5/qml/Qt3D/Core/plugins.qmltypes
/usr/lib64/qt5/qml/Qt3D/Core/qmldir
/usr/lib64/qt5/qml/Qt3D/Extras/libquick3dextrasplugin.so
/usr/lib64/qt5/qml/Qt3D/Extras/plugins.qmltypes
/usr/lib64/qt5/qml/Qt3D/Extras/qmldir
/usr/lib64/qt5/qml/Qt3D/Input/libquick3dinputplugin.so
/usr/lib64/qt5/qml/Qt3D/Input/plugins.qmltypes
/usr/lib64/qt5/qml/Qt3D/Input/qmldir
/usr/lib64/qt5/qml/Qt3D/Logic/libquick3dlogicplugin.so
/usr/lib64/qt5/qml/Qt3D/Logic/plugins.qmltypes
/usr/lib64/qt5/qml/Qt3D/Logic/qmldir
/usr/lib64/qt5/qml/Qt3D/Render/libquick3drenderplugin.so
/usr/lib64/qt5/qml/Qt3D/Render/plugins.qmltypes
/usr/lib64/qt5/qml/Qt3D/Render/qmldir
/usr/lib64/qt5/qml/QtQuick/
/usr/lib64/qt5/qml/QtQuick/Scene2D/libqtquickscene2dplugin.so
/usr/lib64/qt5/qml/QtQuick/Scene2D/plugins.qmltypes
/usr/lib64/qt5/qml/QtQuick/Scene2D/qmldir
/usr/lib64/qt5/qml/QtQuick/Scene3D/libqtquickscene3dplugin.so
/usr/lib64/qt5/qml/QtQuick/Scene3D/plugins.qmltypes
/usr/lib64/qt5/qml/QtQuick/Scene3D/qmldir
/usr/share/doc/packages/libqt5-qt3d-imports/LICENSE.GPL
/usr/share/doc/packages/libqt5-qt3d-imports/LICENSE.GPL2
/usr/share/doc/packages/libqt5-qt3d-imports/LICENSE.GPL3
/usr/share/doc/packages/libqt5-qt3d-imports/LICENSE.GPL3-EXCEPT
/usr/share/doc/packages/libqt5-qt3d-imports/LICENSE.GPLv3
/usr/share/doc/packages/libqt5-qt3d-imports/LICENSE.LGPL3
/usr/share/doc/packages/libqt5-qt3d-imports/LICENSE.LGPLv3

Changelog

2019-04-18 - fabian@ritter-vogt.de
- Update to 5.12.3:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.3/?h=v5.12.3
2019-03-17 - wbauer@tmo.at
- Drop use-Assimp-namespace-to-fix-build-for-big-endian.patch,
merged upstream (since 5.11.0-beta1 already)
- Adjust filelist for Leap 42.3 to fix the build, assimp is only
compiled with gcc5 or higher now
2019-03-14 - fabian@ritter-vogt.de
- Update to 5.12.2:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.2/?h=5.12.2
2019-02-01 - fabian@ritter-vogt.de
- Update to 5.12.1:
* New bugfix release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.1/?h=v5.12.1
2018-12-06 - fabian@ritter-vogt.de
- Update to 5.12.0:
* New feature release
* For more details please see:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=v5.12.0
2018-12-03 - fabian@ritter-vogt.de
- Update to 5.12.0-rc2:
* New bugfix release
* Only important bugfixes
- Changelog for Qt 5.12.0:
* http://code.qt.io/cgit/qt/qt3d.git/plain/dist/changes-5.12.0/?h=5.12.0
2018-11-22 - fabian@ritter-vogt.de
- Update to 5.12.0-rc:
* New bugfix release
* No changelog available
2018-11-08 - fabian@ritter-vogt.de
- Update to 5.12.0-beta4:
* New bugfix release
* No changelog available
2018-10-26 - fabian@ritter-vogt.de
- Update to 5.12.0-beta3:
* New bugfix release
* No changelog available
2018-10-17 - fabian@ritter-vogt.de
- Update to 5.12.0-beta2:
* New bugfix release
* No changelog available

See Also

Package Description
libqt5-qt3d-private-headers-devel-5.12.3-1.1.noarch.rpm Non-ABI stable experimental API for the Qt5 3D library
libqt5-qt3d-tools-5.12.3-1.1.i586.rpm Qt5 3D tools
libqt5-qt3d-tools-5.12.3-1.1.x86_64.rpm Qt5 3D tools
libqt5-qtbase-common-devel-5.12.3-1.1.i586.rpm Qt 5 Core Development Binaries
libqt5-qtbase-common-devel-5.12.3-1.1.x86_64.rpm Qt 5 Core Development Binaries
libqt5-qtbase-devel-5.12.3-1.1.i586.rpm Development files for the Qt5 base library
libqt5-qtbase-devel-5.12.3-1.1.x86_64.rpm Development files for the Qt5 base library
libqt5-qtbase-examples-32bit-5.12.3-1.1.x86_64.rpm Qt5 base examples
libqt5-qtbase-examples-5.12.3-1.1.i586.rpm Qt5 base examples
libqt5-qtbase-examples-5.12.3-1.1.x86_64.rpm Qt5 base examples
libqt5-qtbase-platformtheme-gtk3-5.12.3-1.1.i586.rpm Qt 5 gtk3 plugin
libqt5-qtbase-platformtheme-gtk3-5.12.3-1.1.x86_64.rpm Qt 5 gtk3 plugin
libqt5-qtbase-platformtheme-xdgdesktopportal-5.12.3-1.1.i586.rpm Qt 5 XDG Desktop Portal Plugin
libqt5-qtbase-platformtheme-xdgdesktopportal-5.12.3-1.1.x86_64.rpm Qt 5 XDG Desktop Portal Plugin
libqt5-qtbase-private-headers-devel-5.12.3-1.1.noarch.rpm Non-ABI stable experimental API
Advertisement
Advertisement