libqb20-1.0.3+20190326.a521604-1.1.x86_64.rpm


Advertisement

Description

libqb20 - An IPC library for high performance servers

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libqb20-1.0.3+20190326.a521604-1.1.x86_64.rpm
Package name libqb20
Package version 1.0.3+20190326.a521604
Package release 1.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://github.com/ClusterLabs/libqb
License LGPL-2.1-or-later
Maintainer -
Download size 79.88 KB
Installed size 176.05 KB
libqb is a library providing high performance client server reusable
features. It provides logging, tracing, IPC, and polling.

Alternatives

Package Version Architecture Repository
libqb20-1.0.3+20190326.a521604-1.1.i586.rpm 1.0.3+20190326.a521604 i586 openSUSE Oss
libqb20 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.17)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -

Provides

Name Value
libqb.so.20()(64bit) -
libqb20 = 1.0.3+20190326.a521604-1.1
libqb20(x86-64) = 1.0.3+20190326.a521604-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libqb20-1.0.3+20190326.a521604-1.1.x86_64.rpm
Source Package libqb-1.0.3+20190326.a521604-1.1.src.rpm

Install Howto

Install libqb20 rpm package:

# zypper install libqb20

Files

Path
/usr/lib64/libqb.so.20
/usr/lib64/libqb.so.20.0.0
/usr/share/doc/packages/libqb20/COPYING

Changelog

2019-04-02 - Jan Engelhardt <jengelh@inai.de>
- Drop manual requires from libqb-tests.
- Let libqb-devel depend on the exact package, libqb20 not just
a virtual libqb provide.
- Drop redundant %if..%endif guards that do not affect the build.
2019-04-02 - Yan Gao <ygao@suse.com>
- Update to version 1.0.3+20190326.a521604:
- enable building / shipping of libqb-tests.rpm (bsc#1131328)
2019-02-07 - ygao@suse.com
- spec: libqb-tools conflicts with libqb0 <= 1.0.3
2019-01-29 - ygao@suse.com
- spec: libqb20 provides libqb-%{version}-%{release}
- spec: add missing COPYING in libqb20 package
2019-01-29 - Jan Engelhardt <jengelh@inai.de>
- Trim filler wording from descriptions. Remove unnecesary
pkgconfig Requires (automatically discovered).
- Split non-library parts of libqb20 into libqb-tools.
2019-01-24 - ygao@suse.com
- Update to version 1.0.3+20190115.c880fcf:
- Add Pthreads (and possibly other) flags to the pkg-config file (#332)
- skiplist: Fix previous skiplist fix
2018-11-12 - ygao@suse.com
- Update to version 1.0.3+20181112.926e851:
- log: Remove more dead code from linker callsites (#331) (bsc#1074327, bsc#1098449)
- Add the option of hi-res (millisecond) timestamps (#329)
- log: Add configure-time option to use systemd journal instead of syslog (#327)
- log: Add option to re-open a log file (#326)
- skiplist: fix use-after-free in the skiplist traversal
2018-10-01 - ygao@suse.com
- Update to version 1.0.3+20180927.633f262:
- logging: Remove linker 'magic' and just use statics for logging callsites (#322) (bsc#1074327, bsc#1098449)
- log: Use RTLD_NOOPEN when checking symbols (#310)
- low customisable log line length (#292)
- ipc_shm: Don't truncate SHM files of an active server (#307)
2018-01-02 - ygao@suse.com
- Update to version 1.0.3+20171226.6d62b64:
- build: fix configure script neglecting, re-enable out-of-tree builds
2017-12-22 - ygao@suse.com
- Update to version 1.0.3
- warnings cleanup: fix initialiser warning
- warnings cleanup: Wformat: sign-correct PRIu32 specifiers as appropriate
- warnings cleanup: Wsign-compare: log_format: int32_t -> size_t
- warnings cleanup: Wsign-compare: hdb: uint32_t <-> int32_t
- warnings cleanup: Wsign-compare: array: int32_t -> size_t
- warnings cleanup: hdb+loop_timerlist: Wsign-compare: (canary?) variables
- warnings cleanup: Wshift-overflow: trigger arithmetic conv. to unsigned
- Upstream version cs: 28dff090c74b6ba8609c4797294a5afe3fe73987 (v1.0.3)

See Also

Package Description
libqb20-32bit-1.0.3+20190326.a521604-1.1.x86_64.rpm An IPC library for high performance servers
libqca-qt5-2.2.1-1.1.i586.rpm Qt Cryptographic Architecture 2
libqca-qt5-2.2.1-1.1.x86_64.rpm Qt Cryptographic Architecture 2
libqca-qt5-32bit-2.2.1-1.1.x86_64.rpm Qt Cryptographic Architecture 2
libqca-qt5-devel-2.2.1-1.1.i586.rpm Development files for the Qt Cryptographic Architecture 2
libqca-qt5-devel-2.2.1-1.1.x86_64.rpm Development files for the Qt Cryptographic Architecture 2
libqca-qt5-devel-32bit-2.2.1-1.1.x86_64.rpm Development files for the Qt Cryptographic Architecture 2
libqca-qt5-plugins-2.2.1-1.1.i586.rpm Various plugins for the Qt Cryptographic Architecture 2
libqca-qt5-plugins-2.2.1-1.1.x86_64.rpm Various plugins for the Qt Cryptographic Architecture 2
libqca-qt5-plugins-32bit-2.2.1-1.1.x86_64.rpm Various plugins for the Qt Cryptographic Architecture 2
libqca2-2.2.1-1.1.i586.rpm Qt Cryptographic Architecture 2
libqca2-2.2.1-1.1.x86_64.rpm Qt Cryptographic Architecture 2
libqca2-32bit-2.2.1-1.1.x86_64.rpm Qt Cryptographic Architecture 2
libqca2-devel-2.2.1-1.1.i586.rpm Development files for the Qt Cryptographic Architecture 2
libqca2-devel-2.2.1-1.1.x86_64.rpm Development files for the Qt Cryptographic Architecture 2
Advertisement
Advertisement