libpulse0-12.2-5.1.x86_64.rpm


Advertisement

Description

libpulse0 - Client interface to PulseAudio

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libpulse0-12.2-5.1.x86_64.rpm
Package name libpulse0
Package version 12.2
Package release 5.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage http://pulseaudio.org
License GPL-2.0+ AND LGPL-2.1+
Maintainer -
Download size 283.21 KB
Installed size 940.16 KB
pulseaudio is a networked sound server for Linux and other Unix like
operating systems and Microsoft Windows. It is intended to be an
improved drop-in replacement for the Enlightened Sound Daemon (ESOUND).
This package contains the system libraries for clients of pulseaudio
sound server.

Alternatives

Package Version Architecture Repository
libpulse0-12.2-11.1.x86_64.rpm 12.2 x86_64 Multimedia Libs
libpulse0-12.2-11.1.i586.rpm 12.2 i586 Multimedia Libs
libpulse0-12.2-5.1.i586.rpm 12.2 i586 openSUSE Oss
libpulse0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.27)(64bit) -
libdbus-1.so.3()(64bit) -
libdbus-1.so.3(LIBDBUS_1_3)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.15)(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.4)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libsndfile.so.1()(64bit) -
libsndfile.so.1(libsndfile.so.1.0)(64bit) -
libsystemd.so.0()(64bit) -
libsystemd.so.0(LIBSYSTEMD_209)(64bit) -
libxcb.so.1()(64bit) -

Provides

Name Value
config(libpulse0) = 12.2-5.1
libpulse-simple.so.0()(64bit) -
libpulse-simple.so.0(PULSE_0)(64bit) -
libpulse.so.0()(64bit) -
libpulse.so.0(PULSE_0)(64bit) -
libpulse0 = 12.2-5.1
libpulse0(x86-64) = 12.2-5.1
libpulsecommon-12.2.so()(64bit) -
pulseaudio-libs = 12.2

Obsoletes

Name Value
pulseaudio-libs < 12.2

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libpulse0-12.2-5.1.x86_64.rpm
Source Package pulseaudio-12.2-5.1.src.rpm

Install Howto

Install libpulse0 rpm package:

# zypper install libpulse0

Files

Path
/etc/pulse/client.conf
/etc/pulse/client.conf.d/
/usr/lib64/libpulse-simple.so.0
/usr/lib64/libpulse-simple.so.0.1.1
/usr/lib64/libpulse.so.0
/usr/lib64/libpulse.so.0.20.3
/usr/lib64/pulseaudio/libpulsecommon-12.2.so
/usr/share/doc/packages/libpulse0/GPL
/usr/share/doc/packages/libpulse0/LGPL
/usr/share/doc/packages/libpulse0/LICENSE
/usr/share/doc/packages/libpulse0/README

Changelog

2019-04-26 - mvetter@suse.com
- bsc#1130588: Require shadow instead of old pwdutils
2019-04-24 - Martin Li?ka <mliska@suse.cz>
- Disable LTO (boo#1133278).
2019-04-21 - tiwai@suse.de
- Fix the UCM module build due to the removal of alsa/* include
path (bsc#1132880):
updated pulseaudio-alsa.patch
2019-03-27 - Jan Engelhardt <jengelh@inai.de>
- Remove one redundant Requires: systemd, and add
BuildRequires: systemd-rpm-macros.
2019-03-26 - olaf@aepfle.de
- Use alsa API properly. Consumers are expected to use
<alsa/asoundlib.h> instead of <asoundlib.h>.
This is in preparation of an change to pkgconfig(alsa) to
not pollute CFLAGS with -I/usr/include/alsa anymore (bsc#1130333)
pulseaudio-alsa.patch
2019-01-30 - alarrosa@suse.com
- Make /var/lib/gdm %ghost again in pulseaudio-gdm-hooks so we don't
create the directory when installing the package. gdm was just
changed to create that directory as %ghost too to keep both
packages in sync.
- Add /var/lib/pulseaudio (which is already created by systemd-tmpfiles)
as %ghost so users can easily query who created the directory,
it gets uninstalled on package removal and rpmlint doesn't complain
about it.
2019-01-15 - tiwai@suse.de
- Enable systemd user socket for activating PA (bsc#1083473)
- Disable auto-spawn along with the change above
2018-11-18 - tiwai@suse.de
- Drop ghost from gdm hook dir to sync with gdm package itself
2018-11-15 - tiwai@suse.de
- Fix setup-pulseaudio script to deal with the new alsa/conf.d
setup that was introduced since alsa-lib 1.1.7 (bsc#1116153)
2018-10-19 - Antonio Larrosa <alarrosa@suse.com>
- Add a Supplements line to pulseaudio-gdm-hooks so it's selected
for installation when gdm and pulseaudio are installed.

See Also

Package Description
libpulse0-32bit-12.2-5.1.x86_64.rpm Client interface to PulseAudio
libpurple-2.13.0-5.4.i586.rpm GLib-based Instant Messenger Library
libpurple-2.13.0-5.4.x86_64.rpm GLib-based Instant Messenger Library
libpurple-branding-openSUSE-42.2-1.7.noarch.rpm GLib-based Instant Messenger Library -- openSUSE Default Configuration
libpurple-branding-upstream-2.13.0-5.4.noarch.rpm GLib-based Instant Messenger Library -- Upstream default configuration
libpurple-devel-2.13.0-5.4.i586.rpm Development Headers, Documentation, and Libraries for libpurple
libpurple-devel-2.13.0-5.4.x86_64.rpm Development Headers, Documentation, and Libraries for libpurple
libpurple-lang-2.13.0-5.4.noarch.rpm Translations for package pidgin
libpurple-plugin-bot-sentry-1.3.0-2.6.i586.rpm Libpurple plugin to prevent Instant Message spam
libpurple-plugin-bot-sentry-1.3.0-2.6.x86_64.rpm Libpurple plugin to prevent Instant Message spam
libpurple-plugin-bot-sentry-lang-1.3.0-2.6.noarch.rpm Translations for package purple-bot-sentry
libpurple-plugin-carbons-0.2.2-1.1.i586.rpm Experimental XEP-0280: Message Carbons plugin for libpurple
libpurple-plugin-carbons-0.2.2-1.1.x86_64.rpm Experimental XEP-0280: Message Carbons plugin for libpurple
libpurple-plugin-facebook-0.9.6-1.2.i586.rpm Facebook protocol plugin for libpurple
libpurple-plugin-facebook-0.9.6-1.2.x86_64.rpm Facebook protocol plugin for libpurple
Advertisement
Advertisement