libpowerman0-2.3.24-6.4.x86_64.rpm


Advertisement

Description

libpowerman0 - Libraries for applications using PowerMan

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libpowerman0-2.3.24-6.4.x86_64.rpm
Package name libpowerman0
Package version 2.3.24
Package release 6.4
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://github.com/chaos/powerman
License GPL-2.0+
Maintainer -
Download size 14.76 KB
Installed size 18.17 KB
A shared library for applications using PowerMan.

Alternatives

Package Version Architecture Repository
libpowerman0-2.3.24-45.18.x86_64.rpm 2.3.24 x86_64 Hardware
libpowerman0-2.3.24-45.18.i586.rpm 2.3.24 i586 Hardware
libpowerman0-2.3.24-6.4.i586.rpm 2.3.24 i586 openSUSE Oss
libpowerman0 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.14)(64bit) -

Provides

Name Value
libpowerman.so.0()(64bit) -
libpowerman0 = 2.3.24-6.4
libpowerman0(x86-64) = 2.3.24-6.4

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libpowerman0-2.3.24-6.4.x86_64.rpm
Source Package powerman-2.3.24-6.4.src.rpm

Install Howto

Install libpowerman0 rpm package:

# zypper install libpowerman0

Files

Path
/usr/lib64/libpowerman.so.0
/usr/lib64/libpowerman.so.0.0.0

Changelog

2018-04-25 - eich@suse.com
- For SLE-12 set user/group to daemon/root for backward
compatibility.
2017-08-15 - eich@suse.com
- Minor specfile cosmetics:
* Simplified the entry for %{_sysconfdir}/powerman.
2017-08-11 - eich@suse.com
- This package should not provide the user/group powerman
as it is the only user of this group: powermand runs as
this user/group and writes its data as this user/group.
This gives the sysadmin some control over who to give
access. There is no other application requiring this
user/group.
2017-08-11 - eich@suse.com
- run systemd-tmpfiles --create ... before starting service (bsc#1053481).
2017-06-15 - jjolly@suse.com
- powerman service configured to start as powerman:powerman user
- Fixed autoconf files to allow for dynamic user and group in
powerman.service file
- service-dynamic-user-autofiles.patch
- Updated configure file with only necessary changes from
autoconf changes
- service-dynamic-user-configure.patch
- Added %config to /etc/powerman/*.dev files
2017-04-02 - meissner@suse.com
- prequire daemon user for new factory userhandling
2017-02-15 - eich@suse.com
- Create /usr/lib/tmpfiles.d/powerman.conf:
Add systemd handling for temporary directory /var/run/powerman.
2017-01-04 - eich@suse.com
- Added support for snmp, tcpwrappers and genders to be compatible
with the powerman package from openHPC.community (latter one is
currently disabled).
To use tcpwrappers, they need to be enabled in /etc/powerman/powerman.conf
- the default is 'off'.
- Don't create /run/powerman - systemd will do this for us.
2015-11-13 - mpluskal@suse.com
- Update to 2.3.24
* Don't package /var/run/powerman; let systemd manage it
[TOSS-2987]
* Cleanup: drop trailing whitespace
- Changes for 2.3.23
* Build: silence CC lines, fix AC_LANG_CONFTEST warnings, fix
$(EXEEXT) warnings.
* Build: install System V init scripts if
- -with-systemdsystemunitdir is not configured and include both
in EXTRA_DIST.
* Build: re-enable 'make check' unit tests.
* Build: fix some 'make distcheck' issues, but until unit tests
are fixed to find *.exp and *.conf files in $(srcdir), this will still fail.
* RPM: configure genders, httppower, snmppower, and tcp-wrappers
unconditionally; update URL.
- Cleanups spec file with spec-cleaner
- Drop powerman.service and use bundled one
2015-03-12 - p.drouand@gmail.com
- Update to version 2.3.20
* add dist tag to release (TOSS-2667)
* Minor automake updates
- Move to systemd
- Remove unneeded patchs
* powerman-piddir.patch
* powerman-runlevel.patch
- Update project and download Urls; project has moved to github
- Some cleanup

See Also

Package Description
libpq5-11.2-1.1.i586.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-11.2-1.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpq5-32bit-11.2-1.1.x86_64.rpm Shared Libraries Required for PostgreSQL Clients
libpqos-devel-3.0.1-2.1.i586.rpm Development package for libpqos3
libpqos-devel-3.0.1-2.1.x86_64.rpm Development package for libpqos3
libpqos3-3.0.1-2.1.i586.rpm Runtime pqos library
libpqos3-3.0.1-2.1.x86_64.rpm Runtime pqos library
libpqxx-5_0-5.0.1-3.1.i586.rpm C++ Client Library for PostgreSQL
libpqxx-5_0-5.0.1-3.1.x86_64.rpm C++ Client Library for PostgreSQL
libpqxx-devel-5.0.1-3.1.i586.rpm C++ Client Library for PostgreSQL
libpqxx-devel-5.0.1-3.1.x86_64.rpm C++ Client Library for PostgreSQL
libpqxx-doc-5.0.1-3.1.noarch.rpm Documentation for libpqxx
libprelude-devel-5.0.0-1.1.i586.rpm Development files for libprelude
libprelude-devel-5.0.0-1.1.x86_64.rpm Development files for libprelude
libprelude-devel-bindings-5.0.0-1.1.i586.rpm Development files for libprelude
Advertisement
Advertisement