libpolkit-qt-1-1-0.112.0-1.9.x86_64.rpm


Advertisement

Description

libpolkit-qt-1-1 - PolicyKit Library Qt Bindings

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libpolkit-qt-1-1-0.112.0-1.9.x86_64.rpm
Package name libpolkit-qt-1-1
Package version 0.112.0
Package release 1.9
Package architecture x86_64
Package type rpm
Category Development/Libraries/KDE
Homepage http://api.kde.org/kdesupport-api/kdesupport-apidocs/polkit-qt/html/
License LGPL-2.1+
Maintainer -
Download size 59.07 KB
Installed size 204.75 KB
Polkit-qt aims to make it easy for Qt developers to take advantage of
PolicyKit API. It is a convenience wrapper around QAction and
QAbstractButton that lets you integrate those two components easily
with PolicyKit.

Alternatives

Package Version Architecture Repository
libpolkit-qt-1-1-0.112.0-1.9.i586.rpm 0.112.0 i586 openSUSE Oss
libpolkit-qt-1-1 - - -

Requires

Name Value
/sbin/ldconfig -
libQtCore.so.4()(64bit) -
libQtDBus.so.4()(64bit) -
libQtGui.so.4()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libpolkit-agent-1.so.0()(64bit) -
libpolkit-gobject-1.so.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -

Provides

Name Value
libpolkit-qt-1-1 = 0.112.0-1.9
libpolkit-qt-1-1(x86-64) = 0.112.0-1.9
libpolkit-qt-agent-1.so.1()(64bit) -
libpolkit-qt-core-1.so.1()(64bit) -
libpolkit-qt-gui-1.so.1()(64bit) -
libpolkit-qt0 = 0.9.3

Obsoletes

Name Value
libpolkit-qt0 < 0.9.3

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libpolkit-qt-1-1-0.112.0-1.9.x86_64.rpm
Source Package polkit-qt-1-0.112.0-1.9.src.rpm

Install Howto

Install libpolkit-qt-1-1 rpm package:

# zypper install libpolkit-qt-1-1

Files

Path
/usr/lib64/libpolkit-qt-agent-1.so.1
/usr/lib64/libpolkit-qt-agent-1.so.1.112.0
/usr/lib64/libpolkit-qt-core-1.so.1
/usr/lib64/libpolkit-qt-core-1.so.1.112.0
/usr/lib64/libpolkit-qt-gui-1.so.1
/usr/lib64/libpolkit-qt-gui-1.so.1.112.0

Changelog

2015-06-19 - tittiatcoke@gmail.com
- Update to version 0.112.0
* Qt5 support
* Update deprecated methods to latest Polkit API
- Qt4 and Qt5 versions are now aligned.
- Drop patches merged upstream:
* fixed-reference-counting-of-GObjects.patch,
* fixed-GCancellable-handling-in-PolkitQtListener.patch
- Added do-not-use-global-static-systembus-instance.patch from
upstream, fixes crash on DBus disconnect
2013-07-16 - hrvoje.senjan@gmail.com
- Update to 0.103.0
* Bugfix release, contains previously included patches
- Droped ck-avoid-crash.diff and d3c337da.patch, included in this
release
- Added fixed-GCancellable-handling-in-PolkitQtListener.patch and
fixed-reference-counting-of-GObjects.patch from upstream
(kde#257802, kde#286935, kde#291977, kde#307323, kde#270489)
2011-12-12 - idonmez@suse.com
- Add git commit d3c337da to fix kde#258916
2011-08-11 - toddrme2178@gmail.com
- Removed self-obsoletes (fix for RPMLINT warning)
- Cleaned up spec file formatting
2011-06-28 - lnussel@suse.de
- devel package must depend on polkit-devel nowadays
2011-06-10 - dmueller@suse.de
- fix crash when ConsoleKit is unavailable
2011-04-18 - ro@suse.de
- fix baselibs.conf
2010-12-18 - tittiatcoke@gmail.com
- Change the specfile to build according openSUSE standards
2010-12-17 - tittiatcoke@gmail.com
- Enable build for 11.2 and 11.3 in compatibility mode. 0.99.1 has
became a requirement for KDE 4.6
2010-12-09 - tittiatcoke@gmail.com
- update to 0.99.1
- Introduction of a compatibility mode for older PolicyKit version

See Also

Package Description
libpolkit-qt-1-1-32bit-0.112.0-1.9.x86_64.rpm PolicyKit Library Qt Bindings
libpolkit-qt-1-devel-0.112.0-1.9.i586.rpm PolicyKit Library Qt Bindings
libpolkit-qt-1-devel-0.112.0-1.9.x86_64.rpm PolicyKit Library Qt Bindings
libpolkit-qt5-1-1-0.112.0-4.14.i586.rpm PolicyKit Library Qt Bindings
libpolkit-qt5-1-1-0.112.0-4.14.x86_64.rpm PolicyKit Library Qt Bindings
libpolkit-qt5-1-1-32bit-0.112.0-4.14.x86_64.rpm PolicyKit Library Qt Bindings
libpolkit-qt5-1-devel-0.112.0-4.14.i586.rpm PolicyKit Library Qt Bindings
libpolkit-qt5-1-devel-0.112.0-4.14.x86_64.rpm PolicyKit Library Qt Bindings
libpolkit-qt5-1-devel-32bit-0.112.0-4.14.x86_64.rpm PolicyKit Library Qt Bindings
libpolkit0-0.115-4.1.i586.rpm PolicyKit Authorization Framework -- Libraries
libpolkit0-0.115-4.1.x86_64.rpm PolicyKit Authorization Framework -- Libraries
libpolkit0-32bit-0.115-4.1.x86_64.rpm PolicyKit Authorization Framework -- Libraries
libpoppler-cpp0-0.72.0-1.3.i586.rpm C++ API of the Poppler PDF rendering library
libpoppler-cpp0-0.72.0-1.3.x86_64.rpm C++ API of the Poppler PDF rendering library
libpoppler-cpp0-32bit-0.72.0-1.3.x86_64.rpm C++ API of the Poppler PDF rendering library
Advertisement
Advertisement