libpipewire-0_2-1-0.2.5-2.1.x86_64.rpm


Advertisement

Description

libpipewire-0_2-1 - A Multimedia Framework designed to be an audio and video server and more

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libpipewire-0_2-1-0.2.5-2.1.x86_64.rpm
Package name libpipewire-0_2-1
Package version 0.2.5
Package release 2.1
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage https://pipewire.org/
License LGPL-2.1-or-later
Maintainer -
Download size 89.94 KB
Installed size 235.61 KB
PipeWire is a server and user space API to deal with multimedia pipelines.
Some of its features include:
* Capture and playback of audio and video with minimal latency;
* Real-time Multimedia processing on audio and video;
* Multiprocess architecture to let applications share multimedia content;
* GStreamer plugins for easy use and integration in current applications;
* Sandboxed applications support.
This package provides the PipeWire shared library.

Alternatives

Package Version Architecture Repository
libpipewire-0_2-1-0.2.5-28.1.x86_64.rpm 0.2.5 x86_64 GNOME Next
libpipewire-0_2-1-0.2.5-28.1.i586.rpm 0.2.5 i586 GNOME Next
libpipewire-0_2-1-0.2.5-13.1.x86_64.rpm 0.2.5 x86_64 GNOME Factory
libpipewire-0_2-1-0.2.5-13.1.i586.rpm 0.2.5 i586 GNOME Factory
libpipewire-0_2-1-0.2.5-2.1.i586.rpm 0.2.5 i586 openSUSE Oss
libpipewire-0_2-1 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.28)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.3.3)(64bit) -

Provides

Name Value
libpipewire-0.2.so.1()(64bit) -
libpipewire-0_2-1 = 0.2.5-2.1
libpipewire-0_2-1(x86-64) = 0.2.5-2.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libpipewire-0_2-1-0.2.5-2.1.x86_64.rpm
Source Package pipewire-0.2.5-2.1.src.rpm

Install Howto

Install libpipewire-0_2-1 rpm package:

# zypper install libpipewire-0_2-1

Files

Path
/usr/lib64/libpipewire-0.2.so.1
/usr/lib64/libpipewire-0.2.so.1.205.0

Changelog

2019-04-19 - Fabian Vogt <fabian@ritter-vogt.de>
- Add patch to fix use of headers from C++:
* avoid-invalid-conversion-error-with-C++.patch
2019-02-21 - bjorn.lie@gmail.com
- Update to version 0.2.5:
+ Build fixes for systemd.
+ Add cursor and bitmap metadata. This can be used to send a
cursor sprite with the video stream.
+ Permissions were set too strict for non-flatpak clients.
+ Fix crash in loop caused by thread unsafe hook emission.
+ Add more error checking for thread-loop.
+ Small cleanups and bugfixes.
- Drop libspa define and add spa_ver define, and following this
drop libspa-lib1 subpackage, no longer built.
- Drop doxygen BuildRequires and manpages source, follow upstream
in not building docs nor manually installing manpages that have
to be updated every version bump to ensure they are current.
- Add pkgconfig(libsystemd) BuildRequires: New dependency.
- Update options passed to meson following upstream changes.
2018-08-13 - bjorn.lie@gmail.com
- Update to version 0.2.2:
+ Add apiversion to pkgconfig as well.
- Add apiver define and set it to 0.2.
- Bump libpipewire define to libpipewire-0_2-1 and libspa define to
libspa-lib1 following upstream changes.
2018-07-23 - bjorn.lie@gmail.com
- Update to version 0.2.1:
+ stream: update to latest API.
+ hook: add private data for future expansion.
2018-07-17 - alarrosa@suse.com
- Update to version 0.2.0
* No changelog provided by upstream. To see the changes in this
version, please browse the commit logs at
https://github.com/PipeWire/pipewire/commits/0.2.0 .
2018-03-13 - luc14n0@linuxmail.org
- Initial package, version 0.1.9.

See Also

Package Description
libpisock-devel-0.12.5-25.22.i586.rpm PalmPilot Development Header Files
libpisock-devel-0.12.5-25.22.x86_64.rpm PalmPilot Development Header Files
libpisock9-0.12.5-25.22.i586.rpm Pilot-Link Library for Palm devices
libpisock9-0.12.5-25.22.x86_64.rpm Pilot-Link Library for Palm devices
libpisync-devel-0.12.5-25.22.i586.rpm Pilot-Link based Synchronization Library for Palm devices
libpisync-devel-0.12.5-25.22.x86_64.rpm Pilot-Link based Synchronization Library for Palm devices
libpisync1-0.12.5-25.22.i586.rpm Pilot-Link based Synchronization Library for Palm devices
libpisync1-0.12.5-25.22.x86_64.rpm Pilot-Link based Synchronization Library for Palm devices
libpixman-1-0-0.36.0-1.2.i586.rpm Pixel manipulation library
libpixman-1-0-0.36.0-1.2.x86_64.rpm Pixel manipulation library
libpixman-1-0-32bit-0.36.0-1.2.x86_64.rpm Pixel manipulation library
libpixman-1-0-devel-0.36.0-1.2.i586.rpm Development files for the Pixel Manipulation library
libpixman-1-0-devel-0.36.0-1.2.x86_64.rpm Development files for the Pixel Manipulation library
libpkcs11-helper1-1.25.1-1.1.i586.rpm Helper Library for the Use with Smart Cards and the PKCS#11 API
libpkcs11-helper1-1.25.1-1.1.x86_64.rpm Helper Library for the Use with Smart Cards and the PKCS#11 API
Advertisement
Advertisement