libphobos2-ldc85-1.15.0-1.1.i586.rpm


Advertisement

Description

libphobos2-ldc85 - The D standard library

Property Value
Distribution openSUSE Tumbleweed
Repository openSUSE Oss all
Package filename libphobos2-ldc85-1.15.0-1.1.i586.rpm
Package name libphobos2-ldc85
Package version 1.15.0
Package release 1.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage https://wiki.dlang.org/LDC
License BSD-3-Clause AND Artistic-1.0
Maintainer -
Download size 1.74 MB
Installed size 10.76 MB
This package includes ldc's phobos library - The D standard library.

Alternatives

Package Version Architecture Repository
libphobos2-ldc85-1.15.0-1.1.x86_64.rpm 1.15.0 x86_64 openSUSE Oss
libphobos2-ldc85 - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libc.so.6(GLIBC_2.28) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libdruntime-ldc-debug-shared.so.85 -
libdruntime-ldc-shared.so.85 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -

Provides

Name Value
libphobos2-ldc-debug-shared.so.85 -
libphobos2-ldc-shared.so.85 -
libphobos2-ldc85 = 1.15.0-1.1
libphobos2-ldc85(x86-32) = 1.15.0-1.1

Download

Type URL
Mirror widehat.opensuse.org
Binary Package libphobos2-ldc85-1.15.0-1.1.i586.rpm
Source Package ldc-1.15.0-1.1.src.rpm

Install Howto

Install libphobos2-ldc85 rpm package:

# zypper install libphobos2-ldc85

Files

Path
/usr/lib/libphobos2-ldc-debug-shared.so.2.0.85
/usr/lib/libphobos2-ldc-debug-shared.so.85
/usr/lib/libphobos2-ldc-shared.so.2.0.85
/usr/lib/libphobos2-ldc-shared.so.85

Changelog

2019-04-20 - Matthias Eliasson <elimat@opensuse.org>
- Update to 1.15.0
* Big news
- Frontend, druntime and Phobos are at version 2.085.1, incl. new
command-line options -preview, -revert, -checkaction=context,
- verrors-context and -extern-std. (#3003, #3039, #3053) (new)
+ The Objective-C improvements from DMD 2.085 are not implemented
(#3007)
- Support for LLVM 8.0. The prebuilt packages have been upgraded to
LLVM 8.0.0 and include the Khronos SPIRV-LLVM-Translator, so that
dcompute can now emit OpenCL too. (#3005)
- Compiler memory requirements can now be reduced via the new -lowmem
switch, which enables the garbage collector for the front-end and
sacrifices compile times for less required memory. In some cases, the
overall max process memory can be reduced by more than 60%; see #2916
(comment) for some numbers. (#2916)
+ Note for package maintainers: this feature requires a recent D host
compiler (most notably, it doesn't work with ltsmaster), ideally
LDC 1.15 itself due to important GC memory overhead improvements in
2.085 druntime.
- Support for generic @llvmAttr("name") parameter UDAs, incl. new
@restrict with C-like semantics. (#3043) (new)
- macOS: 32-bit support was dropped in the sense of not being CI-tested
anymore and the prebuilt macOS package now containing x86_64 libraries
only. MACOSX_DEPLOYMENT_TARGET for the prebuilt package has been raised
from 10.8 to 10.9.
- Prebuilt packages don't depend on libtinfo and libedit anymore.
(#1827, #3019)
- x86: SSSE3 isn't required for the prebuilt packages and generated
optimized binaries anymore. (#3045) (new)
* Platform support
- Supports LLVM 3.9 - 8.0.
* Bug fixes
- Implicit cross-module-inlining of functions annotated with
pragma(inline, true) without explicit -enable-cross-module-inlining has
been restored. (#2552, #3014)
- Propagate well-known length of newly allocated dynamic arrays for
better optimizability. (#3041, #3042) (new)
- JIT: Support implicit __chkstk calls for Windows targets, e.g., for
large stack allocations. (#3051) (new)
- Update so_version to 85
2019-01-25 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Requires binutils.gold as ldc uses ld.gold by default since version 1.13.0
2019-01-21 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Enable bootstrap again for all flavours, otherwise ldc will require old
.so file instead of new one
- Use ldc 1.12.0 as intermediate build on 32-bit, due to upstream bug:
* https://github.com/ldc-developers/ldc/issues/2947
2019-01-10 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Remove wrong requires to 'ldc-utils' as there is no such package
2018-12-18 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Disable bootstrap in Tumbleweed and Leap 15+ as it is bootstrapped already
and to workaround https://github.com/ldc-developers/ldc/issues/2947
2018-12-18 - Guillaume GARDET <guillaume.gardet@opensuse.org>
- Add bash-completion sub-package

See Also

Package Description
libphodav-2_0-0-2.3-1.1.i586.rpm A library for file sharing with WebDAV
libphodav-2_0-0-2.3-1.1.x86_64.rpm A library for file sharing with WebDAV
libphonon4-32bit-4.10.2-1.1.x86_64.rpm Phonon Multimedia Platform Abstraction
libphonon4-4.10.2-1.1.i586.rpm Phonon Multimedia Platform Abstraction
libphonon4-4.10.2-1.1.x86_64.rpm Phonon Multimedia Platform Abstraction
libphonon4qt5-32bit-4.10.2-1.1.x86_64.rpm Phonon Multimedia Platform Abstraction
libphonon4qt5-4.10.2-1.1.i586.rpm Phonon Multimedia Platform Abstraction
libphonon4qt5-4.10.2-1.1.x86_64.rpm Phonon Multimedia Platform Abstraction
libphysfs-devel-3.0.1-1.1.i586.rpm Libraries, includes and more to develop PhysicsFS applications
libphysfs-devel-3.0.1-1.1.x86_64.rpm Libraries, includes and more to develop PhysicsFS applications
libphysfs1-3.0.1-1.1.i586.rpm PhysicsFS file abstraction layer for games
libphysfs1-3.0.1-1.1.x86_64.rpm PhysicsFS file abstraction layer for games
libpinyin-data-2.3.0-1.1.i586.rpm Data files for the libpinyin IME
libpinyin-data-2.3.0-1.1.x86_64.rpm Data files for the libpinyin IME
libpinyin-devel-2.3.0-1.1.i586.rpm Development files for the libpinyin IME
Advertisement
Advertisement